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Legal disclaimer
Alibaba Cloud reminds you to carefully read and fully understand the terms and 
conditions of this legal disclaimer before you read or use this document. If you have 
read or used this document, it shall be deemed as your total acceptance of this legal 
disclaimer.
1. You shall download and obtain this document from the Alibaba Cloud website

 or other Alibaba Cloud-authorized channels, and use this document for your 
own legal business activities only. The content of this document is considered
 confidential information of Alibaba Cloud. You shall strictly abide by the 
confidentiality obligations. No part of this document shall be disclosed or provided
 to any third party for use without the prior written consent of Alibaba Cloud.

2. No part of this document shall be excerpted, translated, reproduced, transmitted, 
or disseminated by any organization, company, or individual in any form or by any 
means without the prior written consent of Alibaba Cloud.

3. The content of this document may be changed due to product version upgrades
, adjustments, or other reasons. Alibaba Cloud reserves the right to modify 
the content of this document without notice and the updated versions of this
 document will be occasionally released through Alibaba Cloud-authorized 
channels. You shall pay attention to the version changes of this document as they 
occur and download and obtain the most up-to-date version of this document from 
Alibaba Cloud-authorized channels.

4. This document serves only as a reference guide for your use of Alibaba Cloud 
products and services. Alibaba Cloud provides the document in the context that
 Alibaba Cloud products and services are provided on an "as is", "with all faults
" and "as available" basis. Alibaba Cloud makes every effort to provide relevant
 operational guidance based on existing technologies. However, Alibaba Cloud 
hereby makes a clear statement that it in no way guarantees the accuracy, integrity
, applicability, and reliability of the content of this document, either explicitly 
or implicitly. Alibaba Cloud shall not bear any liability for any errors or financial
 losses incurred by any organizations, companies, or individuals arising from 
their download, use, or trust in this document. Alibaba Cloud shall not, under any
 circumstances, bear responsibility for any indirect, consequential, exemplary, 
incidental, special, or punitive damages, including lost profits arising from the use
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 or trust in this document, even if Alibaba Cloud has been notified of the possibility
 of such a loss.

5. By law, all the content of the Alibaba Cloud website, including but not limited to 
works, products, images, archives, information, materials, website architecture, 
website graphic layout, and webpage design, are intellectual property of Alibaba
 Cloud and/or its affiliates. This intellectual property includes, but is not limited
 to, trademark rights, patent rights, copyrights, and trade secrets. No part of the
 Alibaba Cloud website, product programs, or content shall be used, modified
, reproduced, publicly transmitted, changed, disseminated, distributed, or 
published without the prior written consent of Alibaba Cloud and/or its affiliates
. The names owned by Alibaba Cloud shall not be used, published, or reproduced 
for marketing, advertising, promotion, or other purposes without the prior written
 consent of Alibaba Cloud. The names owned by Alibaba Cloud include, but are 
not limited to, "Alibaba Cloud", "Aliyun", "HiChina", and other brands of Alibaba 
Cloud and/or its affiliates, which appear separately or in combination, as well as
 the auxiliary signs and patterns of the preceding brands, or anything similar to 
the company names, trade names, trademarks, product or service names, domain
 names, patterns, logos, marks, signs, or special descriptions that third parties 
identify as Alibaba Cloud and/or its affiliates).

6. Please contact Alibaba Cloud directly if you discover any errors in this document.
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Generic conventions
Table -1: Style conventions
Style Description Example

This warning information 
indicates a situation that will 
cause major system changes, 
faults, physical injuries, and other
 adverse results.

Danger:
Resetting will result in the loss of
user configuration data.

This warning information 
indicates a situation that may 
cause major system changes, 
faults, physical injuries, and other
 adverse results.

Warning:
Restarting will cause business
interruption. About 10 minutes are
required to restore business.

This indicates warning informatio
n, supplementary instructions, 
and other content that the user 
must understand.

Notice:
Take the necessary precautions
to save exported data containing
sensitive information.

This indicates supplemental 
instructions, best practices, tips, 
and other content that is good to 
know for the user.

Note:
You can use Ctrl + A to select all
files.

> Multi-level menu cascade. Settings > Network > Set network
type

Bold It is used for buttons, menus
, page names, and other UI 
elements.

Click OK.

Courier
 font

It is used for commands. Run the cd  / d  C :/ windows
 command to enter the Windows

system folder.
Italics It is used for parameters and 

variables.
bae  log  list  --
instanceid  Instance_ID

[] or [a|b] It indicates that it is a optional 
value, and only one item can be 
selected.

ipconfig  [-all|-t]
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Style Description Example
{} or {a|b} It indicates that it is a required 

value, and only one item can be 
selected.

swich  {stand | slave}
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1 Organization management
1.1 Manage the organization
1.1.1 Basic concepts about organization management

Organization management is a feature provided by Quick BI Pro and Quick BI
Enterprise Standard that allows you to develop data collaboratively with other
members in the organization. Quick BI Pro and Quick BI Enterprise Standard are
officially released. Users can upgrade Quick BI Basic to a higher Quick BI version in
the Quick BI console. The system automatically creates an organization for you after
the upgrade.

What is an organization?
Generally, organizations refer to small and medium-sized enterprises (SMEs), public 
institutions, schools, or departments of large companies.
If your organization values data security highly and data analysis needs to be
performed collaboratively by more than 10 members, we recommend that you
purchase Quick BI Pro. Quick BI Pro brings the following benefits:
• Members have different access permissions to reports based on the departments 

that they belong to.
• Members have different access permissions to a report based on their roles.
We recommend that you use Quick BI Basic if the number of users is fewer than 10.
Organization member management refers to adding Alibaba Cloud users that need to 
work collaboratively into the same organization.
Organization management includes:
• Managing organizational information
• Managing member information
• Managing workspaces
Only administrators of an organization have permissions to manage the members of 
the organization. The creator of an organization is set as an administrator by default.
The roles of members in an organization include administrator and user.
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1.1.2 Modify the information of an organization
Administrators of an organization can modify the information of an organization.

Context
Procedure

1. Log on to the Quick BI console.
2. Select Settings > Organization > Basics.

3. Modify the information of the organization manually as shown in the following
figure.

4. Click Save to complete the modifying of the information of the organization.
1.1.3 Add, search, edit, and remove members

You can add a member to an organization by adding an Alibaba Cloud account or
RAM user. You can use the import members function to add multiple members to an
organization. You can also search for or remove members.

Add a member
Add an Alibaba Cloud account
1. Log on to the Quick BI console.
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2. Choose Settings > Organization > Members.
3. Click Add Member as shown in the following figure:

4. On the Add Member page, click the Tenant Account tab.

Note:
Make sure that you enter an account ID. An account ID is a numeric string.

5. Enter the Alibaba Cloud account and an alias for the member. You can select Set
As Admin to specify the member as an administrator, as shown in the following
figure:

6. Click OK to add the member.
Add a RAM user
1. Log on to the Quick BI console.
2. Choose Settings > Organization > Members > Add Member.
3. Click the RAM User tab.
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4. Enter the Alibaba Cloud account, the RAM user, and an alias. You can select Set
As Admin to specify the member as an administrator, as shown in the following
figure:

Note:
Make sure that you enter an account ID. An account ID is a numeric string.
For RAM users, enter the RAM username in "RAM username@Default domain
or enterprise alias.onaliyun.com". For example, if your RAM user account is
zhangsan@.test.onaliyun.com, enter zhangsan.

5. Click OK to add the member.
Import members
1. Log on to the Quick BI console.
2. Choose Settings > Organization > Members.
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3. Click Import Members, as shown in the following figure:

4. Click Upload Excel to upload a list of members from the local disk, as shown in the
following figure:

5. Click OK to import the members.
Search members

You can search for members by alias or Alibaba Cloud account.
1. Log on to the Quick BI console.
2. Choose Settings > Organization > Members.
3. Enter an alias or Alibaba Cloud account into the search bar, as shown in the

following figure:

4. Click the Search icon to search for the member.
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Edit a member
Administrators can edit the information of members.
1. Log on to the Quick BI console.
2. Choose Settings > Organization > Members.
3. Select a member, and click Edit in the Actions column.

4. You can edit the alias of the member, and choose whether to specify the member as
an administrator by setting the Set as Admin option.

5. Click OK to submit the changes.
Remove a member

Administrators can remove members. The remove operation is irreversible. Use with
caution. To rejoin an organization, you must contact an administrator to add you to
the organization as a member.
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1. Log on to the Quick BI console.
2. Choose Settings > Organization > Members.
3. Select a member, and click Remove in the Actions column.

Note:
If the member is in a workspace, the system prompts the following error message:

You cannot remove a user who is a member of a group workspace. For more
information about removing a member from a workspace, see #unique_8/
unique_8_Connect_42_section_qgp_tzq_pgb.

4. Click OK to remove the member.
1.1.4 View the workspaces that a member belongs to

You can view the workspaces that a member belongs to by clicking the corresponding
Workspace icon.

Context
A blue icon indicates that the member belongs to at least one workspace. A grey icon 
indicates that the member does not belong to any workspaces.

Procedure
1. Log on to the Quick BI console.
2. Choose Settings > Org Units > Members.
3. Select a member and click the Workspace icon (blue) in the Workspace column.
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4. View the workspaces that the member belongs to as shown in the following figure.

5. Click OK to close the dialog box.
1.1.5 Tags

Member tags are used to set dataset row-level permissions. This topic describes
how to manage member tags. For more information about the row-level permission
setting, see #unique_11.

Add a tag
You can use the import members function to add tags, as shown in the following
figure:

Click Download Template to download the member template. In this example, the
member information is as follows:
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Note:
For members that do not need the row-level permission setting, set their tags to $
ALL_MEMBERS$.

Manage tags
You can manage tags as shown in the following figure:

Edit a tag
1. Select a member that you need to set the row-level permission for, and click Edit 

Member Tags.
2. On the edit member tags page, enter the tag values, and then click OK, as shown in

the following figure:

1.1.6 Create a user group
Members in an organization may belong to different departments, such as the sales,
operations, and technology departments. They may also have different roles, such
as analysts, project managers, and project directors. You can create multiple user
groups for these members. A member can be added to multiple user groups. You
can then grant these user groups the access permission to datasets and BI portals as
needed.
1. Log on to the Quick BI console.
2. Choose Settings > Organization > User Groups.
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3. On the user groups page, click the Add Child Group icon.

4. On the child group page, enter a group name and then click OK.

After creating the child group, you can click Add User to add users to this group.

1.2 Manage workspaces
1.2.1 Concepts

In Quick BI Basic, a user's workspace is called personal space. In Quick BI Pro and
 Enterprise Standard, a user's workspace is divided into personal space and group 
space.

What is a group space?
A group space is a workspace where organization unit members collaborate on 
development. In a group space, group members can collaborate to create and modify
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 data sources, cubes, worksheets, dashboards, and data portals based on their roles
. These data objects exist in the group space they belong to. Different group spaces 
have different data objects.
In group space management, the organizational unit administrator adds members 
in the organizational unit to different group spaces based on their work scope and 
responsibilities.
Group spaces can correspond to actual business departments of the organizational
 unit. For example, administrators can create workspaces for the sales department 
and the HR department of the organization and then add the employees as members 
to the corresponding workspaces.
Workspaces are similar to DingTalk groups. For example, employees can share 
information and communicate with each other through the DingTalk group that is 
corresponding to the department that they belong to.

Manage workspaces
A group space is managed by the group space administrator. Members of a workspace
 are appointed to be administrators by the administrator of the organization that 
creates the workspace. Administrators of a workspace have permission to set other 
members in the workspace to be administrators.
Workspace management includes:
• Creating a workspace
• Modifying a workspace
• Setting a default workspace

Differences between a personal space and a group space
Main differences between a personal space and a group space are as follows:
• A personal workspace is created automatically after the first logon. A workspace is 

created manually by an administrator of the organization.
• The personal space cannot be deleted, and a new personal space cannot be created

.
• You are not allowed to add other members to a personal workspace. Therefore, a 

personal workspace does not support collaboration or transfer.
• Workspaces can be transferred to users in a group space, and can be shared with 

users in an organization. Personal spaces can be shared with Alibaba Cloud users.
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1.2.2 Create a workspace
You can perform the following steps to create a workspace.

Procedure
1. Log on to the Quick BI console.
2. Choose Settings > Workspaces.
3. Click Create Workspace as shown in the following figure.

4. In the Name field, enter a name for the workspace as shown in the following figure.

5. Click OK to complete the creating of the workspace.
1.2.3 Modify the information of a workspace

Only the owner of a personal workspace is allowed to modify the information of the
personal workspace. Oppositely, only the administrators of a workspace are allowed
to modify the information of the workspace.

Procedure
1. Log on to the Quick BI console.
2. Choose Settings > Workspaces.
3. Click the Settings tab to jump to the Settings tab page.
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4. Click Edit Workspace as shown in the following figure.

5. Click OK to finish the modification.
1.2.4 Set a default workspace

When a member is added to an organization, the member is added to the default
workspace.

Procedure
1. Log on to the Quick BI console.
2. Choose Settings > Workspaces.
3. Hover your mouse over a workspace. Click Set as Default as shown in the following

figure.

After you do that, the Default button is displayed in the Default column. Click the
button to cancel the operation of setting the workspace as a default one.

1.2.5 Transfer a workspace
Before leaving an organization, the owner of a workspace can transfer the workspace
to another member of the organization. The new owner can be any member, not
required to be an administrator.

Procedure
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1. Log on to the Quick BI console.
2. Choose Settings > Workspaces.
3. Click Transfer in the Actions column for the workspace to transfer as shown in the

following figure.

4. Click the drop-down arrow and select a new owner of the workspace by the
nickname as shown in the following figure.

5. Click OK to complete the transferring of the workspace.
1.2.6 Leave a workspace

You can perform the following steps to leave a workspace.
Procedure

1. Log on to the Quick BI console.
2. Choose Settings > Workspaces.
3. Click the Settings tab to jump to the settings tab page.
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4. Click Leave Workspace as shown in the following figure.

5. Click the drop-down arrow to select a new owner of your data objects by the
nickname.

6. Click OK to leave the workspace.
1.2.7 Workspace member overview

You need to assign a role to the member after you add it to a workspace . Roles have
different permissions. Each member can be assigned a maximum of one role.
Roles include Space Manager, Developer, Analyst, and Viewer.

Mappings for roles and permissions
Mappings for roles and permissions are fixed and not modifiable. To grant permission
to the member of a workspace, you only need to specify the role for the member.

Note:
The classic workbook feature is in beta and will not be supported in future versions.
A classic workbook does not support custom grouping fields, data type conversions,
dataset joins based on snowflake schemas, and joins for databases from different
data sources.

Table 1-1: Function navigation entry
Permission Developer Analyst Viewer
Datasets/Data 
sources

Supported Not supported Yes
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Permission Developer Analyst Viewer
Classic Workbooks/
Workbooks

Supported Supported Supported

Dashboards Supported Supported Supported
BI Portals Supported Supported Supported

Table 1-2: Datasets/Data sources
Permission Developer Analyst Viewer
Create data sources Supported Not supported Not supported
Modify data sources Only modifying 

own data sources is
 supported

Not supported Not supported

Delete data sources Only deleting own
 data sources is 
supported

Not supported Not supported

Use data sources Supported Not supported Not supported
Create datasets Supported Not supported Not supported
Modify datasets Only modifying 

own datasets is 
supported

Not supported Not supported

Delete Datasets Only deleting 
own datasets is 
supported

Not supported Not supported

Use datasets Supported Supported Not supported
Table 1-3: Classic workbooks
Permission Developer Analyst Viewer
Create classic 
workbooks

Supported Supported Not supported

Modify classic 
workbooks

Only modifying
 own classic 
workbooks is 
supported

Only modifying
 own classic 
workbooks is 
supported

Not supported
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Permission Developer Analyst Viewer
Delete classic 
workbooks

Only deleting own 
classic workbooks 
is supported

Only deleting own 
classic workbooks 
is supported

Not supported

View classic 
workbooks

Supported Supported Supported

Share classic 
workbooks

Only sharing own 
classic workbooks 
is supported

Only sharing own 
classic workbooks 
is supported

Not supported

Reference classic 
workbooks

Supported Supported Not supported

Table 1-4: Workbooks
Permission Developer Analyst Viewer
Create workbooks Supported Supported Not supported
Modify workbooks Only modifying 

own workbooks is 
supported

Only modifying 
own workbooks is 
supported

Not supported

Delete workbooks Only deleting own
 workbooks is 
supported

Only deleting own
 workbooks is 
supported

Not supported

View workbooks Supported Supported Supported
Share workbooks Only sharing own

 workbooks is 
supported

Only sharing own
 workbooks is 
supported

Not supported

Reference 
workbooks

Supported Supported Not supported

Table 1-5: Dashboards
Permission Developer Analyst Viewer
Create dashboards Supported Supported Not supported
Modify dashboards Only modifying 

own dashboards is 
supported

Only modifying 
own dashboards is 
supported

Not supported
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Permission Developer Analyst Viewer
Delete dashboards Only deleting own

 dashboards is 
supported

Only deleting own
 dashboards is 
supported

Not supported

View dashboards Supported Supported Supported
Share dashboards Only sharing own

 dashboards is 
supported

Only sharing own
 dashboards is 
supported

Not supported

Reference 
dashboards

Supported Supported Not supported

Publish dashboards Only publishing 
own dashboards is 
supported

Only publishing 
own dashboards is 
supported

Not supported

Table 1-6: BI portals
Permission Developer Analyst Viewer
Create BI portals Supported Supported Not supported
Modify BI portals Only modifying 

own BI portals is 
supported

Only modifying 
own BI portals is 
supported

Not supported

Delete BI portals Only deleting 
own BI portals is 
supported

Only deleting 
own BI portals is 
supported

Not supported

View BI portals Supported Supported Supported
Share BI portals Only sharing 

own BI portals is 
supported

Only sharing 
own BI portals is 
supported

Not supported

1.2.8 Add, edit, search, and delete workspace members
On the workspaces page, you can add, edit, search, and delete workspace members.
To perform these actions, you must first go to the workspaces page.

Go to the workspaces page
1. Log on to the Quick BI console.
2. Click Settings > Workspaces in the upper-right corner of the page.
3. Click the Members tab to show the Members tab page.
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Add members to a workspace
1. On the workspaces page, click the workspace that you want to add members to.
2. Click the Members tab, and then click Add Members on the members tab page, as

shown in the following figure:

3. Search members by alias and select a role for the members, as shown in the
following figure:

4. Click OK to add the members.
Modify the member role

1. On the workspaces page, click the workspace that the member belongs to.
2. Click the Members tab, and click Edit in the Actions column for the target member.
3. Change the role of the member.

Different roles are granted different permissions. For more information, see
#unique_22.

4. Click OK to submit the change.
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Search members
1. On the workspaces page, click a workspace to search members.
2. Click the Members tab, enter an alias into the search box on the members tab page.

3. Click the Search icon to search for the member.
Delete a member

1. On the workspaces page, click the workspace that the target member belongs to.
2. Click the Members tab, and click Delete in the Actions column for the target

member.
3. Select a new owner from the drop-down list. Items under the member to be deleted

 will be transferred to the new owner.
4. Click OK to delete the member.
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2 Data modeling
2.1 Overview of data modeling

Data modeling is used to visualize data and allows you to quickly identify and extract
information. Furthermore, it helps you to make correct decisions based on the trend
represented by the data.
The basic process of data modeling is shown in the following figure.

1. Add data sources: a required step. Operations on datasets, workbooks, dashboards,
and portals are all based on data sources. For more information about data
sources, see Data sources management overview.
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2. Create datasets: a required step. You can create a dataset by using any one of the
following three methods:
• Tables in a data source: You can create dashboards and workbooks based on

datasets. For more information about operations on datasets, see Datasets
management overview.

• Local files: You can only create datasets based on local files in Personal
Workspace. You can create datasets based on CSV files uploaded from your local
disk. For more information about operations on CSV files, see Upload local files.

• Custom SQL queries: You can create datasets based on custom SQL queries in
MaxCompute. For more information about operations on custom SQL queries,
see SQL overview.

2.2 Data source management
2.2.1 Manage data sources

Quick BI supports the following types of data sources.
Cloud data sources

• MaxCompute
• MySQL
• SQL Server
• AnalyticDB
• HybridDB for MySQL
• HybridDB for PostgreSQL
• PostgreSQL
• PPAS
• Hive (Quick BI Enterprise Standard)
• Data Lake Analytics (Quick BI Enterprise Standard and Pro）
• OSS (Quick BI Enterprise Standard)
• DRDS (Quick BI Enterprise Standard)

User-created data sources
• MySQL
• SQL Server
• Oracle
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• PostgreSQL
• Hive (Quick BI Enterprise Standard)
• Vertica (Quick BI Enterprise Standard)
• IBM DB2 LUW (Quick BI Enterprise Standard)
• SAP IQ (Sybase IQ) (Quick BI Enterprise Standard)
• SAP HANA (Quick BI Enterprise Standard)

User space
• CSV files
• Excel files
• Data IDE
Local files are uploaded and stored in the user space. Only Quick BI provides user 
spaces. Currently, each user has a user space of 1 GB.

Network requirements for data sources
Quick BI has the following network requirements for data sources.
1. Quick BI can connect to RDS instances in a VPC by using public IP addresses. 

MySQL and SQL Server instances can be connected by using private IP addresses.
2. Quick BI can connect to instances in a classic network by using both public and

private IP addresses. When Quick BI connects to RDS instances by using public IP
addresses, set a whitelist of IP addresses that are allowed to access RDS instances
in the RDS console. For more information, see Set a whitelist.

3. Quick BI can be accessed on the public network.
4. Quick BI can connect to user-created MySQL and SQL Server databases on ECS 

instances in a VPC by using private IP addresses.
More operations

For more operations on data sources, see:
• #unique_30
• #unique_31
• #unique_27
• #unique_32
• #unique_33
• #unique_34
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• #unique_35
2.2.2 Create cloud data sources

Operations on datasets, workbooks, dashboards, and BI portals are based on data
sources. This topic describes how to create a cloud data source.
You need to go to the Add Data Source page before adding a cloud data source.
1. Log on to the Quick BI console.
2. Click Data Sources to go to the Data Sources page.
3. Click Create Data Source.
4. Click the Cloud Data Sources tab.

MaxCompute
1. Click the MaxCompute icon.
2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the default address is displayed. For modification, see

#unique_37.

Note:
The database address is based on the region where the database instance is
deployed. For example, if you choose a classic network as the network type for
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your database instance that is deployed in the Hong Kong region, the database
address is http://service.cn-hongkong.maxcompute.aliyun-inc.com/api. If the
database instance is deployed in the Asia Pacific SE 1 (Singapore) region, the
database address is http://service.ap-southeast-1.maxcompute.aliyun-inc.com/
api. For more information, see #unique_37.

• Project: the project name.
• AccessKey ID: the AccessKey ID.
• AccessKey Secret: the AccessKey Secret.

Note:
Make sure that the AccessKey is valid. The corresponding account is an
administrator of the project, the owner of the project, or a user that has List,
Select, and CreateInstance permissions.

3. Click Test Connection to perform a data source connectivity test.

Note:
If the connection is successful, a message that indicates success is displayed.

4. Click Add to add the data source.
After the data source is added, the Data Sources page is redirected automatically.
All tables that are contained in the data source are listed in the right section.
MaxCompute data sources use asynchronous loading. Creating a MaxCompute data
 source takes one to five minutes to synchronize data.

MySQL
You need to add IP addresses or security groups to the whitelist of the RDS instance in
 the ApsaraDB for RDS console before you add an RDS data source.
For more information, see Set a whitelist.
1. Click the MySQL icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Username: the database username.
• Password: the database password.
Contact the administrator of your data warehouse if you forget the username and 
password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

If a data source with the same configurations exists, a message that indicates 
conflict is displayed. You do not need to create the same data source again.

SQL Server
Adding an RDS (SQL Server) data source is similar to adding an RDS (MySQL) data
source. However, you need to specify the Schema configuration item for an RDS (SQL
Server) data source. The default port number for an SQL Server data source is 1433.
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1. Click the SQL Server icon.
2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Schema: the database schema. The default schema is dbo.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

AnalyticDB
1. Click the AnalyticDB icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Access ID: the AccessKey ID.
• Access Key: the AccessKey Secret.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

HybridDB for MySQL
Adding a HybridDB for MySQL data source is similar to adding a MySQL data source.
1. Click the HybridDB for MySQL icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number. The default port number is 3306.
• Database: the database name.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

HybirdDB for PostgreSQL
Adding a HybridDB for PostgreSQL data source is similar to adding a SQL Server data 
source. The default port number for a HybridDB for PostgreSQL database is displayed
.
1. Click the HybridDB for PostgreSQL icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

PostgreSQL
1. Click the PostgreSQL icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

PPAS
Adding a PPAS data source is similar to adding a PostgreSQL data source.
1. Click the PPAS icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

Hive (Quick BI Enterprise Standard)
If you use Quick BI Enterprise Standard, you can add a Hive data source.
1. Click the Hive icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

Data Lake Analytics (Quick BI Pro and Quick BI Enterprise Standard)
If you use Quick BI Enterprise Standard or Quick BI Pro, you can add a Data Lake
Analytics data source.
1. Click the Data Lake Analytics icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port: 10000
• Database: the database name.
• Access ID: the AccessKey ID.
• Access Key: the AccessKey Secret.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

DRDS
If you use Quick BI Enterprise Standard, you can add a DRDS data source.
1. Click the DRDS icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or the hostname of the database.
• Port Number: the port number.
• Database: the name of a database that you connect to.
• Username: the database username.
• Password: the database password.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

2.2.3 Create a user-created data source
This topic describes how to create a user-created data source. You can access all data
sources that are created in Quick BI Enterprise Standard by using SSH tunnels.

MySQL
1. Log on to the Quick BI console.
2. Click Data Sources to go to the Data Sources page.
3. Choose Create Data Source > User-created Data Sources > MySQL
4. Enter the fields for connecting to the data source as shown in the following figure.

Note:
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Select ECS (VPC) User-created Data Source and enter the required fields when you
connect to an ECS (VPC) user-created data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 3306.
• Database: the database name.
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• Username: the database username.
• Password: the database password.
• AccessKey ID: the AccessKey ID for the account that purchased the ECS instance

 for housing the database.
• AccessKey Secret: the AccessKey Secret.
• Instance ID: the ECS instance ID.
• ECS Instance Region: the region location ID of the ECS instance.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

5. Click Test Connection to perform a data source connectivity test.
6. Click Add to add the data source.
You need to remove the firewall of the user-created database for allowing users to 
access MySQL through the Internet.
1. Run the following command to open the configuration file for the firewall.

vi  / etc / sysconfig / iptables

2. Add the following command to the configuration file.
- A  RH - Firewall - 1 - INPUT  - m  state  – state  NEW  - m  
tcp  - p  tcp  – dport  3306  - j
            ACCEPT

3. Restart iptables.
service  iptables  restart

SQL Server
1. Click the SQL Server icon.
2. Enter the fields for connecting to the data source as shown in the following figure.

Note:
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Select ECS (VPC) User-created Data Source and enter the required fields when you
connect to an ECS (VPC) user-created data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 1433.
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• Database: the database name.
• Schema: the database schema. The default schema is dbo.
• Username: the database username.
• Password: the database password.
• AccessKey ID: the AccessKey ID for the account that purchased the ECS instance

 for housing the database.
• AccessKey Secret: the AccessKey Secret.
• Instance ID: the ECS instance ID.
• ECS Instance Region: the region location ID of the ECS instance.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

PostgreSQL
1. Click the PostgreSQL icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 5432.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
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• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

Note:
After you select ssh, interactive query services that are provided by MaxCompute
Lightning are supported.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.

Oracle
1. Click the Oracle icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 1521.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
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4. Click Add to add the data source.
Hive (Quick BI Enterprise Standard)

If you use Quick BI Enterprise Standard, you can add a Hive data source.
1. Click the Hive icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number.
• Database: the database name.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.
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Vertica (Quick BI Standard)
If you use Quick BI Enterprise Standard, you can add a Vertica data source.
1. Click the Vertica icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 5433.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
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4. Click Add to add the data source.
IBM DB2 LUW (Quick BI Enterprise Standard)

If you use Quick BI Enterprise Standard, you can add an IBM DB2 LUW data source.
1. Click the IBM DB2 LUW icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 50000.
• Database: the database name.
• Schema: the database schema. The default schema is DB2INST1.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
4. Click Add to add the data source.
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SAP IQ (Sybase IQ) (Quick BI Enterprise Standard）
If you use Quick BI Enterprise Standard, you can add an SAP IQ (Sybase IQ) data
source.
1. Click the SAP IQ(Sybase IQ) icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 2638.
• Database: the database name.
• Schema: the database schema. The default schema is sybase.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
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4. Click Add to add the data source.
SAP HANA (Quick BI Enterprise Standard)

If you use Quick BI Enterprise Standard, you can add an SAP HANA data source.
1. Click the SAP HANA icon.
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2. Enter the fields for connecting to the data source.

• Name: the data source name.
• Database Address: the IP address or hostname of the database.
• Port Number: the port number. The default port number is 30015.
• Database: the database name.
• Schema: the database schema. The default schema is public.
• Username: the database username.
• Password: the database password.
• SSH Host: The host name or IP address.
• SSH Username: The username for logon through SSH.
• SSH Password: The password for logon through SSH.
• SSH Port: The default SSH port number 22.

3. Click Test Connection to perform a data source connectivity test.
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4. Click Add to add the data source.
2.2.4 Upload local files

You can upload local CSV files and Excel files (.xls and .xlsx files) to the explore space 
as a data source.
The explore space is a data source type that is used only in the personal workspace. 
Each user has 1 GB storage space.
In addition, you can import data resources from the Data IDE.

Note:
The method that you upload local files through Create Data Source > Local Files is
only available in personal workspaces.

CSV file
CSV files in UTF-8 format are decoded without errors. CSV files in GBK or GB2312 
format are automatically decoded, but the decoding may fail in some special cases.
If your CSV files cannot be decoded correctly, use text editors such as Notepad to 
convert the encoding of the files to UTF-8. Otherwise, the content of the uploaded 
files is shown as gibberish.
1. Use Notepad to open a CSV file.
2. Choose File > Save As.
3. Click the drop-down arrow of Encoding.
4. Select UTF-8.
After you have changed the encoding, upload the CSV file to the explore space.
1. Log on to the Quick BI console.
2. Click Data Source to enter the Data Sources page.
3. ChooseCreate > Local Upload > CSV file.
4. Enter a display name for the file.
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5. Click Select a file to select the file to upload, as shown in the following figure.

6. Click OK to upload the file.
Excel file

When you upload Excel files, the first sheet in each excel file is uploaded by default. 
To make the editing and maintenance more flexible, you can only select one sheet in 
one Excel file at a time.
1. ChooseCreate > Local Upload > EXCEL file.
2. Enter a display name for the file.
3. Click Select a file to select the file to upload, as shown in the following figure.

4. Click OK to complete uploading the file.
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Data IDE

Note:
Only supports importing data sources from the China (Shanghai) region, and you
must add your account to the project.

1. ChooseCreate > From Other > Data IDE.
2. Select the data source from the list.
3. Click Import to complete the importing of the data source.

Update table data according to the local data source
The local data source feature of Quick BI is designed to meet the analysis requiremen
ts for your changing and growing business.
After you have uploaded a file, new files are generated as the business grows. You can
 append the new files to the table corresponding to the previously uploaded file to 
analyze business data consistently over a long period of time.
The new file can be in a format different from the previously uploaded file. For 
example, if you have uploaded a CSV file, you can import data from a sheet in an Excel
 file. Make sure that the field names and the field types in the files to be uploaded are 
the same as those in the previously uploaded file.
1. Click Data Source to enter the Data Sources page.
2. Click Explore Space to enter the Explore Space page.
3. Select a file, and then click Update.
4. Click Append to upload the file that needs to be appended, as shown in the

following figure.

5. Click OK to append the data.
Delete the data of the table corresponding to a local data source

If a file that you have appended contains dirty data, which decreases the accuracy of
 the data, you can delete the file with dirty data that is corresponding to the table in 
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the uploaded file list. The corresponding dashboard displays corrected data without 
any manual changes. Therefore, the analysis results of data are accurate at all times.
1. Click Data Source to enter the Data Sources page.
2. Click Explore Space to enter the Explore Space page.
3. Select a file, and then click Update.
4. Locate the file that needs to be deleted, and then click the Delete icon, as shown in

the following figure.

Example of local files
To help you learn to use local data source files, we provide a sample CSV file here: 
Sales data examples.
The structure of the sales data is shown in the following table.
Field Field type Description

order_id varchar Order ID
report_date datetime Order date
customer_name varchar Customer name
order_level varchar Order grade
order_number double Order quantity
order_amt double Order amount
back_point double Discount
shipping_type varchar Shipping type
profit_amt double Profit amount
price double Unit price
shipping_cost double Shipping cost
area varchar Region

56 Issue: 20190816

http://docs-aliyun.cn-hangzhou.oss.aliyun-inc.com/assets/attach/47483/cn_zh/1483006983645/company_sales_record_utf8.csv?spm=a2c63.p38356.a3.1.613841274yUUi1&file=company_sales_record_utf8.csv
http://docs-aliyun.cn-hangzhou.oss.aliyun-inc.com/assets/attach/47483/cn_zh/1483006983645/company_sales_record_utf8.csv?spm=a2c63.p38356.a3.1.613841274yUUi1&file=company_sales_record_utf8.csv


Quick BI User Guide /  2 Data modeling

Field Field type Description

province varchar Province
city varchar City
product_type varchar Product type
product_sub_type varchar Product subtype
product_name varchar Product name
product_box varchar Product packing box
shipping_date Datetime Shipping date

2.2.5 Edit, search, and delete data sources
On the data sources page, you can view all created data sources, and edit, search, and
delete data sources. To perform these actions, go to the data sources page first.

Go to the data sources page
1. Log on to the Quick BI console.
2. In the left-side navigation pane, select Data Sources.

Edit a data source
1. On the data sources page, select a data source, and click the Edit icon.
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2. Edit the following information in the dialog box. Click Save to save the changes.

Search data sources
On the data sources page, enter a data source name into the search box and then click
the Search icon to search for the data source.
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Delete a data source
On the data sources page, select a data source, and click the Delete icon to delete the
data source.

Note:
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If a dataset is created on the data source, then you cannot delete the data source. The
system will prompt an error message when you delete the data source.

2.2.6 Search for tables in a data source
Procedure

1. Log on to the Quick BI console.
2. Click Data Sources to go to the Data Sources page.
3. Enter a table name into the search box and click the Search icon to search for the

table.

2.2.7 View the tables in a data source
Procedure

1. Log on to the Quick BI console.
2. Click Data Sources to go to the Data Sources page.
3. In the My Data Sources list, click a data source. All tables stored in the data source

are displayed on the right side of the page.
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4. Select a table and click the View Details icon to view the details of the table.

2.2.8 Synchronize data sources
In the Personal Space of Quick BI, you can synchronize MaxCompute and MySQL data
sources to Exploration Space.
1. On the Data Sources page, click Import Data.

2. Select a MaxCompute data source or a MySQL data source.

Note:
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• You must add the following IP addresses to the RDS whitelist before
synchronizing the MySQL data source.
11.193.158.0/24,11.193.162.0/24,47.74.161.0/24,47.74.162.0/24

• You must switch to a classic network to synchronize MySQL data sources. A VPC
 network does not support the synchronization of MySQL data sources.

• This function is a one-time synchronization. If the data source is updated, you 
must synchronize the data source again.

2.3 Dataset management
2.3.1 Manage datasets

You can create datasets based on the data sources that you add or import. For adding
and importing data sources, see #unique_46, #unique_47, and #unique_48.
After creating a dataset, you can create a dashboard as needed. For creating
dashboards, see #unique_49.
On the edit page of a dataset, you can analyze, edit, and rename the dataset.
The edit page of a dataset consists of the following sections.
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On the edit page of a dataset, you can perform the following operations on the
dataset.
• #unique_50
• #unique_51
• #unique_52
• #unique_53
• #unique_54

2.3.2 Create a dataset
Prerequisites

Make sure that a data source is created or uploaded before you create a dataset.
Context

For more information, see Create a cloud data source, Create a user-created data
source, and Upload a file.

Procedure
1. Log on to the Quick BI console.
2. Click Data Sources to go to the Data Sources page.
3. Select a data source.
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4. You can create a dataset from a data source directly or use an ad-hoc query result
as a dataset.
• Use a data source

Select a table and click the Create Dataset icon in the Actions column.

• Use an ad-hoc query result
a. Click Ad Hoc Query. On the Ad Hoc Query page, enter SQL statements.

Note:
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Click Format to format SQL statements.
b. Click Run to view the result and history.
c. ClickCreate Dataset to save the result as a

dataset.
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Note:
On the History tab page, you can click Create Dataset in the Actions column
to create a dataset based on the corresponding SQL statements.

After the dataset is created, the current page is redirected to the Datasets page. A
new dataset is displayed with a NEW icon.

2.3.3 Edit dimensions and measures
To edit a dimension or a measure, you can click the operations icon, or you can right-
click the dimension or measure and select an operation from the shortcut menu
that appears. For example, you need to change the dimension type to Geo when you
create a bubble map or a colored map. Otherwise, the map chart cannot be displayed
properly.

Edit a dimension
1. Select a dimension. For example, order_level.
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2. Right-click order_level and a shortcut menu appears.

• Edit: edits the dimension name and description.
• Duplicate Dimension: duplicates a dimension. The name of the duplicate

dimension ends with _Duplicate.
• Hide When Analyze: hides a dimension.
• Show All: shows all dimensions.
• Delete: deletes a dimension.
• Create Calculated Field (Dimensions): creates a dimension and customizes the 

expression.
• Move To: moves a dimension to a hierarchy for drilling.
• Create Hierarchy: creates a hierarchy for a dimension.
• Move Up/Move Down: moves a dimension. You can also do this with drag and 

drop.
• Convert to Measure: converts a dimension to a measure.
• Change Dimension Type: changes the dimension type. Dimension types include 

Date/Time, Geo, String, and Number.
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Note:
• You can duplicate, hide, and delete dimensions of different hierarchy levels.
• You can set the start day of a week for the week calculated field. A week field is

calculated by using the WEEK() function.

Edit a measure
1. Select a measure. For example, order_number.
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2. Right-click order_number and a shortcut menu appears.

• Edit: edits the measure name and description.
• Duplicate Measure: duplicates a measure. Name of the duplicate measure

contains _Duplicate.
• Hide When Analyze: hides a measure.
• Show All: shows all measures.
• Delete: deletes a measure.
• Create Calculated Field (Measures): creates a measure and customizes the 

expression.
• Move To: moves a measure to a hierarchy.
• Move Up/Move Down: moves a dimension. You can also do this with drag and 

drop.
• Convert to Dimension: converts a measure to a dimension.
• Format: specifies the number format to display.
• Default Aggregates: specifies the aggregate function. Aggregate functions 

include Sum, Count, Count Distinct, Maximum, Minimum, and Average.
• Change Measure Type: changes the measure type. Measure types include String 

and Number.
Issue: 20190816 69



Quick BI User Guide /  2 Data modeling

2.3.4 Change field types
To create a map chart, such as a geo bubble map or a geomap, select dimension fields
containing geographical information and change the dimension type from String to
Location. Otherwise, the map cannot be displayed.
1. Click Datasets to go to the Datasets page.
2. Select a target dataset, for example, company_sales_record, and click Edit to go to

the dataset editing page, as shown in the following figure.

3. In the dimension list, locate the area option.
4. Right-click the dimension and choose Change Dimension Type > Location > Region,

as shown in the following figure.

Note:
When the dimension type is changed to geographical information, the selected
geographical information must match with the field. For example, if the field is
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area, you must select Region in the geographical information list. Otherwise, the
dimension type cannot be changed.
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5. You can change to Province/Municipality or City in the same way, as shown in the
following figure.
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6. After the dataset is edited, click Save, as shown in the following figure.

7. Click Refresh Preview. The data is automatically displayed in the table, as shown in
the following figure.
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2.3.5 Toolbar
You can save, refresh, synchronize, and enable the protected security level for a
dataset by using the toolbar.

• Lock mechanism: protects data when the protected security level is enabled.
• Sync Schema: detects changes of fact tables such as field adding and the dataset is 

synchronized with the changes. Deleting or renaming fields does not cause deleting
 dimensions or measures of a dataset

• Refresh Preview: refreshes a dataset and displays the data preview. Save before 
refreshing a dataset to view the latest data.

• Set Filter: sets filters for a dataset to avoid full table scan.
• Save: saves a dataset.
• Save as: saves a copy of a dataset.

2.3.6 Add a grouping field
On the dataset edit page, you can select Add Grouping Field to classify values in a field
into different groups, and create a new field to store the grouping information.

Note:
• This function is only available in Quick BI Pro.
• Classic workbooks do not support the grouping function. Classic workbook is a 

feature of the beta version. It will be deprecated soon. We recommend that you 
use workbooks.

1. On the Datasets page, click a dataset name.
2. On the Datasets page, choose + > Add Grouping Field next to Dimensions.
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3. In the Edit Grouping Field dialog box, enter the required information and click OK.

4. Click Save and then click Refresh Preview. The dimension list shows the grouping
field.

2.3.7 Join data tables
If you have multiple tables based on the same data source, you can use the Table 
Joinb function to join multiple tables by using the snowflake model. For example,
when you join Table A with Table B and join Table B with Table C, Quick BI
automatically adds join fields involved in hierarchies to the dimension and measure
lists of Table A.

Description of joined data tables

Note:
• You cannot associate multiple datasets with charts in Quick BI Basic and Quick BI 

Pro.
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• You can associate multiple datasets with charts in Quick BI Enterprise Standard
. Now, this feature is only available when the data source type is MaxCompute, 
MySQL, and Oracle.

• The associated data table can only be the original table in the database. Currently, 
it cannot be associated with created datasets.

Currently, you can use the following three joins in Quick BI:
• Inner join
• Left outer join
• Full join

Note:
You cannot use a full join on a MySQL data source.

Example of joining data tables
1. Click the Join icon to enter the Table Join page as the following figure shows.

2. Click the + icon to add a table that you want to join.
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3. Click the drop-down arrow for Dataset Field to select a field as the following figure
shows.

4. Click the drop-down arrow for Join Type to select a type as the following figure
shows.
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5. Click the drop-down arrow for Associate Table to select a table as the following
figure shows.

6. Click the drop-down arrow for Join On to select a field.
7. Click OK to add a join table.

• Click the + icon at position 1 to join the third table with the second table.
• Click the + icon at position 2 to join the third table with the first table.

8. Click the Preview icon to switch to the preview mode as the following figure shows.
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9. Click Save to save the dataset.

Note:
Before saving the dataset, you can click Set filter conditions to filter the data in the
current dataset to reduce searches for non-relevant data when using this dataset.

2.3.8 Enable table scan
Enable table scan
You can enable the table scan function for MaxCompute (formerly known as ODPS) 
datasets. Follow these steps to enable table scan:
1. On the Datasets page, right-click a MaxCompute dataset, and select Edit Properties.
2. On the Properties page, select the Table Scan option to enable this function.

2.3.9 Search for and delete datasets
After you create a dataset, you can search for and delete the dataset.

Search for a dataset
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
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3. In the search box, enter a dataset name or the creator's name.

4. Click the search icon to search for the dataset.
Delete a dataset

1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select a dataset. Click More in the Actions column or right-click the dataset.
4. Select Delete to delete the dataset.

2.3.10 Rename, transfer, and set security levels
You can rename, transfer, and set the security level for a dataset by editing the
properties of the dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select a dataset, click the More icon in the Actions column and select the Edit

Properties icon from the drop-down list.
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4. On the Edit Properties page, you can perform the following operations on the
dataset.

• Change the dataset name.
• Change the dataset owner.
• Change the security level. If you choose Protected as the security level, you need

to lock the data object first before editing it.
• Scan Full Table: Enables this feature to scan the full table.

Note:
This feature only applies to MaxCompute data sources.

2.3.11 Manage datasets
On the datasets page, you can create, rename, and delete dataset folders.

Create a dataset folder
1. Log on to the Quick BI console.
2. In the left-side navigation pane, select Datasets.
3. Click Create Folder and enter a folder name.
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4. Click OK.

Rename a dataset folder
1. Log on to the Quick BI console.
2. In the left-side navigation pane, select Datasets.
3. Select a dataset folder. Click the Rename icon, or right-click the folder and select

Rename.
4. Enter a new folder name, and clickOK.

Delete a dataset folder
1. Log on to the Quick BI console.
2. In the left-side navigation pane, select Datasets.
3. Select a dataset folder. Click the Delete icon, or right-click the dataset folder and

select Delete.
4. Click OK to delete the dataset folder.

2.3.12 Dataset row-level permissions
For more information about row-level permissions of datasets, see #unique_66.
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3 Create dashboards
3.1 Dashboard overview

This topic describes the basic concepts of a dashboard, including the chart types, 
scenarios, and chart elements.
For more information about the basic operations on a dashboard, see Dashboard
basic operations.
For more information about creating charts, see Create a chart.
The dashboard provides a flexible tile view to show the interaction between data. It 
visualizes data and supports filtering and querying a variety of data types. It displays 
data in various ways and highlights the keyword segments in the data.
In terms of data visualization, the dashboard guides you through dragging or double
-clicking a field to display data explicitly. In terms of data analysis, the dashboard 
utilizes user-friendly notifications to improve user interaction.
Data visualization performance has improved significantly. On the editing page of the
 dashboard, you can filter dynamic data.

Chart types and scenarios
You need to use the corresponding charts to display different types of data. Quick 
BI currently supports 35 types of charts, including line charts, vertical bar charts, 
bubble maps, and funnel charts.
The following table describes the analysis types and scenarios for each chart.
Analysis type Description Scenarios Applicable charts
Comparison Compares the

 differences 
between values, 
or compares the 
measures based on 
the dimensions.

Compares the sales
/income difference
s between different
 countries or 
regions.

Vertical bar chart, 
combination chart
, horizontal bar 
chart, radar chart, 
funnel chart, cross
 table, pivot table
, polar diagram, 
tornado-leaned 
funnel chart, and 
word cloud.
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Analysis type Description Scenarios Applicable charts
Proportion Displays the 

percentage of a
 portion of the
 whole, or the 
proportion of 
a certain value 
compared to the 
whole.

Displays the sales
 of the salesperso
n who has the 
greatest percentage
 of total sales.

Pie chart, funnel 
chart, gauge, and 
treemap.

Relationship Displays the 
relationship 
between values, or 
between measures.

You can view 
the relationsh
ip between two 
measures and learn
 the influence the
 first measure has
 on the second 
measure.

Scatter chart, 
treemap, kanban
, hierarchy chart, 
flow analysis chart, 
and progress bar.

Trend Displays data 
trends (especially 
trends based on the
 date such as the 
year/month/day), 
or the progress of
 a data indicator 
and other possible 
patterns.

You can view trends
 in sales or revenue 
for a product over a 
period of time.

Line chart and area
 chart.

Geographic map Displays the 
relevant data and 
distribution range
 for a country or
 region on the 
map. The datasets 
used must include 
geographic data.

You can view the
 income for each 
region in a country.

Bubble map, 
colored map, and 
LBS bubble map.

The elements of a chart
Each chart has three tabs, which are Data, Style, and Advanced, as shown in the 
following figure.

• Settings in the Data tab determine the data shown on the chart.
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• Settings in the Style tab determine the appearance of the chart and the details to be
 displayed.

• Settings in the Advanced tab determine whether the data and multiple charts can 
be linked, and dynamically display the interaction and comparison of the data as 
needed.

The charts provided by Quick BI present distinct perspectives and data elements for
 different visualization scenarios. Take the geographic chart as an example. A core 
data element is latitude. Otherwise, the map cannot display data.
The following table describes the elements of each chart.
Chart Type Elements Chart Configuration
Line chart Category axis and value 

axis
The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Area chart Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Stacked area chart Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

100% stacked area chart Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Vertical bar chart Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Issue: 20190816 85



Quick BI User Guide /  3 Create dashboards

Chart Type Elements Chart Configuration
Stacked vertical bar chart Category axis and value 

axis
The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

100% stacked vertical bar 
chart

Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Circular bar Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Combination chart Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Horizontal bar chart Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

Stacked horizontal bar 
chart

Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.

100% stacked horizontal 
bar chart

Category axis and value 
axis

The category axis 
must have at least one 
dimension. The value axis
 must have at least one 
measure.
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Chart Type Elements Chart Configuration
Pie chart Labels and central angle The label contains only 

one dimension, and the
 value of the dimension 
must be less than or equal
 to 12. The central angle 
has only one measure.

Bubble map Location and the bubble 
size

The location contains only
 one dimension, which is 
the geographic dimension
. The bubble size element 
can have 1-5 measures.

Colored map Location and colorscale The location contains only
 one dimension, which is 
the geographic dimension
. The colorscale element 
can have 1-5 measures.

Geo bubble map Location and the bubble 
size

The location contains only
 one dimension, which is 
the geographic dimension
. The bubble size element 
can have 1-5 measures.

Geo map Location and colorscale The location has only 
one dimension, which is 
geographic data. The color
 saturation has only one 
measure.

LBS bubble map Geographical area and LBS
 bubble size

The geographical area has 
only one dimension, which
 is the latitude. The LBS 
bubble size element can
 have at least one and at 
most five measures.

LBS heat map Location and LBS heat 
metric

The geographical area has 
only one dimension, which
 is the latitude. The LBS 
bubble size element can
 have at least one and at 
most five measures.
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Chart Type Elements Chart Configuration
LBS flying line map Geo location (from), Geo 

location (to), and routes (
measures).

You can select a maximum
 of two dimensions for the
 geo locations. You can 
select a minimum of one
 and a maximum of five 
measures for the routes.

Cross table Row and column The row has unlimited 
dimensions. The column 
has unlimited measures.

Gauge Indicator angle and tooltip The indicator angle has 
only one measure.

Radar chart Radius label and radius You can select a minimum
 of one and a maximum 
of two dimensions for the
 labels. You can select a 
minimum of one measure 
for the lengths.

Scatter chart Colors, X-axis, and Y-axis You can select a minimum
 and maximum of one 
dimension for the color
 legend. The number of
 the dimension's values
 is up to 1,000. You can 
select a minimum of one
 and a maximum of three
 measures for the x-axis. 
You can select a minimum
 and maximum of one 
dimension for the y-axis.

Bubble chart X-axis, Y-axis, and bubble 
size

The X-axis has only one 
dimension. The Y-axis has
 only one measure. The 
bubble size has only one 
measure.

Funnel chart Tier labels and tier area The tier labels element has
 only one dimension. The 
tier area element has only 
one measure.
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Chart Type Elements Chart Configuration
Kanban Labels and metrics You can select a maximum

 of one dimension for the
 labels. You can select a
 minimum of one and a 
maximum of 10 measures 
for the metrics.

Treemap Rectangle label and 
rectangle size

The rectangle size element
 has only one dimension, 
with a value less than or 
equal to 12. The rectangle 
size element has only one 
measure.

Polar diagram Slice label and arc radius The slice label element 
has only one dimension, 
with a value greater than 
or equal to three and less
 than or equal to 12. The
 arc radius element has 
only one measure.

Word cloud Word size and word The word size element has
 only one dimension. The 
word element has only one
 measure.

Tornado-leaned funnel 
chart

Comparison and contrast 
indicator

The comparison element
 has only one dimension. 
The contrast indicator has 
at least one measure.

Hierarchy chart Node label and node 
metric

The node label has at least 
two dimensions. The node
 metric has at least one 
dimension.

Flow analysis Previous Page, Current
 Page, and Next Page. 
Previous Page PV, Previous
 Page UV, Current PV, 
Current UV, Next Page PV, 
Next Page UV, Conversion 
Rate, and Bounce Rate

Each data element has only
 one dimension and one 
measure.
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Chart Type Elements Chart Configuration
Progress bar Progress Indicator The progress indicator has

 a minimum of one and a 
maximum of five measures
.

Pivot chart Row and value The row has unlimited 
dimensions. The value has 
unlimited measures.

3.2 Dashboard basic operations
3.2.1 Basic dashboard operations

This topic describes how to go to the Dashboards page and perform basic dashboard
operations.
For more information about dashboards, see #unique_72.
To learn how to create charts, see #unique_49.

Go to the Dashboards page
Quick BI Quick BI Pro
1. Log on to the Quick BI console.
2. Click Workspace > Dashboards to go to the Dashboards page.
3. Click Create Dashboard > Standard to go to the dashboard editing page.
Quick BI Professional edition
1. Log on to the Quick BI console.
2. Click Workspace > Dashboards to go to the Dashboards page.
3. Hover your mouse cursor over Create Dashboard button and select a display mode.

Click the display mode, as shown in the following figure.

For more information about how to create standard dashboards, see Standard
dashboards.
For more information about how to create full-screen dashboards, see Full-screen
dashboards.

90 Issue: 20190816



Quick BI User Guide /  3 Create dashboards

Areas of a dashboard
You can perform basic dashboard operations in the following three areas.
• Dataset selection area
• Dashboard configuration area
• Dashboard display area
Dataset selection area
In the dataset selection area, you can switch from an existing dataset to another 
dataset. Based on the preset data types, the fields of the new dataset are displayed in 
the dimension list and the measure list. You can select dimension and measure fields 
based on the data elements in the chart.
Dashboard configuration area
In the dashboard configuration area, you can select a chart type, and edit the title, 
layout, and legend pattern of the chart. In Advanced Settings, you can relate multiple
 charts and display analysis results from multiple perspectives. You can filter data 
using Filters. You can also insert a filter bar to search any key metric in a chart.
Dashboard display area
In the dashboard display area, you can drag and drop a chart to change its position as
 you like. You can also change the chart type based on your needs. For example, you 
can change a column chart to a geo bubble map. The system will display the missing 
or error elements based on the basic components of different charts. The dashboard 
provides a guide feature to help you learn how to create a dashboard.

3.2.2 Switch datasets
In the dataset selection area, you can select or switch datasets, and search for datasets
by dimension and measure fields.
1. Click the Dataset Switch icon.
2. In the drop-down list, select or search for the datasets that need to be analyzed,

such as company_sales_record.

If you cannot find the required dataset from the drop-down list, go back to the dataset
 management page and ensure that the dataset has been successfully created.
For more information about how to create datasets, see #unique_76 Create datasets.
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3.2.3 Search for the dimensions field and the measures field
After you have selected the datasets, the system automatically separates fields into 
the dimension and measure areas.
You can enter a keyword in the search bar, and click the search icon. The system 
automatically searches for the fields that contain the keyword.
1. For example, enter a keyword called product in the search bar.
2. The fields that contain the keyword automatically appear in the list, as shown in

the following figure.

3.2.4 Configure a chart
You can select a chart in the configuration area of a dashboard. After you select a 
chart, you can configure this chart.
You must ensure that you have selected a dataset on the Data tab before you create a 
chart. In addition, dimensions and measures are applicable.
For more information about dimensions and measures, see #unique_79.
1. After you click a chart icon, the selected chart appears in a dashboard.

You can switch a chart to other types by clicking Change chart type in the upper-
right corner of the page.

2. On the Data tab, select the required dimensions and measures.

• Click the cross icon next to a field to remove this field from the Category Axis
(Dimensions) area.

• Click the triangle icon next to a field to display the values of this field in
ascending or descending order.
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3. Select a field and drag this field to the Colors (Dimensions) area.
The selected field appears in a chart with the specified color. If you fail to drag a 
field, an error message occurs. You can follow the instruction on the message to 
add or remove dimensions and measures.
Take the product_type field as an example.
a. Drag the product_type field to the Colors (Dimensions) area, and then click

Update.

b. Select Style > Series settings to change your color matching themes.
4. Select the time interval that data automatically refreshes on the Auto refresh list.
5. On the Style tab, you can change the visual format of a chart by setting options in

General config, Style, Layout, Axis, and Series settings.
You can change a unit by setting a number in the Unit area. You can only multiply
the values of a field by the number you set in the Unit area.
Assume that the previous unit is centimeter. If you want to display data in meters
, you must divide the previous unit by 100. In the Unit area, you can enter 0.01 in 
this case. For a multiplication operation, you can enter 100.

6. On the Advanced tab, you can associate the current chart with other charts.
You must ensure at least two charts are created in the display area of a dashboard 
before you associate charts.

3.2.5 Filter by fields
When you work with a large dataset, you can use the filter feature to view only 
specific types of data from the dataset.
You can filter data of the string, number, or date type.

Filter data in string type
You can filter municipalities from the province field using the filter feature.
Take filtering municipalities as an example.
1. Drag the province field to the Filter Bar area, as shown in the following figure.
2. Click the Set Filter icon, and set filtering criteria.
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3. Select the required filtering criteria. For example, select Filter by Enumeration, as
shown in the following figure.

4. Manually enter the field names or select the city names from the list.

5. After you have specified the fields, click OK.
6. Click Update. The system automatically redraws the chart based on the filters.
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Filter numerical data
You can specify filtering criteria in the filter. For example, you can specify the order
 number with a value between 50 thousand and 100 thousand. In this case, the chart 
displays data based on your specified range.
Take filtering profit amount as an example.
1. Drag the profit amount field to the Filter Bar area.
2. Click the Set Filter icon, and set filtering criteria.
3. Select the filters as needed, such as greater than, less than, or equal to, as shown in

the following figure.

4. After you have specified the fields, click OK.
5. Click Update. The system automatically redraws the chart based on the filters.

Filter data in date type
You can use the filter feature to filter data in a specific date range. For example, you 
can filter the order amounts in the range from 2013 to 2015.

Note:
You can filter data in date type exact to seconds.

Take filtering order dates (year) as an example.
1. Drag the order date (year) field to the Filter Bar area. Click the Set Filter icon, and

set filtering criteria.
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2. Select the filters as needed. For example, specify the Absolute Time with the range
from 2013 to 2015, as shown in the following figure.

3. After you have specified the fields, click OK.
4. Click Update. The system automatically redraws the chart based on the filters.

3.2.6 Sort data
In the Data tab, you can sort the data based on the selected measures and dimensions.
The chart displays the data trend based on the sorted result.

Procedure
1. Select order_number, click the triangle icon next to the field, as shown in the

following figure.
The upward triangle indicates ascending order, and the downward triangle 
indicates descending order.

2. Click Update.
3.2.7 Standard

In Standard mode, you can perform the following operations in a dashboard.
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• Adjust the chart position
• View the chart data
• Delete a chart
• Change the chart type
• Add to favorites
• Global variables
The Dashboards wizard is displayed when you use Quick BI Dashboards for the first 
time. You can learn operations on a dashboard by following the wizard.

More operations
In the upper-right corner of a chart, click the More Actions icon. Then you can
perform the following operations.
• Move To: moves the chart to a tab container.
• View Data: views the data of the chart.
• Export: exports the data of the chart in Excel format.
• View SQL Statements: views the SQL statements of the chart.
• Copy: copies the chart.
• Delete: deletes the chart.

Change the chart type
On the dashboard page, you can change the chart type.
Select a chart, click Change Chart Type in the Graphic Design panel, and select a chart
 type to change the chart type.
1. Select a chart in the dashboard.
2. Click Change Chart Type as shown in the following figure. Change the chart type to 

Radar Chart as shown in the following figure.
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3. The chart updates as shown in the following figure.
A failed change of the chart type indicates that the chart elements for the two chart 
types do not match. You need to manually modify the fields used for chart elements to
 change the chart type.
The chart elements for which you need to modify the fields are displayed based on the
 target chart type. Select the fields from the Dimensions and Measures lists as needed
 and add them to the corresponding sections of chart elements to change the chart 
type.

Add to favorites
Click the Add to Favorites icon next to the dashboard name to add a dashboard to the
favorites.

Page settings
Click the Page Settings icon to configure whether to allow downloads of the
dashboard and whether to add watermarks.

Global variables
After creating a dashboard and clicking Save, you can configure global variables. You
can use global variables for page jumping. For more information, see #unique_83.
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3.2.8 Fullscreen mode
In the fullscreen mode, you can perform the following operations in the display area 
of a dashboard.
• Change chart position
• Add a subscreen
• View chart data
• Delete chart
• Change chart type
• Configure settings

Change chart position
In fullscreen mode, a chart will be scaled to its maximum extent in the display area
 of a dashboard. In addition, when multiple charts exist in a dashboard, click the 
arrow cross icon and hold down the left button, and then drag charts to change the 
arrangement as shown in the following figure.
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Add a subscreen
1. Click the plus icon in the lower-right corner as shown in the following figure.

2. In a subscreen, you can add a chart as shown in the following figure.

3. Click the dot icon to switch between subscreens as shown in the following figure.

4. Click the Delete icon to delete a subscreen as shown in the following figure.

View chart data
1. Select a chart.
2. Click the More icon in the upper-right corner of a chart.
3. Select View Data.
4. Click the Export button in the Data Info dialog box to download data to your local

disk.
Delete chart

1. Select a chart.
2. Click the More icon in the upper-right corner of a chart.
3. Select Delete.

Change chart type
1. Select a chart in the display area of a dashboard.
2. In the configuration area of a dashboard, click Change chart type.
3. Select a chart type that you want to change to.
A chart may fail to change types. This issue occurs when data fields of the selected 
chart type do not match those of the current chart data. You must modify these fields 
manually to change the chart type.
You are required to modify some data fields based on the selected chart type. To 
change chart types, follow the instructions on the screen to change corresponding 
dimensions and measures.
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Configure settings
Click Page setting to change the page scale, skin setting, theme, time interval to
update data, and the time interval of carousel set.

3.3 Visualization analysis
3.3.1 Drilling, filter interaction, and hyperlink

Quick BI supports drilling, filter interaction, and hyperlinks for multi-dimension data
analysis. This topic describes the scenarios and instructions about these features.

Overview
• Drilling: In the dashboard, click a section in a chart or a field in a table in the 

dashboard. The granularity of analysis changes as the dimension level changes.
• Filter interaction: In the dashboard, click a section in a chart. Other charts related 

to the chart change accordingly.
• Hyperlink: In the dashboard, click a field in a chart and you are taken to the linked

page. You can use global parameters and URLs for page jumping.

Note:
Hyperlinks only apply to cross tables and scatter charts. Using global parameters
for page jumping only applies to group workspaces. For more information about
group workspaces, see #unique_87.

Scenarios
The following example describes how to perform filter interactions among charts, 
drill through a hierarchy to change the granularity of data analysis, and jump to the 
Order information pages by using hyperlinks in Quick BI.
The example uses the company_sales_record dataset. You can click sample sales data
 and create the same dataset based on the downloaded CSV file. For more information
about datasets, see #unique_48 and #unique_76.
Procedure:
1. Edit a dataset
2. Create a dashboard
3. Set drilling
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4. Set filter interactions
5. Set hyperlinks

Edit a dataset
Make sure that you have converted the dimension type of the area, province, and city
fields to Geo and have added them to the same hierarchy.
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Create a dashboard
• Create the company's market data dashboard

1. Create a dashboard named company's market data based on the
company_sales_record dataset.

2. Create a pie chart as shown in the following figure and name it Regional order
proportion analysis.

3. Create a colored map as shown in the following figure and name it Regional
sales.
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4. Create a cross table as shown in the following figure and name it Order
information.

After the creation, the company's market data dashboard is as follows.
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• Create the Order profits dashboard
Create a dashboard to show order profits. Name the dashboard Order profits and
create a cross table called Order profits.

Set drilling
You need to manually enable the drilling feature. Click the Drilling icon as shown in
the following figure.

You can set a drilling hierarchy as follows.
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• Use the hierarchy in the dataset: When the selected dimension of a dataset contains
a hierarchy, the hierarchy is displayed by default. You can modify the hierarchy as
shown in the following figure.

• Customize the hierarchy: When the selected dimension of a dataset does not
contain a hierarchy, you can customize the hierarchy and drag the drill dimension
to the Drill (Dimensions) section.

Note:
You can enable drilling for a maximum of three dimensions in a cross table. Other
charts support a maximum of one drill dimension. You can set a maximum of six
levels of a hierarchy.

After the settings are complete, the drill icon appears on the left of the chart title as
shown in the following figure.
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• Drill down: In the Regional order proportion analysis pie chart, click the South
slice and the pie chart based on the provinces of South appears. In the lower-left
corner of the chart, the values of drill dimensions with higher levels are displayed.

• Drill up: Click area to drill up to the area-level data.
Filter interactions

1. In the company's market data dashboard, select the Regional order proportion
analysis pie chart and click the Advanced tab in the Graphic Design panel .

2. Click the pen icon next to Filter Interaction .
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3. In the Filter Interaction dialog box that appears, select the linked field area, the
cross table Order information, and the colored map Regional sales. Click OK.

4. In the Regional order proportion analysis pie chart, click a slice. Click the South
slice and click Filter Interaction.

Both the Order information cross table and the Regional sales colored map show
the sales details in the Se area. Move the pointer over the upper-right corner of the
colored map and the filter value appears.
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Hyperlinks
Parameter
Scenario: Click Office in the Order information cross table and the Order profits
dashboard is jumped to automatically. All Office orders are displayed.
• Configure global parameters

Note:
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The following example uses global parameters for page jumping. You need to set
global parameters first.

1. On the Order profits dashboard page, click the Global Variables icon.

2. In the Global Variables dialog box that appears, perform the configurations as
shown in the following figure and click OK.
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• Configure a hyperlink
1. In the company's market data dashboard page, select the Order information

cross table, click the Advanced tab in the Graphic Design panel.
2. Click the pen icon next to Hyperlink.
3. In the Hyperlink dialog box, perform the configurations as shown in the

following figure and click OK.

After configurations are complete, the product_type column values in the Order
information cross table are displayed as hyperlinks.

• Page jumps
Click Office in the Order information cross table, the Order profits dashboard is
jumped to automatically. Only orders with Office as the value of the corresponding
product_type field are displayed.

External link
You can jump to specified URLs such as web UIs of customer systems by using the 
external link feature.
1. Select the Order information cross table and click the Advanced tab in the Graphic

Design panel.
2. Click the pen icon next to Hyperlink.
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3. On the Hyperlink dialog box, select the fields that you want to hyperlink and select
External Link as the hyperlinking method. Enter a URL and click OK.

Note:
You can add parameters to URLs by entering them manually or by double-clicking
the fields in the Add Dimensions list.

4. Click the hyperlinked field values and the corresponding URL is jumped to.
3.3.2 Metric analysis

You can use metric analysis to view the trends and outliers of data. Currently,
supported analysis tools include Auxiliary Line, Trendline, Prediction, and Anomaly
Detection. Trendline, Prediction, and Anomaly Detection only apply to Quick BI
Enterprise Standard.
Create a dashboard before you use metric analysis. For more information, see Create
a dashboard.

Auxiliary lines
You can add an auxiliary line to view the difference between the value of a measure
and the value shown by the auxiliary line. The value shown by an auxiliary is either
a fixed value or an aggregate value. Aggregate values includes average, maximum,
minimum, and median values.
1. On the edit page of a dashboard, choose Graphic Design > Advanced and choose

Metric Analysis > Auxiliary line.
2. In the Auxiliary Line dialog box, click Add Auxiliary Line. Select a value type for

the auxiliary line to be created.
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3. Click OK. An example of auxiliary lines is shown as follows.

Trendlines
A trendline displays the trend of current data. Types of trendlines include Intelligent, 
Linear, Logarithmic, Exponential, Polynomial, and Power.
1. On the edit page of a dashboard, choose Graphic Design > Advanced and choose

Metric Analysis > Trendline.
2. In the Trendline dialog box, click Add Trendline. Select a measure, a trendline

type, and the number of subsequent periods for which to predict trends.
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3. Click OK. An example of a trendline is shown as follows.

Prediction
You can add a predicted metric to view the trend of current data and predict the trend
.
1. On the edit page of a dashboard, choose Graphic Design > Advanced and choose

Metric Analysis > Prediction.
2. In the Prediction dialog box, click Add Predicted Metric. Select a measure and a

color for the line.
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3. Click OK. An example of a prediction is shown as follows.

Exception detection
You can add a detected metric to view the outliers of the current data.
1. On the edit page of a dashboard, choose Graphic Design > Advanced and choose

Metric Analysis > Anomaly Detection.
2. In the Anomaly Detection dialog box, click Add Detected Metric. Select a measure.
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3. Click OK. An example of an outlier is shown as follows.

Note:
In a line chart, outliers are represented as red dots. In bar charts, outliers are
represented as red vertical bars.

3.4 Common widgets
The presentation area of a dashboard supports the following widget types. You can 
double-click or drag a widget to add it to the presentation area of a dashboard.
• Standard mode

- Filter bar
- Text area
- IFrame
- TAB
- Image

• Full-screen mode
- Text area
- IFrame
- Image

3.4.1 Filter bars
You can use a filter bar to filter data in one or more charts. A dashboard can contain
multiple filter bars. You can pin a maximum of one filter bar each time.
1. Click a filter bar.
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2. Select a dataset and select the fields to be added to the filter bar as shown in the
following figure.

Note:
You can select Enter a filter for a dimension field. After doing this, queries can be
performed only when you select a value for the field.
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3. On the Style tab page, you can perform the following operations.
• Settings: configures the name of the filter bar, whether to show the name,

whether to pin the filter bar, arrangement of filters in the bar, and whether to
hide the Query button.

• Bar style: configures the height of the filter bar, alignment of filters in the bar,
and label position.

• Field style: configures the style of filters and width of search fields.
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Currently, a filter bar supports filter interactions between charts of the current 
dataset or charts of different datasets.
Filter interaction example for the current dataset
1. Select Current Dataset. In the current dataset field list, select charts by the field

type, as shown in the following figure.
2. Click Style to edit the display name of the filter bar.
3. Click Search to filter the associated charts.
Filter interaction example for different datasets
Filter bars can also filter data from different datasets. However, in the associated 
items, the data members must have the same fields. Otherwise, the interaction does 
not work.
1. Select a chart, such as a table.
2. Select the required fields, and then click Update.
3. Click the Style tab, and then change the display name and layout of the table. For

example, set the display name of the table to overseas data.
4. Click the icon that switches datasets to change to another dataset.
5. Select a chart, such as a table.
6. Select the required fields, and then click Update.
7. Click the Style tab, and then change the display name and layout of the table. For

example, set the display name of the table to domestic data.
8. Click the Filter Bar icon, and then select the dataset and add filter fields to the filter

bar.
9. Select Other Dataset. In the Other Dataset list, select the associated items based on

the field type.
10.Click the Style tab to specify the display name of the widget.
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11.Click Search to update the charts filtered by the fields.
Cascade filter example
The filter bar supports cascade filtering, which simplifies the steps of setting multiple
 filters.
1. Create line charts on the dashboard editing page, as shown in the following figure.

2. Click the filter bar widget and then select the dataset and fields to be filtered. In
this example, we select the province field as the filter, as shown in the following
figure.

3. Click the cascade icon. On the Configure Field Cascade page, click + Add cascading
relationship to add the fields to be cascaded, and then click OK. In this example, we
select the city field and the product type field.

Note:
• The cascade filter supports three-level cascades, with lines connected between 

the parent nodes and child nodes.
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• The cascade filter supports renaming the cascade fields.

4. Click Set Filter to set the filters and then click OK. In this example, we select Tile
cascade display and Multiple Select, as shown in the following figure.

Note:
The cascade display supports Tree cascade display and Tile cascade display. You
can select Cognate inheritance and Manually set default values.
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5. In the search widget, click Search. The result is shown in the following figure.

Note:
To view the detailed information of the cascade, you can hover over the cascade
icon in the upper-right corner.

Filter by date
When you filter data in date type, you can select the date range of the filter, manually
set default values, and customize shortcuts, as shown in the following figure.
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1. In the Data tab, select the dataset and the fields to be filtered, such as the order
date (month).

2. Select a chart that needs to be filtered, and then click Set Time Range.
3. In the Set Time Range dialog box, enable Set Time Range, specify the time range,

and then click OK, as shown in the following figure.

4. Select Manually set default values or Customize shortcuts to select a date range,
and then click OK.

Note:
The date currently supports types of month and day for you to customize the date
range.

5. Click Search. All the charts that are filtered by the widget are updated.
Filter by text data
When you filter data in text type, you can set the enumeration range as shown in the
following figure .
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1. In the Data tab, select the dataset and fields to be filtered, such as the product
package.

2. Select a chart that needs to be used, and then click Set Enumeration Range.
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3. In the Enumeration Range dialog box, enable Set Enumeration Range, click
Manually set values or add available values such as middle box, large box, small
package, and small box, and then click OK, as shown in the following figure.
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4. Select Filter by Enumeration and Multiple Select, and then click the drop-down
menu. The system automatically adds the available values of this field to the filter
bar, as shown in the following figure.

Note:
Select Add by Select Sequence to sort and display values by the sequence in which
you select the values.

5. Manually specify the value or select the available values for the field to be filtered,
and then click OK > OK.

6. Click Search. The charts that are filtered by the filter bar are updated.
Filter by numeric data
1. On the Data tab page, select a dataset and filter fields. The following example uses

order_number.
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2. Select charts to be linked. Click OK as shown in the following figure.

3. Click Query and charts that are linked by the filter bar update.
3.4.2 Text area

You can use a text area to enter text. For example, you can use this to create the report
title.
1. Click the Text Area icon, and a text area appears in the dashboard display area.
2. Enter text, as shown in the following figure.

3.4.3 IFrame
You can use iFrames to insert required web pages to filter web data and browse web 
pages related to the current data in real time.
1. Click the IFrame icon, and an iFrame appears in the dashboard display area.
2. In the URL input box, enter the URL.

Note:
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You must use an https URL.
3.4.4 Tab

You can use Tab to present charts in the form of multiple tabs.
1. Click the Tab icon, and a Tab appears in the dashboard display area.
2. In the Tab editing menu, you can add, move, hide, or delete tabs, as shown in the

following figure.

3. Select a Tab to insert charts. For example, click Tab1, and Tab1 is highlighted with 
a blue line.
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4. Click a chart icon to add a chart, and the selected chart is added to Tab1.
Alternatively, you can choose More > Move to in the upper-right corner to move the
existing chart to Tab1, as shown in the following figure.

5. Follow the procedure to create a chart.
3.4.5 Image

1. Click the Image icon, and an image appears in the dashboard display area.
2. Enter the URL of the image.
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3. Configure the style of the image, as shown in the following figure.

3.5 Create charts
3.5.1 Create a dashboard

This topic describes how to create a chart.
See Dashboard overview and Dashboard basic operations before reading this topic.
You must create and edit a dataset before creating a chart. For example, you must
switch the dimension field type to Location.
For more information about how to create and edit a dataset, see Create a dataset.
For more information about how to switch the dimension type, see Change the
dimension type.

Line charts
#unique_104 display the trends of data at equal intervals or over time.

Area charts
Similar to a line chart, an area chart displays the data trend and proportions.

Stacked area charts
A stacked area chart is an extension of an area chart. The values of each measure
are displayed on top of each other. A stacked area chart displays the data trend and
proportions.
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100% stacked area charts
A 100% stacked area chart is a stacked area chart that shows percentages rather than 
absolute numbers.

Vertical bar charts
#unique_106 display the differences between data of different categories and the
trends of data.

Stacked vertical bar charts
Each bar in a stacked vertical bar chart represents a whole, and segments in the bar 
represent different parts or categories of that whole.

100% stacked vertical bar charts
Each segment in a bar shows percentages rather than absolute numbers. Each bar in
 the chart represents a whole, and segments in the bar represent different parts or 
categories of that whole.

Circular bars
A circular bar chart displays the differences between data of different categories and 
the trends of data.

Combination charts
A combination chart can display data of different magnitudes by using dual Y-axis.

Horizontal bar charts
Similar to a vertical bar chart, a horizontal bar chart displays the differences between
data of different categories.

Stacked horizontal bar charts
Splits each entry to display the data size of each entry of the same type. Each bar 
in a chart represents a whole, and segments in the bar represent different parts or 
categories of that whole.

100% stacked horizontal bar charts
Each segment in a bar shows percentages rather than absolute numbers. Each bar 
in a chart represents a whole, and segments in the bar represent different parts or 
categories of that whole.
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Pie charts
#unique_108 display the size and proportion of each data category.

Bubble maps
#unique_109 display the size and distribution scope of metrics by region or country.

Colored maps
#unique_110 show the size and distribution of data by using shades of color.

LBS bubble maps
#unique_111 use bubbles on a map to reflect the data size.

LBS heat maps
#unique_112 use different colors to show the data values and ranges.

LBS flying line maps
#unique_113 use dynamic flying lines on a map to reflect the data size between two or
more locations. It also shows data indicators and the distribution of data for a country
or region.

Cross tables
#unique_114 show the aggregated value of a field in the table, including the sum,
average, count, maximum, and minimum.

Gauges
#unique_115 show the range of a specific indicator.

Radar charts
#unique_116 show analyzed numbers or ratios.

Scatter charts
#unique_117 show the correlation and distribution of data.

Bubble charts
A bubble chart displays the data distribution and aggregation information by placing 
proportionally sized bubbles in corresponding locations.

Funnel charts
#unique_118 show values across multiple stages in a process.
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Kanbans
#unique_119 show the data changes in each stage.

Treemaps
#unique_120 display hierarchical data as a set of nested rectangles.

Polar diagrams
#unique_121 compare multiple data values.

Word clouds
#unique_122 can be used in user profiles and user labels.

Tornado-leaned funnel charts
#unique_123 compare two objects under different indicators or analyzes a process
that has complicated steps.

Hierarchy charts
#unique_124 analyze an organizational structure.

Flow analysis charts
#unique_125 illustrate the conversion rate of a webpage by comparing page views
(PVs) and the number of unique visitors (UVs).

Progress bars
Similar to a gauge, a progress bar shows the progress of completing a task.

Pivot tables
Similar to a cross table, a pivot table shows the aggregated value of a field in the table,
including the sum, average, count, maximum, and minimum.

3.5.2 Line charts
This topic describes the overview, examples, and deletion of a line chart.
See Dashboard overview and Dashboard basic operations before reading this topic. To
create a dataset, see Create a dataset.

Overview
A line chart presents the changing trend of data through broken lines and shows 
continuous data that changes over time. Line charts are useful for analyzing and 
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showing data trends at equal intervals. Line charts are also used for analyzing the
 interactions among multiple groups of data that change over time. For example, 
analyzing the sales volume of a certain product or related products to predict future 
sales.
A line chart is based on the category axis and the value axis. The category axis is the
 horizontal axis. The categories must be dimensions such as dates, provinces, and 
product types. The value axis is the vertical axis. The values must be measures such 
as performance indicators and order numbers.
Dimensions and measures are automatically used for the category axis and the
value axis respectively in the dashboards. You only need to select fields from the 
Dimensions  and Measures  lists.

Samples

Notes
You need to select at least one dimension for the category axis and at least one
measure for the value axis. The color legend supports up to one dimension.

Note:
You can enable the color legend only when the value axis involves one measure.

Examples
Scenario: displays order numbers and unit prices of multiple products. The following 
example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
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3. Click the Create Dashboard icon for the company_sales_record dataset.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.

4. Click the Line Chart icon and an empty line chart appears on the dashboard.
5. Select dimensions and measures.

On the Dimensions list, locate the product_type field and add it to the Category
Axis (Dimensions) section. On the Measures list, locate the order_number and
price fields and add them to the Value Axis (Measures) section respectively.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.
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6. On the Style tab page, you can configure the basic information, chart type, axes,
functionality, and series settings.

7. Click Save to save the dashboard.
Configure the style

• In the Basic Settings section, you can configure the chart title, enable the hyperlink
for page jumping, change the chart background color, and switch the chart type.
This example uses Dark as the background theme.

Note:
To configure a hyperlink used to jump to a report or an external page, select Show
Hyperlink and enter a name and address.

• In the Chart Type section, you can configure whether to show labels, line style, the
position of legend, and whether to display dual Y-axis. This example uses Dual Y-
Axis and shows labels.

Note:
Select Show Labels to show all measure labels. Labels support Smart Display
and Full Display. Assume that a chart involves many dimension values and the
scroll bar is not shown in the chart. In Smart Display mode, only partial labels are
displayed. In Full Display mode, all labels are displayed.

• You can set the titles and units for the axes. This example uses Product Type as the
title for the horizontal axis.

• In the Functionality section, you can configure whether to show a scroll bar.
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• In the Series Settings section, you can set measure aliases, the axis style, boundary
values, and the data display format. This example uses blue as the line color for the
price measure.

Click Update and the updated chart is shown as follows.

For more information about Style, see Configure a chart.
Delete a chart

Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.3 Area charts
This topic describes the overview, examples, and deletion of an area chart.
See Dashboard overview and Dashboard basic operations before reading this topic. To
create a dataset, see Create a dataset.

Overview
Similar to a line chart, an area chart displays the data trend and proportions.
An area chart consists of the category axis and the value axis. The category axis is the
 horizontal axis. The categories must be dimensions such as dates, provinces, and 
product types. The value axis is the vertical axis. The values must be measures such 
as performance indicators and order numbers.
Dimensions and measures are automatically used for the category axis and the 
value axis respectively in the dashboards. You only need to select fields from the 
Dimensions and Measures lists.
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Samples

Notes
You can set at least one dimension for the category axis, and set at least one measure
for the value axis. The Colors field can take only one dimension.

Note:
You can enable the color legend only when the value axis involves one measure.

Examples
Scenario: visualizes the number of orders for each product type of each province. The
 following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Click the Create Dashboard icon for the company_sales_record dataset.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.

4. Click the Area Chart icon and an area chart appears on the dashboard.
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5. Select dimensions and measures.
On the Dimensions list, drag the province and product_type fields to the Category
Axis (Dimensions) section respectively. On the Measures list, drag the order_amt
field to the Value Axis (Measures) section as shown in the following figure.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

6. Drag the product_type field to the Colors (Dimensions) area and click Update.

Note:
You can enable the color legend only when the value axis involves one measure.

7. On the Style tab page, you can configure the basic information, chart type, axes,
functionality, and series settings.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, hyperlink, and
background color. This example uses Dark as the background theme.

Note:
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- In the Basic Information section, you can configure the chart type, such as line 
chart, stacked area chart, and 100% stacked area chart.

- To configure a hyperlink used to jump to a report or an external page, select
Show Hyperlink and enter a name and address.

• In the Chart Type section, you can configure whether to show labels, the position
of legend, whether to display dual Y-axis, and whether to switch to a stacked area
chart or a 100% stacked area chart. This example uses 100% Stacked.

Note:
Select Show Labels to show all measure labels. Labels support Smart Display
and Full Display. Assume that a chart involves many dimension values and the
scroll bar is not shown in the chart. In Smart Display mode, only partial labels are
displayed. In Full Display mode, all labels are displayed.

• In the axis, you can set the title and unit of the Axis. In this example, set the title of
the horizontal axis to Province.

• In the Functionality section, you can configure whether to show a scroll bar.
• In the Series Settings section, you can set measure aliases, the axis style, boundary

values, and the data display format. In Series settings, change the color of the
Office field to orange.

Click Update and the updated chart is shown as follows.

Note:
For more information about Style, see Configure a chart.
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Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.4 Vertical bar charts
This topic describes the overview, examples, and deletion of a vertical bar chart.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A vertical bar chart shows comparisons among discrete categories. You can use a
 vertical bar chart to visualize data changes over a period of time or comparisons 
among discrete categories. For example, you can show the comparison of the traffic 
flow of vehicles over different periods of time at a crossing.
Similar to a line chart, a vertical bar chart is based on the category axis and value
axis.

Samples

Notes
You can set at least one dimension for the category axis such as province and
product_type. In addition, you can set at least one measure for the value axis such as
order_amt and profit_amt. The Color Legend (Dimensions) section can take only one
dimension.

Note:
You can enable the color legend only when the value axis involves one measure.
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Examples
Scenario: compares the shipping cost for different products of provinces of East 
China. The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Click the Create Dashboard icon on the right side of the company_sales_record

dataset.

Note:
If you use Quick BI Enterprise Standard, you need to choose Standard or Full
Screen as the dashboard display mode. The following example uses the Standard
display mode.

4. Click the Vertical Bar Chart icon and an empty chart appears on the dashboard.
5. On the Dimensions list, locate the area field and add it to the Filters section.

East China is filtered by using the area filter as shown in the following figure.
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6. Click the Filter icon and select Filter by Value in the dialog box that appears as
shown in the following figure.

7. Select East China and click OK.
8. Drag province and product_type to the Category Axis (Dimensions) area in turn.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

9. On the Measures list, drag shipping_cost to the Value Axis (Measures) area.
10.Drag product_type to the Colors (Dimensions) area.

Note:
You can enable the color legend only when the value axis involves one measure.
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11.Click Update to update the chart.
12.On the Style tab page, you can configure the basic information, chart type, axes,

functionality, and series settings.
13.Click Save to save the dashboard.

Configure the style

Note:
For more information about Style, see Configure a chart.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.5 Combination charts
Combination charts are a new chart type that is used for combining basic charts. This
topic describes how to use a combination chart.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A combination chart displays data of different magnitudes by using dual y-axis. 
Multiple chart types (line chart, vertical bar chart, and area chart) and stack modes (
stacked and 100% stacked) can be displayed within a combination chart.
A combination chart is based on the category axis, primary value axis, and secondary
 value axis.

Samples
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Notes
You can select a minimum of one dimension, such as report date (year), for the
category axis. You can select a minimum of one measure, such as order_amt and
profit_amt, for the primary value axis and secondary value axis. You can select a
maximum of one dimension for the color legend.

Note:
You can enable the color legend only when the value axis involves one measure.

Scenario: compares the order amounts and profit amounts over multiple years.
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Click the Create Dashboard icon on the right side of the company_sales_record

dataset.

Note:
If you use Quick BI Enterprise Standard, you need to choose Standard or Full
Screen as the dashboard display mode. The following example uses the Standard
display mode.

4. Click the Combination Chart icon and an empty chart appears on the dashboard.
5. On the Dimensions list, locate the report_date (year) field and add it to the

Category Axis (Dimensions) section.
6. On the Measures list, locate the order_amt and profit_amt fields and add them to

the Primary Measures and Secondary Measures sections respectively.

Note:
You can select vertical bar chart, line chart, or area chart as the chart type for the
primary value axis or secondary value axis by clicking the chart type icon.
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You can select the stack mode by clicking the stack mode icon.

7. Click Update and the chart is updated.
8. On the Style tab page, you can configure the basic information, chart type, axes,

functionality, and series settings.
9. Click Save to save the dashboard.

Configure the style
• In the Basic Information section, you can configure the title, hyperlink, and

background color. This example uses Dark as the background color.

Note:
To jump to a report or an external page, select Show Hyperlink and enter a name
and address.

• In the Chart Type section, you can configure the labels, chart direction, line style,
and legend position.

Note:
Select Show Labels to show all measure labels. Labels support Smart Display and
Full Display modes. Assume that a chart involves many dimension values and the
scroll bar is not shown in the chart. In the Smart Display mode, only partial labels
are displayed. In Full Display mode, all labels are displayed.
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• In the Axes section, you can configure axis titles and units. In this example, Show
Scale is selected for the x-axis.

• In the Functionality section, you can configure whether to show the scroll bar.
• In the Series Settings section, you can set measures' aliases, boundary values, and 

data display formats.
Click Update and the updated chart is shown as follows.

Note:
For more information about Style, see Configure a chart.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.6 Horizontal bar charts
This topic describes the overview, examples, and deletion of a horizontal bar chart.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A horizontal bar chart shows comparisons between categories. You can use a 
horizontal bar chart to visualize data changes over a period of time or comparisons 
between categories. For example, you can show the working progress of employees in
 a project group.
Similar to a line chart, a horizontal bar chart is based on the category axis and the
value axis.
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Samples

Notes
You can set a minimum of one dimension for the category axis such as province and
product_type. In addition, you can set at least one measure for the value axis such as
order_amt and profit_amt. The Color Legend (Dimensions) section can take only one
dimension.

Note:
You can add dimensions to the Color Legend (Dimensions) section when only one
measure is added to the Value Axis (Measures) area. Otherwise, you are not allowed
to add dimensions to the Color Legend (Dimensions) section.

Examples
Scenario: compares the shipping costs of products in multiple cities.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Click the Create Dashboard icon on the right side of the company_sales_record

dataset.

Note:
If you use Quick BI Enterprise Standard, you need to choose Standard or Full
Screen as the dashboard display mode. The following example uses the Standard
display mode.

4. Click the Horizontal Bar Chart icon and an empty chart appears on the dashboard.
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5. On the Dimensions list, locate the city field and add it to the Filters section.
Municipalities are filtered from cities by using the filter as shown in the following 
figure.

6. Click the Filter icon and select Filter by Value in the dialog box that appears.
7. Select four municipalities from the list or enter four municipality names manually

and click OK as shown in the following figure.

8. Add the city and product_type fields to the Category Axis (Dimensions) section in
sequence.

Note:
Make sure that you have converted the dimension type of the city field from String
to Geo.
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9. On the Measures list, locate the shipping_cost field and add it to the Value Axis
(Measures) section.

10.Add the product_type field to the Color Legend (Dimensions) section.

Note:
You can add dimensions to the Color Legend (Dimensions) section when only one
measure is added to the Value Axis (Measures) section. Otherwise, you are not
allowed to add dimensions to the Color Legend (Dimensions) section.

11.Click Update and the chart is updated.
12.On the Style tab page, you can configure the basic information, chart type, axes,

functionality, and series settings.

13.Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, hyperlink, and
background color. This example uses Dark as the background color.

Note:
- To jump to a report or an external page, select Show Hyperlink and enter a

name and address.
- In the Basic Information section, you can change the chart type to a stacked 

horizontal bar chart or 100% stacked horizontal bar chart.
• In the Chart Type section, you can configure labels, alignment, legend position,

dual y-axis, and chart type (stacked horizontal bar chart and 100% stacked
horizontal bar chart). This example uses Stacked.

• In the Axes section, you can configure axis titles and units. This example uses Show
Scale for the bottom axis.
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• In the Functionality section, you can configure whether to show a scroll bar and 
the display mode.

• In the Series Settings section, you can set measures' aliases, boundary values, and 
data display formats.

Click Update and the chart is updated.

Note:
For more information about Style, see Configure a chart.

Delete a chart
To delete a chart, move the pointer over the upper-right corner of a chart, click the
More Actions icon that appears, and select Delete from the drop-down list.

3.5.7 Pie charts
This topic describes the overview, examples, and deletion of a pie chart.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A pie chart displays a data series. Each data series has a unique color or texture. Pie 
charts show data distribution and proportions. For example, you can use a pie chart
 to show the proportion of five social insurances and one housing fund in a person's 
income. You can also use a pie chart to show the sales proportion of an auto brand in 
total sales of all brands.
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A pie chart consists of slices. The label of a sector is determined by a dimension such 
as the area field and the product_type field. The degree of an angle is determined by a 
measure such as order_amt and profit_amt.

Samples

Notes
You can set at least one dimension such as area and product_type. In addition, you 
can set at least one measure for the Arc Angle (Measures) area such as order_amt and 
profit_amt.

Examples
Scenario: compares shipping costs for multiple areas. The following example uses the
 company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Click the Create Dashboard icon on the right side of the company_sales_record

dataset.

Note:
If you use Quick BI Enterprise Standard, you need to choose Standard or Full
Screen as the dashboard display mode. The following example uses the Standard
display mode.

4. Click the Pie Chart icon and an empty chart appears on the dashboard.
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5. On the Data tab page, select dimensions and measures.
On the Dimensions list, locate the area field and add it to the Labels (Dimensions)
section. On the Measures list, locate the shipping_cost field and add it to the
Central Angle (Measures) section as shown in the following figure.

Note:
Make sure that you have converted the dimension type from String to Geo for the
area dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, legend, display mode,

radius, and aliases of dimension's values.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, font color, hyperlink,
and background color. This example uses Dark as the background color.

Note:
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To jump to a report or an external page, select Show Hyperlink and enter a name
and address.

• In the Layout section, you can configure the legend, display mode, label style,
leaders, and radius. This example uses Name, Value (Percentage) as the label style
and uses Top as the legend position.

• In the Measures section, you can configure the unit and number of decimal places.
This example uses 2 as the number of decimal places.

• In the Series Settings section, you can configure aliases for dimension's values and
colors for corresponding slices. In this example, the color for Northeast is set to
grey.

Click Update and the updated chart is shown as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.8 Bubble maps
This topic describes the overview, examples, and deletion of a bubble map.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A bubble map displays data by using a map with bubbles of different sizes. You can 
view the values and distribution of data based on a country or a region. For example

154 Issue: 20190816



Quick BI User Guide /  3 Create dashboards

, you can use a bubble map to display tourist traffic of multiple tourist attractions or 
the average income in multiple regions.
A bubble map is based on geographic locations and bubble sizes. Geographic 
locations are based on dimensions such as provinces. Color scales are based on 
measures such as order amounts and profit amounts.

Samples

Notes
You can select a maximum of one dimension for geographic locations. The dimension
 type is required to be Geo. You need to select a minimum of one and a maximum of 
five measures for bubble sizes.

Examples
Scenario: compares the order numbers and profit amounts in multiple provinces. The
 following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to Datasets page.
3. Click the Create Dashboard icon on the right side of the company_sales_record

dataset.

Note:
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If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard as the
display mode.

4. Click the Bubble Map icon and an empty chart appears on the dashboard.
5. On the Data tab page, select a dimension and measures.

On the Dimensions list, locate the province field and add it to the Geo Location
(Dimensions) section. On the Measures list, locate the order_number and
profit_amt fields and add them to the Bubble Size (Measures) section respectively.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province field. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, legend, and value ranges.

8. Click Save to save the dashboard.
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Configure the style
• In the Basic Information section, you can configure the title, font color, and

background color. This example uses Dark as the background color.
• In the Layout section, you can configure the legend position and whether to show

tooltips. This example uses Show Geo Names.
• In the Series Settings section, you can configure value ranges and the number of 

decimal places.
Click Update and the chart is updated.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.9 Colored maps
This topic describes the overview, examples, and deletion of a colored map.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.
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Overview
Similar to a Bubble map, a colored map shows the size and distribution of data by
using shades of color.
A colored map consists of color scales and geographic locations. Geographic locations
 are based on dimensions such as provinces. Color scales are based on measures such 
as order amounts and profit amounts.

Samples

Notes
You can select a maximum of one dimension for geographic locations. The dimension
 type is required to be Geo. You need to select a minimum of one and a maximum of 
five measures for color scales.

Examples
Scenarios: compares the shipping costs, order amounts, and profit amounts in 
multiple areas. The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
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3. Click the Create Dashboard icon on the right side of the company_sales_record
dataset.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Colored Map icon and an empty chart appears.
5. On the Data tab page, select dimensions and measures.

In the Dimensions list, select area and add it to Geo Location (Dimensions). In the
Measures list, select order_amt, profit_amt, and shipping_cost, and add them to
Colorscale (Measures), as shown in the following figure:

Note:
Make sure that you have converted the dimension type from String to Geo for the
area dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
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7. On the Style tab page, you can configure the chart title, legend, and value-based
colors.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, hyperlink, and
background color. This example uses Dark as the background color.

Note:
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To jump to a report or an external page, select Show Hyperlink and enter a name
and address.

• In the Layout section, you can configure the legend position, whether to show 
tooltips, and whether to show geo names. This example uses Top as the legend 
position shows geo names.

• In the Series Settings section, you can configure measures' aliases, data display 
formats, and value ranges.

Click Update and the updated chart is shown as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.10 Cross tables
This topic describes the overview, examples, and deletion of a cross table.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A cross table displays aggregates and sub-aggregates of columns and groups columns
. Aggregates include sums, averages, maximums, and minimums.
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A crosstab consists of rows and columns. Rows are horizontal and based on 
dimensions such as provinces and product types. Columns are vertical and based on 
measures such as order numbers and profit amounts.

Samples

Notes
For each crosstab, the numbers of dimensions and measures are unlimited.

Examples
Scenario: Compare multiple types of products with different package designs, 
transportation costs, order quantities, and profit amounts across multiple provinces 
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Cross Table icon and an empty chart appears.
5. On the Data tab page, select dimensions and measures.

In the Dimensions list, select province, product_type, and product_box, and add
them sequentially to Rows (Dimensions), select order_number, shipping_cost,
and profit_amt, and add them sequentially to Values (Measures), as shown in the
following figure.

Note:
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Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the chart title, layout, format, and rules.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title and hyperlinks for
page jumping as shown in the following figure.

Note:
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For jumping to a report or an external page, select Show Hyperlink and enter a
name and an address.

• In the Display Settings section, you can configure the table theme, choose whether
to show row numbers and whether to merge duplicate cells, configure freezing
rules, and set pagination. The updated chart is shown as follows.

Note:
Pagination is disabled if you select Merge Same Cells.
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• In the Functionality Settings section, you can configure conditional formatting
rules and aggregate rules. Conditional formats include Icons and Data bars.
Icon
1. Select a field and select Icon as the format.

2. Select an icon theme from the Theme drop-down list.

3. You can specify the rules for data that needs to be marked out and click the
downward arrow button to specify the style of the data.
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Take the profit_amt column as an example. The following rules are set for different
data values. The updated table is shown in the following figure:
- If values are greater than or equal to 1000, their cells are highlighted in red and 

a green up arrow appears next to each value.
- When the data value is between 500 and 1000, the background color of the cell 

containing the data is set to orange and an orange horizontal line appears next 
to the data.

- If values are less than 500, their cells are highlighted in green and a red down 
arrow appears next to each value.

Data bar
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1. Select a field and select Data Bar as the format.
2. Set the upper limit, lower limit, and fill color.

Note:
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Upper and lower limits can be set automatically or manually.

Sort columns
You can sort columns and group columns. When grouping
columns, you need to set group names as shown in the following
figure.
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Show totals
By using the Show Totals feature, you can configure aggregates, sub-aggregates,
and aggregation functions such as SUM, AVG, and MAX. You can also create an
expression on which to perform the aggregation as shown in the following figure.

Note:
Before configuring sub-aggregates, you need to select Merge Same Cells in the
Display Settings section.

• In the Series Settings section, you can configure field names, alignment, and the
number format.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.
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3.5.11 Pivot charts
This topic describes the overview, examples, and deletion of a pivot chart.

Note:
Pivot tables only apply to Quick BI Enterprise Standard.

Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
A pivot table can be used to display the aggregates of variables and allows you to drill
 into data in a tree structure. One variable defines the values in the header row while 
the other variable defines the values in the header column. Aggregates include sums, 
averages, maximums, and minimums.
Similar to a cross table, a pivot table consists of rows and columns. Rows are
horizontal and based on dimensions such as provinces and product types. Columns
are vertical and based on measures such as order numbers and profit amounts.

Samples

Notes
For each pivot table, the number of dimensions and measures is unlimited.
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Examples
Scenario: compares multiple types of products with different package designs, order 
quantities, and order amounts across multiple provinces. The following example uses
 the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard as the
display mode.

4. Click the Pivot Table icon and the corresponding legend is displayed.
5. Click the Data tab to select data dimensions and data measures.

In the Dimensions list, select province, product_type, and product_box, and add
them sequentially to Rows (Dimensions), select order_number and order_amt, and
add them sequentially to Values (Measures), as shown in the following figure.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
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7. On the Style tab page, you can configure the basic information, chart type, axes,
functionality, and series settings.

8. Click the Plus (+) sign in front of the value to drill into the data in a tree structure.
For example, when you click the plus sign in front of Shanghai, data about product
types and product boxes is displayed in a tree structure.

9. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title and hyperlink of a
chart.

Note:
For jumping to a report or an external page, select Show Hyperlink and enter a
name and an address.
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• In the Display Settings section, you can configure whether to show row numbers,
to freeze columns, and to enable word wrap. This example shows row numbers.

• In the Functionality Settings section, you can configure conditional formats and
whether to show aggregates. See Functionality settings. This example displays
conditional formats and aggregates.

• In the Series Settings section, you can configure the names of series, alignment, 
and number formats.

The updated chart is shown as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.12 Gauges
This topic describes the overview, examples, and deletion of a gauge.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For creating a dataset, see Create a dataset.

Overview
Similar to a dashboard on a car, a gauge shows the range of a specific indicator. You
 can view the progress of the current task or if a metric will exceed its range. For 
example, you can use a gauge to show the inventory status of a category of items, 
whether it is sufficient or needs to be replenished.
The pointer angle of a gauge is determined by the measure, such as the discount and 
profit amount.
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Notes
You can select up to one measure for the pointer angle.

Samples

Examples
Scenario: Uses a gauge to display the order amount. The following example uses the 
company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Gauge icon and an empty chart appears.
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5. On the Data page, select a measure.
In the Measures list, select order_amt and add it to Pointer Angle (Measures), as
shown in the following figure.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, whether to show the

legend, and whether to show tick marks.

8. Click Save to save the dashboard.
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Configure the style
• In the Basic Information section, you can configure the title, hyperlink, and

background.

Note:
For jumping to a report or an external page, select Show Hyperlink and enter a
name and an address.

• In the Layout section, you can configure whether to show tooltips, tick marks, and 
the legend.

• In the Value Ranges section, you can set value ranges and the corresponding colors
. This example uses 100 as the start value and 1000 as the end value of a range. The 
title of the range is named "net profit".

• In the Series Setting section, you can configure the alias of the measure and 
number of decimal places that each value shows.

The updated chart is shown as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.
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3.5.13 Radar charts
This topic describes the overview, examples, and deletion of a radar chart.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.

Overview
Radar charts display numbers and ratios obtained from data analysis. You can view
 the changing trends of indicators by using radar charts. For example, sales of all 
areas are represented by numbers and ratios in radar charts.
A radar chart is based on labels and lengths. Labels are based on dimensions such as 
product types. Lengths are based on measures such as shipping costs.

Notes
You can select a minimum of one and a maximum of two dimensions for the labels of 
a radar chart. The number of dimension values must be greater than or equal to three
 and less than or equal to 12. You need to select a minimum of one dimension for the 
length.

Samples

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
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2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click the Create Dashboard icon in

the Actions column.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Radar Chart icon and an empty chart appears on the dashboard.
5. On the Data tab page, select dimensions and measures.

In the Dimensions list, locate the area field and add it to Labels (Dimensions). In
the Measures list, locate the order_number and order_amt fields and add them
sequentially to Length (Measures).

Note:
Make sure that you have converted the dimension type of the area field from
String to Geo.

6. Click Update and the chart is updated.
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7. On the Style tab page, you can configure the title name, layout, and legend.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title name, hyperlink, and
background color. This example uses Domestic data as the title name and uses
Dark as the background color.

Note:
For jumping to a report or an external page, select Show Hyperlink and enter a
name and an address.

• In the Layout section, you can configure the legend position and whether to show 
tooltips, areas, and labels.

• In the Series Settings section, you can configure aliases for dimensions, data
formats, and numbers of decimal places. This example uses red as the line color
for the order_number field.

Click Update and the chart is updated as shown in the following figure.
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Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.14 Scatter charts
This topic describes how to create a scatter chart. Make sure that you have read
#unique_72 and #unique_69. For creating a dataset, see #unique_76.

Overview
Scatter charts present the distribution and aggregation of data.
A scatter chart is composed of the X-axis and Y-axis. The color legend is based on the 
data dimension such as the product type. The scales of the X-axis and Y-axis are based
 on the data measures.
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Examples

Notes
You can select a maximum of one dimension for the color legend. You can set a 
maximum of 1,000 dimension values.
X-axis: supports a minimum of one and a maximum of three dimensions.
Y-axis: supports one measure.

Scenarios: unit prices and order numbers of multiple product types
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click the Create Dashboard icon in

the Actions column.

Note:
If you use Quick BI Enterprise Standard, you need to choose Standard or Full
Screen as the display mode manually. The following example uses Standard.

4. Click the Scatter Chart icon and an empty chart appears on the dashboard.
5. On the Data tab page, select dimensions and measures.

In the Dimensions list, locate the product_type field and add it to the Color Legend
(Dimensions) section. In the Measures list, locate the price and order_number
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fields and add them to the X Axis (Measures) and Y Axis (Measures) sections
separately.

6. Click Update and the chart is updated.
7. On the Style tab page, you can modify the chart name, layout, and legend as shown

in the following figure.

8. Click Save to save the dashboard.
Configure the style

• In the Title section, you can configure the title.
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• In the Design section, you can choose whether to show axis titles. This example 
shows the axis titles.

• In the Layout section, you can set the legend position and choose whether to show 
tooltips.

The updated chart is as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of the chart and select Delete
from the drop-down list to delete a chart.

3.5.15 Bubble charts
This topic provides you with an overview and applicable scenarios for bubble charts.
You will also learn how to delete bubble charts.
Before reading this topic, you can familiarize yourself with the #unique_72
and #unique_69 topics. If you want to edit a dataset or create a new dataset, see
#unique_76.

Overview
Bubble charts visualize the distribution and aggregation of data based on bubble 
locations and sizes.
Each bubble chart has an X-axis and Y-axis. The X-axis is based on a dimension, 
such as province. The Y-axis and bubble size are each based on a measure such as 
order_amt.
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Sample bubble chart

Precautions
X Axis (Dimensions): represents only one dimension.
Y Axis (Measures): represents only one measure.
Bubble Size (Measures): represents only one measure.

Create a bubble chart
Sample scenario: compares the unit prices and the order quantities of different 
products. The following example is based on the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to open the Datasets page.
3. Locate the company_sales_record dataset and click Create Dashboard next to the

dataset.

Note:
If you are using Quick BI Enterprise Standard, you need to select Standard or
Full Screen to as the display mode. The following takes the Standard mode as an
example.

4. Click the Bubble Chart icon to add a bubble chart to the dashboard.
5. On the Data tab, select the required dimension and measures.

On the list of dimensions, locate the product_type dimension and add the
dimension to the X Axis (Dimensions) field. On the list of measures, locate the
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price measure and add it to the Y Axis (Measures) field, and then locate the
order_number measure and add it to the Bubble Size field.

6. Click Update to update the chart.
7. In the Style tab, you can change the title, layout, and legend of the chart as shown

in the following figure.

8. Click Save to save the dashboard.
Issue: 20190816 185



Quick BI User Guide /  3 Create dashboards

Configure settings on the Style tab
• In the Basic Information section, you can configure the title of a chart.
• In the Layout section, you can select where to show a legend and whether to show a

 tooltip.
Click Update after you complete configurations. A sample bubble chart is shown as
follows.

Delete a chart
If you want to delete a chart, click the  More icon in the upper-right corner of the
chart and select Delete from the drop-down list.

3.5.16 Funnel charts
This topic describes the overview, examples, and deletion of a funnel chart.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.

Overview
Funnel charts are suitable for analyzing business processes that involve a sequence
 of activities and span over a long period. By comparing the business data during 
different stages, you can easily identify potential problems in the business process
. Funnel charts can be used to show the conversion rates during different stages of 
the business process. For example, you can easily see the percentage of visitors who 
became paying customers in a funnel chart.
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A funnel chart consists of a number of tiers with different labels and widths. The 
labels of tiers are determined by data dimensions, such as area. The widths of tiers 
are determined by data measures, such as the order amounts.

Samples

Notes
You can select a maximum of one dimension for tier labels and a maximum of one 
measure for tier areas.

Examples
Scenario: compares the order amounts across multiple areas. The following example 
uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click the Create Dashboard icon in

the Actions column.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.

4. Click the Funnel Chart icon and an empty chart appears on the dashboard.
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5. On the Data tab page, select a dimension and a measure.
In the Dimensions list, locate the area field and add it to the Tier Labels
(Dimensions) section. In the Measures list, locate the order_amt field and add it to
Tier Area (Measures).

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, and legend as shown in

the following figure.
8. Click Save to save the dashboard.

Configure the style
• In the Basic Information section, you can configure the title, hyperlink, and

background color. This example uses Dark as the background color.

Note:
For jumping to a report or an external page, select Show Hyperlink and enter a
name and an address.

• In the Layout section, you can configure the legend position, label style, and 
display mode.

• In the Measures section, you can configure the measure's alias, data format, and 
the number of decimal places.

• In the Blocks section, you can configure the dimension's alias and area colors.
Click Update and the chart is updated.
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Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.17 Kanbans
This topic describes the overview, examples, and deletion of a kanban.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.

Overview
A kanban provides an overview of data such as sales performance. Using kanbans 
enables you to rapidly respond to sales status and management situations. Kanbans 
help you to discover and solve problems.
A kanban is composed of labels and measures. Labels are based on data dimensions
 such as regions. Measures are based on data measures such as order numbers and 
order amounts.
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Samples

Notes
You can select a maximum of one dimension for the labels of a kanban. You can select
 a minimum of one and a maximum of 10 measures for the metrics of a kanban.

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Kanban icon and an empty chart appears on the dashboard.
5. On the Data tab page, select dimensions and measures.

In the Dimensions list, locate the province field and add it to the Labels
(Dimensions) section. In the Measures list, select the order number, order_amt,
shipping_cost, and profit_amt fields and add them to Metrics (Measures) as shown
in the following figure.

Note:
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Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title name, template types, and

number of columns.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, hyperlink, and
background color. This example uses Dark as the background color.

Note:
For jumping to a report or an external page, select Show Hyperlink and enter a
name and address.

• In the Card Settings section, you can configure the template type, number of 
columns, and alignment. This example uses 3 as the number of columns.

• In the Series Setting section, you can configure the aliases for dimensions, units, 
and numbers of decimal places.
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Click Update and the chart is shown as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.18 Treemaps
This topic describes how to create a treemap. We recommend that you read
#unique_72 and #unique_69 before you create a treemap. You also can edit or create a
dataset. For more information, see #unique_76.

Overview
Treemaps can be used to compare the proportions between variables easily.
A treemap consists of nested rectangles of different sizes and labels. The label of each
 rectangle is determined by data dimensions, such as the package design. The size of 
each rectangle is determined by data measures, such as the transportation cost.

Example of a treemap
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Precautions
Only one dimension can be set for the labels of rectangles. This dimension can have
 a maximum of 12 dimension values. Only one measure can be set for the sizes of 
rectangles.

Scenario: Compare the order quantities of different products
The following scenario is based on the company_sales_record dataset.
1. Log on to the Quick BI console.
2. On the homepage, click the Workspace tab. In the left-side navigation pane, enter

a group workspace name in the text box, or click the triangle next to the text box
and select a group workspace from the drop-down list. Click Datasets to go to the
All Items tab.

3. Click the Create Dashboard icon in the Actions column corresponding to the
company_sales_record dataset.

Note:
If you are using Quick BI Enterprise Standard, you must select Standard or Full
Screen. The following scenario uses Standard as an example.

4. In the toolbar, click the Treemap icon. The blank treemap is automatically 
displayed in the display section.

5. Click the Data tab and select the required measure and dimension.
In the Dimensions section, double-click product type, or drag and drop it to the
Rectangle Labels (Dimensions) section. In the Measures section, double-click order
number, or drag and drop it to the Rectangle Size (Measures) section, as shown in
the following figure.

6. Click Update. The system automatically updates the chart.
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7. On the Style tab, you can change the title and legend of the treemap, as shown in
the following figure.

8. Click Save to save the dashboard.
Configure a style

• In the Basic Settings section, you can set Show Title.
• In the Design section, you can set Show Tooltip, AutoFit Mode, and the number of 

decimal places.
Delete a map

Move the pointer over the upper-right corner of the window. Click the More icon that
appears and choose More Actions > Delete to delete the current map.

3.5.19 Polar diagrams
This topic describes the overview, examples, and deletion of a polar diagram.
Make sure that you have read Dashboard overview and Dashboard basic operations
before this topic. For more information about how to create a dataset, see Create a
dataset.
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Overview
A polar diagram compares multiple data values. It is used for comparing enumerated 
data, such as data based on multiple regions.
Similar to a pie chart, a polar diagram consists of slices. Labels of slices are
determined by the dimension, such as the area and product type. Arc radiuses are
determined by the measure, such as order numbers and order amounts.

Samples

Notes
You can select a maximum of one dimension for labels. The minimum number of 
dimension values is three. The maximum number of dimension values is 12. You can 
select a maximum of one measure for arc radiuses.

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Polar Diagram icon and an empty chart appears on the dashboard.
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5. On the Data tab page, select a dimension and a measure.
In the Dimensions list, locate the area field and add it to the Label (Dimensions)
section. In the Measures list, locate the order_number field and add it to the Arc
Radius (Measures) section, as shown in the following figure.

Note:
Make sure that you have converted the dimension type from String to Geo for the
area dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, legend, measures, and

series settings.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title name, title color,
description, hyperlink, and background color. This example uses Dark as the
background color.

Note:
For jumping to a report or an external page, select Show Hyperlink and enter a
name and an address.
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• In the Layout section, you can configure the legend position, whether to show
tooltips, label style, leaders, and radiuses. The example uses Name, Value
(Percentage) as the label style and uses Right as the legend position.

• In the Measures section, you can configure the data format and the number of
decimal places. This example uses 2 as the number of decimal places.

• In the Series Setting section, you can configure aliases for the dimensions and slice
 colors.

Click Update and the chart is shown as follows.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.5.20 Word clouds
This topic describes the overview, examples, and deletion of a word cloud.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.

Overview
A word cloud visualizes the frequency of words. It can be used in user profiles and 
user labels.
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A word cloud is based on words and font sizes. Words are determined by dimensions
, such as customer names and product names. Font sizes of words are determined by 
measures, such as profit amounts and unit prices.

Samples

Notes
You can select a maximum of one dimension for words and a maximum of one 
measure for font sizes.

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses Standard.

4. Click the Word Cloud icon and an empty chart appears.
5. On the Data tab page, select a dimension and measure.

In the Dimensions list, locate the province field and add it to the Word
(Dimensions) section. In the Measures list, locate the order_number field and add
it to the Word Size (Measures) section.

Note:
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Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
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7. On the Style tab page, you can configure the title name, title color, hyperlink, and
background color. The updated chart is shown as follows.

8. Click Save to save the dashboard.
Delete a chart

Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.
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3.5.21 Tornado-leaned funnel charts
This topic describes how to create a tornado-leaned funnel chart. We recommend
that you read #unique_72 and #unique_69 before you create a tornado-leaned funnel
chart. You also can edit or create a dataset. For more information, see #unique_76.

Overview
A tornado-leaned funnel chart is the combination of a tornado chart and a funnel 
chart. Tornado charts can be used to compare different metrics between two objects
, such as the income and education levels between residents in two cities. Funnel 
charts are used to show the rate of conversion between each step of a process. It can 
be used to analyze complex business procedures. For example, you can use a funnel 
chart to clearly show the rate of visitors that finally buy any product after they access 
the website.
A tornado-leaned funnel chart combines the features of tornado charts and funnel 
charts. For example, when you compare the percentage of the migrant population, 
employment rate, and commercial real estate transaction in Beijing and Shanghai, if a
 conversion relation exists between these metrics of the two cities, the tornado-leaned
 funnel chart can show the difference and conversion rates for each city between 
these metrics.
If no conversion relations exist, the chart functions as a tornado chart. If a conversion
 relation exists between metrics and only one object is defined for these metrics, the 
chart functions as a funnel chart.
A tornado-leaned funnel chart consists of objects and metrics. Objects are 
determined by data dimensions, such as the area and product type. Metrics are 
determined by data measures, such as the order quantity and order amount.

Example of a tornado-leaned funnel chart
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Precautions
Only one dimension can be set for the objects. Set at least one measure for metrics.

Scenario: Compare the order quantities, profits, and average profits for different types of
products

The following scenario is based on the company_sales_record dataset.
1. Log on to the Quick BI console.
2. On the homepage, click the Workspace tab. In the left-side navigation pane, enter

a group workspace name in the text box, or click the triangle next to the text box
and select a group workspace from the drop-down list. Click Datasets to go to the
All Items tab.

3. Click the Create Dashboard icon in the Actions column corresponding to the
company_sales_record dataset.

Note:
If you are using Quick BI Enterprise Standard, you must select Standard or Full
Screen. The following scenario uses Standard as an example.

4. In the toolbar, click the Tornado-leaned Funnel Chart icon. The blank tornado-
leaned funnel chart is automatically displayed in the display section.

5. Click the Data tab and select the required measures and dimension.
In the Dimensions section, double-click product type, or drag and drop it to the
Metrics (Dimensions) section. In the Measures section, double-click order number,
profit amt, and average profit, or drag and drop them to Metrics (Measures) in
order, as shown in the following figure.

6. Click Update. The system automatically updates the chart.
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7. On the Style tab, you can set Show Title, Layout, and Show Conversion Rates, as
shown in the following figure.

• Tornado-leaned funnel charts support two display modes. You can also select
one mode as needed.
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• You can also set Legend Position and Show Conversion Rates, as shown in the
following figure.

8. Click Save to save the dashboard.
Delete a chart

Move the pointer over the upper-right corner of the window. Click the More icon that
appears and choose More Actions > Delete to delete the current chart.

3.5.22 Hierarchy charts
This topic describes how to create a hierarchy chart. We recommend that you read
#unique_72 and #unique_69 before you create a hierarchy chart. You also can edit or
create a dataset. For more information, see #unique_76.

Overview
A hierarchy chart uses the tree structure to display and organize hierarchical data. It
 is an implementation of the enumeration method. For example, when you view the
 revenues of the prefecture-level cities within a province, the relationships between
 the province and prefecture-level cities can be displayed in parent-child structures
. Hierarchy charts are used to analyze organizational structures, such as the staff 
structure of a company or the department structure of a hospital.
A hierarchy chart consists of node metrics and node labels. Each node label is 
determined by data dimensions, such as the area and product type. Each node metric 
is determined by data measures, such as the order quantity and order amount.
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Example of a hierarchy chart

Precautions
At least two dimensions must be set for node labels. These two dimensions must have 
a parent-child relationship. At least one measure must be set for the node metric.

Scenario: Compare the order quantities of different products across provinces and areas
The following scenario is based on the company_sales_record dataset.
1. Log on to the Quick BI console.
2. On the homepage, click the Workspace tab. In the left-side navigation pane, enter

a group workspace name in the text box, or click the triangle next to the text box
and select a group workspace from the drop-down list. Click Datasets to go to the
All Items tab.

3. Click the Create Dashboard icon in the Actions column corresponding to the
company_sales_record dataset.

Note:
If you are using Quick BI Enterprise Standard, you must select Standard or Full
Screen. The following scenario uses Standard as an example.

4. In the toolbar, click the Hierarchy Chart icon. The blank hierarchy chart is 
automatically displayed in the display section.

5. Click the Data tab and select the required measures and dimensions.
In the Dimensions section, double-click area, province, and product type, or
drag and drop them to the Node Labels (Dimensions) section in order. This order
determines their hierarchical relationships in the chart. In the Measures section,
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double-click order number, or drag and drop it to the Node Metrics (Measures)
section, as shown in the following figure.

Note:
Make sure you have changed the data type of the province field value from String
to Geo.

6. Click Update. The system automatically updates the chart.
7. On the Style tab, you can set Show Title, Layout, and Design.

• Hierarchy charts support three layouts. You can select the expansion mode (root
nodes are merged by default) and display mode of parent and child nodes as
needed.

• In the Design section, you can manually enter the number of hierarchy levels
displayed in the chart. You can select a primary path from the corresponding
drop down list. The primary path is displayed in a different color from other
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paths. You can load the filter bar to the chart so that you can edit the chart in the
preview mode or on the dashboard, as shown in the following figure.

8. Click Save to save the dashboard.
Delete a chart

Move the pointer over the upper-right corner of the window. Click the More icon that
appears and choose More Actions > Delete to delete the current chart.

3.5.23 Flow analysis charts
This topic describes how to create a flow analysis chart. We recommend that you read
#unique_72 and #unique_69 before you create a flow analysis chart. You also can edit
or create a dataset. For more information, see #unique_76.

Overview
A flow analysis chart illustrates the conversion rate of a Webpage by comparing the 
page traffic or number page views (PV) against the number of unique visitors (UV), so
 that the Webpage operators can gain insights into the operating status of the Website 
and the final transaction volume for a type of product. A flow analysis chart is suitable
 for analyzing digital marketing campaigns and e-commerce websites. For example
, you can use a flow analysis chart to find out which products are in highest demand 
and what are the peak hours of your business.
Currently, a flow analysis chart supports the following three dimensions: previous 
page, current page, and next page. The measures of a flow analysis chart include PV, 
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UV, conversion rate, and bounce rate. You need to specify the PVs or UVs for all three 
pages.

Example of a flow analysis chart

Precautions
Only one dimension can be set for each of the three pages. The dimension fields must
 be hierarchical. The order of the dimensions determines the hierarchical relationsh
ip in the chart. Only one measure can be set for each of the three PVs or UVs, the 
conversion rate, and the bounce rate.
The three dimensions, the conversion rate, and the bounce rate are required fields
. You can choose to specify only the PVs or UVs for all three pages. Error messages 
appear if fields are incorrectly specified when you add the dimensions and measures.

Scenario: Use PVs to demonstrate the conversion and bounce rates on different pages
The following uses the page_source_target_state dataset as an example.
1. Log on to the Quick BI console.
2. On the homepage, click the Workspace tab. In the left-side navigation pane, enter

a group workspace name in the text box, or click the triangle next to the text box
and select a group workspace from the drop-down list. Click Datasets to go to the
All Items tab.

3. Select the page_source_target_state dataset and click Create Dashboard.

Note:
If you are using Quick BI Enterprise Standard, you must select Standard or Full
Screen. The following scenario uses Standard as an example.
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4. In the toolbar, click the Flow Analysis icon. The blank flow analysis chart is 
automatically displayed in the display section.

5. Click the Data tab and select the required measures and dimensions.
In the Dimensions section, double-click Previous Page, Current Page, and Next
Page, or drag and drop them to the corresponding fields. This order determines the
hierarchical relationship between pages in the diagram. In the Measures section,
double-click Conversion Rate and Bounce Rate, or drag and drop them to the
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corresponding fields. You must also select three PVs or UVs for the corresponding
pages, as shown in the following figure.
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6. Click Update. The system automatically updates the chart.
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7. On the Style tab, you can set Show Title and Layout.
In the Layout section, you can select one of the three modes and select Highlight 
Primary Path or Highlight Bounce Path for the mode.

8. Click Save to save the dashboard.
Delete a chart

Move the pointer over the upper-right corner of the window. Click the More icon that
appears and choose More Actions > Delete to delete the current chart.

3.5.24 LBS heat maps
This topic describes the overview, examples, and deletion of an LBS heat map.

Note:
LBS heat maps only apply to Quick BI Enterprise Standard.

Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.
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Overview
Similar to a colored map, an LBS heat map represents the size and distribution of data
by using different shades of location dots.
An LBS heat map is based on geographic locations and heat intensity. Geographic 
locations are determined by Geo type dimensions such as the province. Heat intensity
 is determined by measures such as the order amount and profit amount.

Samples

Notes
You can only select one dimension for the geographical locations and the dimension 
type must be Geo. You can select a minimum of one and a maximum of five measures 
for the heat intensity.
For more information, see Detailed information for regions.

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
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3. Select the company_sales_record dataset and click the Create Dashboard icon.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.

4. Click the LBS Heat Map icon and an empty chart appears.
5. On the Data tab page, select a dimension and measures.

On the Dimensions list, locate the province field and add it to the Geo Location
section. On the Measures list, locate the order_number and shipping cost fields and
add them to the Heat Intensity (Measures) section respectively.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province dimension. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, and measures' aliases.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, hyperlink, and
background color. This example uses Dark as the background color.

Note:
To configure a hyperlink used to jump to a report or an external page, select Show
Hyperlink and enter a name and address.

• In the Layout section, you can configure the legend position, base map, zoom 
setting, and map center. This example uses Google Map as the base map.

• In the Series Settings section, you can configure measures' aliases and legend 
colors.
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Click Update and the chart is updated.

Delete a chart
In the upper-right corner of the chart, choose More Actions > Delete to delete the
chart.

3.5.25 LBS bubble maps
This topic describes the overview, examples, and deletion of an LBS bubble map.

Note:
LBS bubble maps only apply to Quick BI Enterprise Standard.

Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.

Overview
Similar to a bubble map, an LBS bubble map is a map that uses the sizes of bubbles
distributed across the map to reflect data. It provides multiple base maps for you to
choose from, such as AMAP, Google Maps, and GeoQ. LBS bubble maps allow you
to understand the distribution and values of metrics across countries and regions
in an easy and visual way. For example, LBS bubble maps can display the passenger
numbers across tourist attractions or the per capita incomes across regions.
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An LBS bubble map is based on bubble sizes and geographical locations. Geographic
al locations are determined by Geo type dimensions such as the province. Bubble 
sizes are determined by measures such as the shipping cost and order number.

Samples

Notes
You can only select one dimension for the geographical locations and the dimension
 type must be Geo. For example, the area, province, and city fields. You can select a 
minimum of one and a maximum of five measures for bubble sizes.
For more information, see Detailed information for regions.

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.
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4. Click the LBS Bubble Map icon and an empty chart appears.
5. On the Data tab page, select dimensions and measures.

On the Dimensions list, locate the province field to the Geo Location section. On
the Measures list, locate the order_amt and profit_amt fields and add them to the
Bubble Size (Measures) section respectively.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, and data display formats.

8. Click Save to save the dashboard.
In the upper-right corner of the chart, choose More Actions > Delete to delete the
chart.

Configure the style
• In the Basic Information section, you can configure the title, hyperlink, and

background color. This example uses Dark as the background color.

Note:
To configure a hyperlink used to jump to a report or an external page, select Show
Hyperlink and enter a name and address.

• In the Layout section, you can configure the legend position, base map, zoom 
settings, and map center. This example uses Google Map as the base map.

• In the Series Settings section, you can configure the measures' aliases, data display 
formats, and numbers of decimal places.
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Click Update and the chart is updated.

Delete a chart
In the upper-right corner of the chart, choose More Actions > Delete to delete the
chart.

3.5.26 LBS flying line maps
This topic describes the overview, examples, and deletion of an LBS flying line map.

Note:
Only Quick BI Enterprise Standard supports LBS flying line maps.

Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.
An LBS flying line map is a map that uses flying lines to display the relations between 
data across two or more locations.
An LBS flying line map consists of geographic locations and routes. Geographic 
locations are based on dimensions such as the province. Color scales are based on 
measures such as the order amount and order number.

218 Issue: 20190816



Quick BI User Guide /  3 Create dashboards

Overview
An LBS flying line map is a map that uses flying lines to display the relations between 
data across two or more locations.
An LBS flying line map consists of geographic locations and routes. Geographic 
locations are based on dimensions such as the province. Color scales are based on 
measures such as the order amount and order number.

Samples

Notes
You can only select one dimension for each geographic location and the dimensions
 must be Geo type fields such as the area, province, and city. You can select a 
maximum of one measure for the routes.
For more information, see Detailed information for regions.

Examples
The following example uses the company_sales_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
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3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.

4. Click the LBS Flying Line Map icon and an empty chart appears on the dashboard.
5. On the Data tab page, select dimensions and a measure.

On the Dimensions list, locate the area field and add it to the Geo Location (From)
section. Locate the province field and add it to the Geo Location (To) section. On
the Measures list, locate the shipping_cost field and add it to the Routes (Measures)
section as shown in the following figure.

Note:
Make sure that you have converted the dimension type from String to Geo for the
province and area fields. For more information, see Change the dimension type.

6. Click Update and the chart is updated.
7. On the Style tab page, you can configure the title, layout, and series setting as

shown in the following figure.
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8. Click Save to save the dashboard.
In the upper-right corner of the chart, choose More Actions > Delete to delete the
chart.

Configure the style
• In the Basic Information section, you can configure the title, hyperlink, and 

background color. This example uses Dark as the background color.
• In the Layout section, you can configure the legend position, base map, zoom

settings, and map center. This example uses Google Map as the base map.

Note:
You can adjust the flying speed by moving the Flying  Time  slider. The bigger
the slider value, the lower the flying speed.

• In the Series Setting section, you can configure the measure's alias and line color.
Click Update and the chart is updated.

Delete a chart
In the upper-right corner of the chart, choose More Actions > Delete to delete the
chart.
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3.5.27 Progress bars
This topic describes the overview, examples, and deletion of a progress bar.
Make sure that you have read Dashboard overview and Dashboard basic operations
before reading this topic. For more information about how to create a dataset, see
Create a dataset.

Overview
A progress bar displays the progress of a task.
A progress bar consists of multiple progress metrics. Progress metrics are 
determined by data measures such as the order number.

Samples

Notes
• You can select a minimum of one and a maximum of five measures for a progress 

bar.
• Choose Style > Series Settings and set the minimum and maximum values that a

progress bar can display.
Examples

Scenario: displays the order number. The following example uses the company_sa
les_record dataset.
1. Log on to the Quick BI console.
2. Click Datasets to go to the Datasets page.
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3. Select the company_sales_record dataset and click Create Dashboard.

Note:
If you use Quick BI Enterprise Standard, you need to select Standard or Full Screen
as the dashboard display mode. The following example uses the Standard display
mode.

4. Click the Progress Bar icon and an empty chart appears on the dashboard.
5. On the Data tab page, select measures.

On the Measures list, locate the order_number field and add it to the Pointer
(Measures) section as shown in the following figure.

6. Click Update and the chart is updated.
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7. On the Style tab page, you can configure the title, background color, hyperlink,
legend, and measures' aliases as shown in the following figure.

8. Click Save to save the dashboard.
Configure the style

• In the Basic Information section, you can configure the title, hyperlink, and 
background color of a chart. This example uses Dark as the background color.

• In the Layout section, you can select the position of legend and choose whether to 
show the tooltips.
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• In the Series Settings section, you can configure the measures' aliases, value ranges
, data formats, and numbers of decimal places.

Click Update and the chart is updated.

Delete a chart
Click the More Actions icon in the upper-right corner of a chart and select Delete
from the drop-down list to delete the chart.

3.6 Share dashboards, make dashboard public, transferdashboards, add dashboards to favorites, and change thesecurity level
You can share dashboards or make dashboards public.

Share a dashboard
1. Log on to the Quick BI console.
2. Select Workspaces > Dashboards.
3. On the dashboards page, select a dashboard, and click the Share icon.
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4. Set the expiration date and select the users that you want to share the dashboard
with, as shown in the following figure:

Note:
In Quick BI Pro and Quick BI Enterprise Standard, you can share dashboards with
the specified user groups, the specified users, or all users. In Quick BI Standard,
you can only specify users.

5. Click Save to share the dashboard.
Make a dashboard public

1. Log on to the Quick BI console.
2. Select Workspaces > Dashboards.
3. On the dashboards page, select a dashboard, right-click the dashboard and select

Make Public, or click the More icon and select Make Public.

226 Issue: 20190816



Quick BI User Guide /  3 Create dashboards

4. Set the expiration date and select Generate URL.

5. Click Make Public.
Rename a dashboard, transfer it, or change its security level

1. Log on to the Quick BI console.
2. Select Workspaces > Dashboards.
3. On the dashboards page, select a dashboard, right-click the dashboard and select

Properties, or click the Properties icon.
4. On the Properties page, you can rename the dashboard, transfer the dashboard

to another member, or change its security level. If the security level is set to
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Protected, other members in the workspace can edit the dashboard. They can use
the lock function to prevent their changes from being overwritten by others'.

Note:
The dashboard transfer and security level functions are only available in Quick BI
Pro and Quick BI Enterprise Standard workspaces.

Add a dashboard to favorites
You can use the following methods to add a dashboard to favorites:
• Go to the dashboards page, click the Add to Favorites icon before the dashboard

name.
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• Go to the dashboard edit page, click the Add to Favorites icon after the dashboard
name.

Note:
You can click the Add to Favorites icon again to remove a dashboard from your
favorites.
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4 Create workbooks
4.1 Workbook overview

Workbooks are available only in the workspace of Quick BI Pro and Quick BI
Enterprise Standard. You cannot create workbooks in personal spaces. You can only
add charts and filter bars in Quick BI Enterprise Standard.

Edit page description
The Edit page of a workbook is divided into the following areas:
• Dataset selection area
• Workbook configuration area
• Workbook display area

• Dataset selection area: In this area, you can switch datasets. The fields of each 
dataset are displayed in the Dimensions and Measures lists based on the data types
 preset in the system. You can select dimensions and measures based on the data in
 the chart.

• Workbook configuration area: In this area, you can select the expected chart type, 
and set the color, font, and data format of cells as needed.

• Workbook display area: In this area, you can reprocess data based on the displayed
 data in cells and reference data.

4.2 Basic workbook operations
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4.2.1 Create a workbook
After the datasets have been prepared, you can create workbooks based on the
prepared datasets. For more information about creating datasets, see #unique_76.
If you want to perform more complex operations on the fields, you need to go to
the dataset editing page to Convert Dimension to Measure, Convert Measure to
Dimension, Create Calculated Field, and Create Hierarchy.
After a dataset schema has been changed, you need to reload the workbook to view 
the changed dataset schema.
1. Log on to the Quick BI console.
2. Switch to a workspace, as shown in the following figure.
3. ClickWorkspace > Workbook, and enter the Workbooks page.
4. Click Create Workbook to open the workbook editing page.
5. Click the Data Preview icon to open the preview area.
6. Click the drop-down arrow to select a dataset.
7. Double-click or drag a field to the right-side panel, and then click Update.
8. The selected fields are automatically shown in the workbook.
9. Click Transpose > Update to transfer it to a two-dimensional table.
10.After you have selected the fields, click Save.
11.Enter a chart name, and select the location to save the workbook.
12.Click OK to finish creating the workbook.

4.2.2 Configure workbooks
You can configure workbooks on the Edit page.

Common functions
On the workbook Edit page, you can perform multiple operations on data, including
undo, redo, cut, copy, and paste, as shown in the following figure:
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Conditional formatting
Click the Conditional Formatting icon to set conditional formatting rules, for
example, highlight values within a specified value range.

Add images and hyperlinks
You can click the Upload Image and Hyperlink icons to add images and hyperlinks to
the workbook to visually optimize the workbook, as shown in the following figure:
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Add drop-down lists
You can click the Drop Down icon to add labels to the data records.

Note:
Separate multiple labels with commas (,).

Text format
This feature allows you to adjust the text format in charts.
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• Specify the text font, color, and background.
• Specify the text size and style (bold, italic, underline, and strikethrough).
• Specify the cell style (text alignment, text wrap, text indent, and cell merge).
• Specify the text formatting method (general, number, text, percentage, date, and 

custom settings)

Table properties
This feature allows you to adjust table properties.
• Insert rows, insert columns, delete rows, delete columns, autofit row height, and 

autofit column width.
• Group, ungroup, hide rows, hide columns, freeze rows, and freeze columns.
• Set borders.
• Sort, filter, and set table styles.

Global variables
You can set global variables in the workbook. You can use global variables to add 
hyperlinks to cross tables.
1. On the workbook Editing page, click the Global Variables icon.
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2. In the Global Variables dialog box, enter the required variable and click OK, as
shown in the following figure:

Create charts
In the workbook, you can create charts based on the data in the workbook. Currently
, you can create the following types of charts: line, vertical bar, pie, funnel, scatter, 
and radar charts. You can also create gauges and polar diagrams.
1. You can click a chart icon to create a chart, such as a vertical bar chart.
2. You need to select data sources in the workbook to create charts.
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3. Click OK. A chart is automatically created in the workbook.

4.2.3 Add filter bars
You can add filter bars to filter your data.

Procedure
1. Open the editing page of a workbook
2. Click the Filter Bar icon to open the editing page of the Filter Bar.
3. Click the +Add Correlated Datasets icon and select the datasets.

4. Select a field to be filtered such as shipping type by double-clicking or dragging it
to the Filter Fields area.
If Highlight Pivot Tables is set in the chart, you need to select the available pivot
tables for the field.

5. Click the Set Filter icon.
6. Select a chart that this field can affect, such as pivot table 1 in sheet 1. Select the

filter mode. For example, select Filter by Enumeration and Multiple Select.
7. In the drop-down menu, select the field to be queried, such as train, as shown in

the following figure.
8. Click OK to finish the filter settings.
9. Click Search to view the filtered result.
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4.2.4 Highlight pivot tables
You can use the highlight pivot table feature to show data in different pivot tables.
1. Open the workbook editing page
2. Click the Data Preview icon and select a dataset.
3. Double-click or drag the fields to the panel, and then click Update.
4. Click Highlight Pivot Table, and then select the area to show the data.
5. Double-click or drag the fields to the panel, and then click Update.
You can modify the display name for different pivot tables.

4.3 Search, move, and delete workbooks
You can search, move, and delete the workbooks that you have created.

Search workbooks
1. Log on to the Quick BI console.
2. Click Workbooks, enter a workbook name or username in the search box on the

workbooks page.

3. Click the Search icon to search for the workbook.
Move workbooks

1. Log on to the Quick BI console.
2. Click Workbooks, select a workbook on the workbooks page. Click the More icon,

or right-click the workbook.
3. Select Move To.

Issue: 20190816 237



Quick BI User Guide /  4 Create workbooks

4. Select a directory and click Save.

Delete workbooks
1. Log on to the Quick BI console.
2. Click Workbooks, select a workbook on the workbooks page. Click the More icon,

or right-click the workbook.
3. Select Delete to delete the workbook.

4.4 Manage workbooks
On the workbooks page, you can create, rename, and delete workbook folders.

Create a workbook folder
1. Log on to the Quick BI console.
2. Click Workbooks, click Create Folder on the workbooks page, and enter a folder

name.
3. Click OK to create the folder.

Rename a workbook folder
1. Log on to the Quick BI console.
2. Click Workbooks, select a workbook folder on the workbooks page, click the

Rename icon, or right-click the folder and select Rename.
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3. Enter a new folder name, and clickOK.

Create a workbook folder
1. Log on to the Quick BI console.
2. Click Workbooks, select a workbook folder on the workbooks page, click the Delete

icon, or right-click the folder and select Delete.
3. Click OK to delete the workbook folder.
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5 BI portals
5.1 BI portal overview

A BI portal is a set of dashboards, workbooks, and external links organized with
menus. You can use a BI portal to perform complex topic-based data analysis with
navigation menus.

5.2 Create a BI portal
This topic describes how to create a BI portal.

Procedure
1. Log on to the Quick BI console, and select a workspace.
2. In the left-side navigation pane, select BI Portals.
3. Click Create BI Portal.

4. On the BI portal edit page, set the parameters, and then click Save.

5.3 Configure page settings
On the page settings page, you can set the title, logo, and footer of a BI portal page.

Procedure
1. Log on to the Quick BI console, and select a workspace.
2. In the left-side navigation pane, select BI portals.
3. On the BI portals page, click a BI portal name.

You can also create a BI portal. For more information, see #unique_170.
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4. Click the Settings icon to edit the BI portal page.
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5. Click Save.

5.4 Configure menus
On the menu settings page, you can set the title, links, and other information of a
menu.

Procedure
1. Log on to the Quick BI console, and select a workspace.
2. In the left-side navigation pane, select BI Portals.
3. On the data portals page, click a BI portal name.

You can also create a BI portal. For more information, see #unique_170.
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4. Select a menu level from the left-side list, and edit the menu on the right-side
Detail Settings page.

• You can select a menu on the Menu Settings page and edit the menu.
• You can add dashboards or workbooks to menus.
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5. Click Save.

5.5 Share, rename, and transfer BI portals and change securitylevel
The share function allows you to share BI portals with other users. You can edit the
properties of a BI portal. You can rename a BI portal, transfer it to another user, or
change its security level.

Share a BI portal
1. Log on to the Quick BI console, and select a workspace.
2. In the left-side navigation pane, select BI Portals.
3. On the BI portals page, right-click a BI portal, and select Share.
4. Set the expiration date and select the users that you want to share the BI portal

with.

Rename a BI portal, transfer it, or change its security level
1. Log on to the Quick BI console, and select a workspace.
2. In the left-side navigation pane, select BI Portals.
3. On the BI portals page, right-click a BI portal, and select Edit Properties.
4. On the properties page, you can rename the BI portal, transfer it to another user in

the workspace, or change its security level. If the security level is set to Protected,
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other members in the workspace can edit the BI portal. They can use the lock
function to prevent their changes from being overwritten by the other users.

Note:
The BI portal transfer and security level functions are only available in group
workspaces.

5.6 BI portal menu permissions
For more information about managing permissions of BI portal menus, see
#unique_174.
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6 Privilege control
6.1 Basic concepts of permission management

Permission management include data object management and row-level permission
management.
Data objects include data sources, datasets, workbooks, dashboards, and portals. 
Data object management is classified based on the workspace types, which include 
the personal workspace and the workspace.

Row-level permission
You do not need to configure row-level permission for all fields in a dataset. Configure
 row-level permission for certain fields as needed.
Currently, for a single field, the maximum number of values that can be shown on the
 list is 500. If the number of values exceeds 500, you can add the excess values to the 
list manually.
You can find the All check box on the list. If you select the All check box (equivalent to
selecting all values of a field) for a member of the organization, then the member can
access the dataset without restriction from this field. You do not need to reselect the
All check box after adding or deleting values for this field.
Significant time for configuring permissions is saved for administrators through 
selecting the All check box.

Manage data objects in a workspace
Quick BI supports sharing and publishing data objects in a workspace.
Share data objects in a workspace
Quick BI supports sharing workbooks, dashboards, and portals. Shared data objects
are read-only for other Alibaba Cloud accounts and RAM users. Other Alibaba Cloud
accounts and RAM users do not have permission to modify, delete or save the data
objects.
• Only the owner of the data object and the administrators of the workspaces have 

permissions to share the data object.
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• If you clear the Works can be authorized checkbox for a workspace, then the data 
objects in this workspace cannot be shared.

• Currently, data objects can only be shared with Alibaba Cloud accounts and RAM 
users of the same organization.

Members can access the data objects in the workspace that they belong to.
Data objects can be shared with members of the same organization. Authorized users
can view the shared data objects in their own personal workspaces.
Publish data objects in a workspace
Data objects that have been published can be accessed by everyone using the URLs. 
We recommend that you do not publish data objects that involve private business data
.

Manage data objects in the personal workspace
Only the owner of a personal workspace has permission to perform operations on the
 data objects.
Share data objects in the personal workspace
Quick BI supports sharing workbooks, dashboards, and portals. Shared data objects
are read-only for other Alibaba Cloud accounts and RAM users. Other Alibaba Cloud
accounts and RAM users do not have permissions to modify, delete or save the data
objects.
• Only the owner of the data objects has permission to share them.
• Data objects can only be shared with users of Alibaba Cloud Quick BI.
Authorized users can view the shared data objects in their own personal workspaces.
Publish data objects in the personal workspace
Data objects that have been published can be accessed by everyone using the URLs. 
We recommend that you do not publish data objects that involve private business data
.

6.2 Configure row-level permissions
Row-level permissions are performed based on datasets. Quick BI supports
the following authorization modes: User/User Group Authorization and Tag
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Authentication. Currently, only Quick BI Pro and Quick BI Professional Edition
support performing row-level permissions based on datasets.
The User/User Group Authorization mode applies to scenarios that involve a small 
number of members. The Tag Authentication mode applies to scenarios that involve
 a large number of members. Tag Authentication authorizes all users at once instead
 of implementing authorization for users/user groups separately. In scenarios 
that involve a large number of members, using Tag Authentication reduces costs
 and complexity for configuring row-level permissions and makes it easier for 
management.

User/User Group Authorization
1. Log on to the Quick BI console.
2. Select a workspace. If you need to create a workspace, see #unique_178.
3. Click the Datasets icon to jump to the Datasets page.
4. Select a dataset. Click the More icon in the Actions column or right click the

dataset.
5. Select Row-Level Permissions.
6. Select theEnable Row-Level Access Control > User/User Group Authorizationcheck

box to enable row-level permissions.
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7. Click the drop-down arrow. Select the fields to perform row-level permissions,
such as province and metrics, as shown in the following figure.

The values of the metrics field are the metrics in the dataset. By performing row-
level access permissions on the metrics field, users have access to different data
rows that are corresponding to the values of the metrics field.

8. Click the province field in the Permissions list. Then all values of the province field
are listed as shown in the following figure.
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9. Select a member. Then select the values of the province field to grant row-level
permission to the user as shown in the following figure.

The member can only view the data rows where the value of the province field is
Shanghai or Yunnan.

Note:
Specify for all members of the workspace whether they have permissions to
access the data rows that are corresponding to the values of the field, on which
row-level permissions have been performed. Members, who haven't been specified
the permission for, do not have permissions to access any data reports generated
from the dataset by default.

10.Click Add to complete the configuration of row-level permissions.
Tag Authentication

Scenario: Users can only access the data rows in the company_sales_record dataset
where the value of the shipping_type is truck or air.
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Set member tags
1. On the Settings page, select Edit Member Tags in the Actions column for the

member to authorize as shown in the following figure.

2. In the Edit Member Tags dialog box, set the value of the area tag to air, truck and
clickOK.

After setting the member tags, set tag authentication in the Row-Level Access dialog 
box for the dataset.
Set tag authentication
1. Select the company_sales_record dataset. Click the More icon in the Actions

column or right click the dataset.
2. Select Row-Level Permissions.
3. Select the Enable Row-Level Access Control > Tag Authentication check box to

enable row-level permissions.
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4. From the Field drop-down list, select shipping_type. Select area as Tag Parameter.
Click OK to complete the settings.

After tag authentication is complete, the user can only access data rows where the
shipping_type is air or truck.

6.3 Configure BI portal menu permissions
Workspace administrators can manage permissions to view BI portal menus.
You can grant menu permissions to a specified user or user group. Procedure:
1. Log on to the Quick BI console.
2. Select the target workspace. For more information about creating a workspace, see

#unique_178.
3. In the left-side navigation pane, click BI Portals to go to the BI Portals page.
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4. On the BI Portals page, select the target portal and click the More icon in the
Actions column, or right-click the target portal and select Menu Permissions, as
shown in the following figure:

5. In the Manage Menu Permissions dialog box, select the target menu, specify
whether the menu is available only to authorized users, and select the users or user
groups that you need to authorize.

Note:
For more information about Available Only to Authorized Users, see the following
description:
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• Yes: Only authorized user groups and users have permissions to view the 
specified menu.

• No: All users have permissions to view the specified menu.
For more information about user groups, see #unique_180.

6. Click OK to complete the configuration.
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7 Email subscriptions
The email subscription function of Quick BI allows you to use emails to send pictures
of dashboards or workbooks to users periodically. This function is only available in
Quick BI Pro and Quick BI Enterprise Standard.

7.1 Create an email subscription
You can create an email subscription to send emails to the specified recipients.
1. Log on to the Quick BI console.
2. Click Subscriptions.
3. On the email subscriptions page, click +Subscribe.
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4. On the Subscribe page, set the following parameters:

• Subject
• Header: the header of the email.
• Body: the main content of the email, which can be a dashboard or workbook.

To make sure that the email can be sent properly, we recommend that the
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dashboard contains no more than 4,000 pixels in height and the workbook
contains no more than 200 rows and 50 columns.

• Footer: the footer of the email.
• Owner: the user that creates the email subscription. The owner cannot be 

changed.
• Recurrence: the frequency for sending emails.

• Start From
• Recipients: only Alibaba Cloud accounts in the same organization are

supported. If an account is in the grey color, this means that the account does
not have an email address. You must set an email address for the account first.

Note:
You can set an email address for the account in the Personal settings, as shown
in the following figure:

258 Issue: 20190816



Quick BI User Guide /  7 Email subscriptions

5. Click Save to create the email subscription.

7.2 Manage email subscriptions
You can go to the subscriptions page to manage the email subscriptions you have
created.
The following operations are all completed on the subscriptions page. Follow these
steps to go to the subscriptions page:
1. Log on to the Quick BI console
2. Click Subscriptions to go to the email subscriptions page.
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Search email subscriptions
Enter an email subscription name into the search
box and select an email status to search for the email
subscription.

Note:
The following email statuses are available:
• Pending Schedule
• Sending
• Sent
• Canceled
• Error

Edit email subscriptions
Click the Edit icon to edit an email subscription.

Manually send emails
Click the Manually Send icon, and set the business date and recipients in the dialog
box. This function ignores the email subscription schedule and sends an email
immediately. The business time affects the base time depending on which data is
collected for building the dashboard.
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Suspend scheduling
Click the Suspend Scheduling icon to suspend an email subscription.

More actions
Click the More icon to perform the following actions:
• Delete: delete the email subscription.
• Notify: send a notification to the subscription user.
• View log: view the email subscription log as shown in the following figure. You can

check the log when the system failed to send emails.
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