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Legal disclaimer
Alibaba Cloud reminds you t o carefully read and fully underst and t he t erms and condit ions of t his legal
disclaimer before you read or use t his document . If you have read or used t his document , it  shall be deemed
as your t ot al accept ance of t his legal disclaimer.

1. You shall download and obt ain t his document  from t he Alibaba Cloud websit e or ot her Alibaba Cloud-
aut horized channels, and use t his document  for your own legal business act ivit ies only. The cont ent  of
t his document  is considered confident ial informat ion of Alibaba Cloud. You shall st rict ly abide by t he
confident ialit y obligat ions. No part  of t his document  shall be disclosed or provided t o any t hird part y for
use wit hout  t he prior writ t en consent  of Alibaba Cloud.

2. No part  of t his document  shall be excerpt ed, t ranslat ed, reproduced, t ransmit t ed, or disseminat ed by
any organizat ion, company or individual in any form or by any means wit hout  t he prior writ t en consent  of
Alibaba Cloud.

3. The cont ent  of t his document  may be changed because of product  version upgrade, adjust ment , or
ot her reasons. Alibaba Cloud reserves t he right  t o modify t he cont ent  of t his document  wit hout  not ice
and an updat ed version of t his document  will be released t hrough Alibaba Cloud-aut horized channels
from t ime t o t ime. You should pay at t ent ion t o t he version changes of t his document  as t hey occur and
download and obt ain t he most  up-t o-dat e version of t his document  from Alibaba Cloud-aut horized
channels.

4. This document  serves only as a reference guide for your use of Alibaba Cloud product s and services.
Alibaba Cloud provides t his document  based on t he "st at us quo", "being defect ive", and "exist ing
funct ions" of it s product s and services. Alibaba Cloud makes every effort  t o provide relevant  operat ional
guidance based on exist ing t echnologies. However, Alibaba Cloud hereby makes a clear st at ement  t hat
it  in no way guarant ees t he accuracy, int egrit y, applicabilit y, and reliabilit y of t he cont ent  of t his
document , eit her explicit ly or implicit ly. Alibaba Cloud shall not  t ake legal responsibilit y for any errors or
lost  profit s incurred by any organizat ion, company, or individual arising from download, use, or t rust  in
t his document . Alibaba Cloud shall not , under any circumst ances, t ake responsibilit y for any indirect ,
consequent ial, punit ive, cont ingent , special, or punit ive damages, including lost  profit s arising from t he
use or t rust  in t his document  (even if Alibaba Cloud has been not ified of t he possibilit y of such a loss).

5. By law, all t he cont ent s in Alibaba Cloud document s, including but  not  limit ed t o pict ures, archit ect ure
design, page layout , and t ext  descript ion, are int ellect ual propert y of Alibaba Cloud and/or it s
affiliat es. This int ellect ual propert y includes, but  is not  limit ed t o, t rademark right s, pat ent  right s,
copyright s, and t rade secret s. No part  of t his document  shall be used, modified, reproduced, publicly
t ransmit t ed, changed, disseminat ed, dist ribut ed, or published wit hout  t he prior writ t en consent  of
Alibaba Cloud and/or it s affiliat es. The names owned by Alibaba Cloud shall not  be used, published, or
reproduced for market ing, advert ising, promot ion, or ot her purposes wit hout  t he prior writ t en consent  of
Alibaba Cloud. The names owned by Alibaba Cloud include, but  are not  limit ed t o, "Alibaba Cloud",
"Aliyun", "HiChina", and ot her brands of Alibaba Cloud and/or it s affiliat es, which appear separat ely or in
combinat ion, as well as t he auxiliary signs and pat t erns of t he preceding brands, or anyt hing similar t o
t he company names, t rade names, t rademarks, product  or service names, domain names, pat t erns,
logos, marks, signs, or special descript ions t hat  t hird part ies ident ify as Alibaba Cloud and/or it s
affiliat es.

6. Please direct ly cont act  Alibaba Cloud for any errors of t his document .
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Document conventions
St yle  Descript ion  Example

 Danger
A danger notice indicates a situation that
will cause major system changes, faults,
physical injuries, and other adverse
results.

 Danger:

Resetting will result  in the loss of user
configuration data.

 Warning
A warning notice indicates a situation
that may cause major system changes,
faults, physical injuries, and other adverse
results.

 Warning:

Restarting will cause business
interruption. About 10 minutes are
required to restart an instance.

 Not ice
A caution notice indicates warning
information, supplementary instructions,
and other content that the user must
understand.

 Not ice:

If the weight is set to 0, the server no
longer receives new requests.

 Not e
A note indicates supplemental
instructions, best practices, t ips, and
other content.

 Not e:

You can use Ctrl + A to select all files.

>
Closing angle brackets are used to
indicate a multi-level menu cascade.

Click Set t ings   > Net work > Set  net work 
t ype .

Bold
Bold formatting is used for buttons ,
menus, page names, and other UI
elements.

Click OK.

Courier font Courier font is used for commands
Run the cd /d C:/window  command to
enter the Windows system folder.

Italic Italic formatting is used for parameters
and variables.

bae log list  --instanceid

Instance_ID

[] or [a|b]
This format is used for an optional value,
where only one item can be selected.

ipconfig [-all|-t]

{} or {a|b}
This format is used for a required value,
where only one item can be selected.

switch {active|stand}
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The MaxCompute console provides a query editor for you to execute SQL statements and analyze data.
This topic describes how to use the query editor.

Overview
The query editor of MaxCompute is integrated into the DataAnalysis tool of DataWorks. You can use
the query editor to edit  MaxCompute SQL statements, query data, analyze data in workbooks, share
data online, and download data. You can use the query editor to perform the following operations:

Edit  and execute SQL statements and authorization commands, such as access control list  (ACL)-
based authorization commands.

Enable the MaxCompute Query Acceleration (MCQA) feature. After this feature is enabled, the t ime
that is used to run small- and medium-sized query jobs is reduced from minutes to seconds. For more
information about MCQA, see MCQA overview.

Use and test  MaxCompute based on its public datasets. By default , the public datasets are open to
users.

Analyze, download, and share query results by using Web Excel online.

Scenarios
The query editor can be used in the following scenarios:

If  you use and test  MaxCompute for the first  t ime, you can use the query editor to experience the
core features of MaxCompute based on the public datasets.

If  you are a data analyst, you can use the query editor to query data. Then, you can switch to the
analysis mode to analyze the query results by using Web Excel online. To reduce the frequency at
which data is transferred and ensure data security, you can also download the query results to your
computer for analysis.

If  you are a security administrator, you can find a required project  and click Project  permission
management  in the Act ions column to manage role permissions. However, this feature is in trial use.
In many scenarios, you must run commands to manage permissions. The query editor allows you to
run most of the security commands without the need to perform addit ional configurations.

Open the query editor
1. Log on to the MaxCompute console, select  a region in the top navigation bar, and then click Query

edit ing  to open the query editor.

2. In the Select  Dat asource   dialog box, select  MaxComput e  for T ype  and select  an exist ing
project  from the Workspace drop-down list .

1.Query editor

MaxComput e Tools and Downloads·Query edit or
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Not e   If  you select  a project  that is associated with a workspace in standard mode and
submit  a job by using the query editor, the job is submitted in a development project. The name
of such a project  is ended with _dev.

3. Click OK. The SQL Query page appears.

Query mode and analysis mode
The query editor can work in query mode or analysis mode. This feature is integrated into the
DataAnalysis tool of DataWorks. For more information, see DataAnalysis. The components displayed in
query mode are different from those displayed in analysis mode.

Query mode

Tools and Downloads·Query edit or MaxComput e

7 > Document  Version: 20210713

https://www.alibabacloud.com/help/doc-detail/119756.htm#concept-270168


No. Description

① The name of the workspace.

②
Tables in the workspace, tables that have been used, and public
datasets.

③

The editor, which allows you to execute SQL statements and run
authorization commands, such as ACL-based authorization
commands. On the SQL Query page, you can edit  a script without the
need to create a file. You can also save the script as a file.

④
The tabs that allow you to view the saved query files, history, logs,
and results.

Analysis mode

After you execute SQL statements in query mode, you can click Analyze in Spreadsheet  in the
lower-right corner of the page to enter the analysis mode.

MaxComput e Tools and Downloads·Query edit or
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No. Description

① The toolbar that you use to edit  and manage data in a workbook.

② The query results.

Tools and Downloads·Query edit or MaxComput e
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You can use the MaxCompute client  to access MaxCompute projects and run commands. This topic
describes how to install, configure, and run the MaxCompute client  and provides other related
instruct ions.

Prerequisites
Before you use the MaxCompute client, make sure that the following condit ions are met:

Java 8 or a later version is installed on the device on which you want to install the MaxCompute client.

A MaxCompute project  is created.

For more information about how to create a MaxCompute project, see Create a MaxCompute project.

A RAM user as which you want to use the MaxCompute client  is added to the DataWorks workspace
to which the MaxCompute project  belongs.

For more information about how to add members to a workspace, see Add a workspace member and
configure roles.

Context
After the MaxCompute client  is installed and configured, you can start  the MaxCompute client  by using
the script  f ile under the installat ion path or by running commands in the command-line interface (CLI) of
the system. The MaxCompute client  allows you to perform the following operations:

Obtain the information about the current logon user. For more information, see Obtain information of
the current logon user.

Exit  the MaxCompute client. For more information, see Exit  the MaxCompute client.

Obtain help information about commands. For more information, see Obtain help information about
commands.

If  you want to start  the MaxCompute client  by running commands in the CLI, you must specify
parameters in the commands. For more information, see Specify startup parameters.

Limits
MaxCompute client  V0.28.0 and later support  Java Development Kit  (JDK) 1.9. The MaxCompute client  of
a version earlier than V0.28.0 supports only JDK 1.8. You can view the client  version in the CLI after you
start  the MaxCompute client. For more information about how to start  the MaxCompute client, see Run
the MaxCompute client.

Usage notes
The output format of the MaxCompute client  may not be forward compatible. The command syntax
and execution rules of the client  vary based on the client  version. We recommend that you do not
rely on the output format of the client  to parse data. For more information about client  versions, see
aliyun-odps-console.

Two consecutive minus signs (--) are used to comment out a command line on the MaxCompute
client.

Install and configure the MaxCompute client

2.MaxCompute client

MaxComput e Tools and Downloads·MaxComput e 
client

> Document  Version: 20210713 10

https://www.alibabacloud.com/help/doc-detail/27815.htm#task-zl2-mtx-5db
https://www.alibabacloud.com/help/doc-detail/194473.htm#task-1954109
https://github.com/aliyun/aliyun-odps-console/releases


Not e   MaxCompute client  V0.27.0 and later support  the MaxCompute V2.0 data type edit ion.
We recommend that you use the MaxCompute V2.0 data type edit ion. For more information about
the supported data types, see MaxCompute V2.0 data type edit ion.

To install and configure the MaxCompute client, perform the following steps:

1. Download the MaxCompute client  installat ion package.

2. Decompress the downloaded package to obtain the bin, conf, lib, and plugins folders.

3. Open the conf folder and configure the odps_config.ini f ile.

The following example shows the content in the odps_config.ini f ile.

project_name=
access_id=
access_key=
end_point=
log_view_host=
https_check=
# confirm threshold for query input size(unit: GB)
data_size_confirm=
# this url is for odpscmd update
update_url=
# download sql results by instance tunnel
use_instance_tunnel=
# the max records when download sql results by instance tunnel
instance_tunnel_max_record=
# IMPORTANT:
#   If leaving tunnel_endpoint untouched, console will try to automatically get one from odps service, w
hich might charge networking fees in some cases.
#   Please refer to Configure endpoints
# tunnel_endpoint=
# use set.<key>=
# e.g. set.odps.sql.select.output.format=

In the odps_config.ini f ile, lines that start  with a number sign (#) are comments. The following table
describes the parameters in the file.

Parameter Required Description Example

Tools and Downloads·MaxComput e 
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project_name Yes

The name of the MaxCompute
project that you want to
access.

If you create a workspace in
standard mode, pay attention
to the differences of the
project names between the
production environment and
development environment
when you specify this
parameter. The names of the
projects in the development
environment end with _dev. For
more information, see Basic
mode and standard mode.

You can log on to the
MaxCompute console and view
the MaxCompute project names
on the Project  Management
tab.

doc_test_dev

access_id Yes

The AccessKey ID of your
Alibaba Cloud account or a RAM
user within the Alibaba Cloud
account.

You can obtain the AccessKey ID
from the Security Management
page.

None

access_key Yes

The AccessKey secret that
corresponds to the AccessKey
ID.

You can obtain the AccessKey
secret from the Security
Management page.

None

Parameter Required Description Example
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end_point Yes

The endpoint of MaxCompute.

You must set this parameter
based on the region and
network connection method
you selected when you create
the MaxCompute project. For
more information about the
endpoints that correspond to
each region and network, see
Endpoints.

Not ice   If the
endpoint that you
configured is invalid, an
error occurs when you
access MaxCompute.

http://service.cn-
hangzhou.maxcompute.aliyun.c
om/api

log_view_hos
t

No

The Logview Uniform Resource
Locator (URL). You can view the
detailed runtime information of
a job by using this URL. This
information helps you locate
job errors. Set the value to
http://logview.odps.aliyun.com
.

Not e   We
recommend that you set
this parameter. If you do
not set this parameter, you
cannot locate the cause of
job errors.

http://logview.odps.aliyun.com

https_check No

Specifies whether to enable
HTTPS access. If HTTPS access
is enabled, requests to access
MaxCompute projects are
encrypted. Valid values:

True: HTTPS access is used.

False: HTTP access is used.

Default value: False.

True

data_size_co
nfirm

No

The maximum size of input
data, in GB. The value range is
unlimited. We recommend that
you set this parameter to 100.

100

Parameter Required Description Example
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update_url No A reserved parameter. None

use_instance_
tunnel

No

Specifies whether to use
InstanceTunnel to download
the results of SQL statements.
Valid values:

True: InstanceTunnel is used
to download the results of
SQL statements.

False: InstanceTunnel is not
used to download the
results of SQL statements.

Default value: False.

True

instance_tunn
el_max_recor
d

No

The maximum number of SQL
execution results that can be
returned by the client. You
must specify this parameter if
the use_instance_tunnel
parameter is set to True.
Maximum value: 10000.

10000

tunnel_endpo
int

No

The public endpoint of
MaxCompute Tunnel. If you do
not specify this parameter,
traffic is automatically routed
to the Tunnel endpoint that
corresponds to the network
where MaxCompute resides. If
you specify this parameter,
traffic is routed to the specified
endpoint and automatic routing
is not performed.

For more information about the
Tunnel endpoints that
correspond to each region and
network, see Endpoints.

http://dt.cn-
hangzhou.maxcompute.aliyun.c
om

set.<key> No

The properties of the
MaxCompute project.

For more information about the
properties of MaxCompute
projects, see Properties.

set.odps.sql.decimal.odps2=tru
e

Parameter Required Description Example

Run the MaxCompute client
You can start  the MaxCompute client  by using one of the following methods:

Method 1: In the bin folder under the installat ion path of the MaxCompute client, double-click the  o
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dpscmd.bat  f ile to start  the MaxCompute client. If  information shown in the following figure is
returned, the MaxCompute project  is connected.

Method 2: In the CLI of the system, go to the bin folder under the installat ion path of the
MaxCompute client  and run the  odpscmd  command to start  the MaxCompute client. If  information
shown in the following figure is returned, the MaxCompute project  is connected.

You can enter a command at  the cursor shown in the preceding figure and press Enter to run the
command. The following figure shows the sample command and returned results.

Tools and Downloads·MaxComput e 
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Not e   For more information about the command syntax supported by the MaxCompute
client, see Common commands or SQL commands and functions.

Obtain information of the current logon user
You can run the following command in the CLI to obtain the information of the current logon user:

odps@project_name>whoami;

The following figure shows the returned result .

Name: the account of the current logon user.

Source IP: the IP address of the device where the MaxCompute client  is located.

MaxComput e Tools and Downloads·MaxComput e 
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End_Point: the endpoint  of MaxCompute.

Project: the name of the MaxCompute project.

Exit  the MaxCompute client
You can run the following command in the CLI to exit  the MaxCompute client:

odps@project_name>quit;
-- The preceding command is equivalent to the following command. 
odps@project_name>q;

Obtain help information about commands
You can obtain help information about the commands of the MaxCompute client  by using one of the
following methods:

Method 1: View the help information about commands on the MaxCompute client.

View help information about all commands.

odps@project_name>help;
-- The preceding command is equivalent to the following command. 
odps@project_name>h;

Specify a keyword to view the help information about the related commands.

Example: Obtain the help information about the commands related to table operations.

odps@project_name>help table;
-- Returned results: 
Usage: alter table <tablename> merge smallfiles
Usage: export table <tablename>
Usage: show tables [in <project_name>] [like '<prefix>']
       list|ls tables [-p,-project <project_name>]
Usage: describe|desc [<projectname>.]<tablename> [partition(<spec>)]
Usage: read [<project_name>.]<table_name> [(<col_name>[,..])] [PARTITION (<partition_spec>)] [line_n
um]

Method 2: In the CLI of the system, go to the bin folder under the installat ion path of the
MaxCompute client, and run the following command to view the help information about all
commands. If  you start  the MaxCompute client  by running commands in the CLI, you can specify a
series of parameters in the commands. For more information about these parameters, see Specify
startup parameters.

..\odpscmd\bin>odpscmd -h

Specify startup parameters
In the CLI of the system, you can specify a series of parameters to run a command. The following code
shows the usage of these parameters.

Tools and Downloads·MaxComput e 
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Usage: odpscmd [OPTION]...
where options include:
    --help                                  (-h)for help
    --config=<config_file>                  specify another config file
    --project=<prj_name>                    use project
    --endpoint=<http://host:port>           set endpoint
    -k <n>                                  will skip begining queries and start from specified position
    -r <n>                                  set retry times
    -f <"file_path;">                       execute command in file
    -e <"command;[command;]...">            execute command, include sql command

The following table describes the startup parameters.

Parameter Description Sample command

 --help  or  -h Obtains the help information about all
commands of the MaxCompute client.  odpscmd --help 

 --config 

Specifies the directory where the
configuration file odps_config.ini is
saved. The default directory is
 odpscmd_public/conf/odps_config.ini 

.

 odpscmd --
config=D:/odpscmd/conf/odps_config.in
i  

 --project Specifies the name of the MaxCompute
project that you want to access.  odpscmd --project=doc_test 

 --endpoint 
Specifies the endpoint of MaxCompute.
For more information about endpoints,
see Configure endpoints.

 odpscmd --endpoint=http://service.cn-
shanghai.maxcompute.aliyun.com/api 

 -k 

Executes the statement from the
specified location. If  n  is set to a value
that is less than or equal to 0, the
execution starts from the first
statement. Multiple statements are
separated by semicolons (;).

Run the following command to ignore
the first  two statements and start to
execute from the third statement:
 odpscmd -k 3 -e "drop table

table_name;create table table_name
(dummy string);insert overwrite table
table_name select count(*) from
table_name;" 

 -r Specifies the number of retries allowed
when the job fails to run.

 odpscmd -r 2 -e "select * from
sale_detail;select * from table_test;" 

MaxComput e Tools and Downloads·MaxComput e 
client
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 -f Specifies the file to read.

1. Prepare a script file named
script.txt. In this example, the file is
stored in drive D and contains the
following data:

drop table if exists 
test_table_mj;
create table test_table_mj (id 
string, name string);
drop table test_table_mj;

2. In the CLI, go to the bin folder under
the installation path of the
MaxCompute client and run the
following command:

..\odpscmd\bin>odpscmd -f 
D:/script.txt;

 -e Specifies the command that you want to
run.

 odpscmd -e "select * from
sale_detail;" 

Parameter Description Sample command

The dynamic return value of an  odpscmd -e  command may be called by a shell script  that is run in a
shell window or the Command Prompt in Windows. A shell variable may obtain the return value and use
it  in subsequent jobs. In this scenario, only field values are required. Other information, such as runtime
information and headers, must not be returned. To help you call shell commands more easily, you can
run the  set odps.sql.select.output.format={"needHeader":false,"fieldDelim":""};  command to disable
header display.

For example, a table named noheader has one column and three rows of data. The field values are 1, 2,
and 3. After you run the following command to redirect  the standard output of the query result  to the
destination handle, the output contains only field values.

odpscmd -e "set odps.sql.select.output.format={"needHeader":false,"fieldDelim":""};select * from noheader
;" >/temp/test.txt
-- Returned results: 
1
2
3

Version updates
The following table describes the latest  version updates of the MaxCompute client. For more
information, click the URL of a specific version.

Version Change type Description

Tools and Downloads·MaxComput e 
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v0.36.0-public

New feature
An external project can be created to connect to Data Lake
Formation (DLF). This implements the Alibaba Cloud LakeHouse
feature.

Fixed issue
The issue that the nanosecond part of data of the T IMESTAMP
type is incorrectly processed is fixed.

Version Change type Description
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MaxCompute IDEA

MaxCompute Studio is a big data integrated development environment (IDE) tool that is provided by
Alibaba Cloud MaxCompute. It  is a development plug-in based on the widely adopted integrated
development environment IntelliJ IDEA. You can install this plug-in on the clients of developers to
facilitate data development. This topic describes the functional interfaces and common application
scenarios of MaxCompute Studio.

Basic user interface
MaxCompute Studio is a plug-in on the IntelliJ IDEA platform. It  shares basic development interfaces
with IntelliJ IDEA. For more information, see Guided Tour around the User Interface.

MaxCompute Studio provides the following features based on IntelliJ IDEA:

SQL Edit or : provides features such as SQL syntax highlighting, code completion, real-t ime error
prompts, local compilat ion, and job submission.

Compiler View displays the prompts and error messages of statements that are locally compiled, and
locates the code in the editor.

Project  Explorer : connects to a MaxCompute project  and allows you to browse table schemas, user
defined functions (UDFs), and resource files in the project. For more information, see Manage project
connections.

Table Details View displays the details and sample data of tables, views, and other resources.

Job Explorer: allows you to browse and search the MaxCompute job history.

Job Details View: displays the running details about a job, including the execution plan and details
about each execution task. You can view all information about a job in Logview.

Job Output View: displays output information for jobs that are running.

Job Result  View: displays output results for SELECT jobs.

MaxComput e Console : integrated with the MaxCompute client. You can enter and run
MaxCompute client  commands in the MaxCompute console.

Connect to a MaxCompute project
Before you use the features of MaxCompute Studio, you must create a project  connection. For more
information, see Manage project connections. After you create a project  connection, you can view related
data structure and resource information in Project  Explorer . MaxCompute Studio creates a local
metadata backup task for each project. This increases the access frequency to MaxCompute metadata
and reduces latency.

You must specify a MaxCompute project  connection so that you can use MaxCompute Studio to modify
SQL scripts, submit  jobs, view job information, open the MaxCompute console, and implement other
features. For more information about MaxCompute projects, see Project. For more information about
how to manage projects in MaxCompute Studio, see Manage project connections.

Manage data

3.MaxCompute Studio
3.1. What is MaxCompute Studio?
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You can use Project  Explorer  in MaxCompute Studio to browse table schemas, UDFs, and resource files
in projects. You can use the tree view hierarchy to list  data tables, columns, part it ion key columns,
virtual views, UDFs, function signatures, resource files, and types of resource files for all project
connections. You can also use the tree view hierarchy to locate an object.

You can double-click a data table to open T able Det ails View   to view the metadata, data schema,
and sample data of the data table. If  you do not have the permissions on the connected project,
MaxCompute Studio displays an error message.

MaxCompute Studio is integrated with MaxCompute Tunnel to allow you to upload and download local
data. For more information, see Import and export data.

Write SQL scripts
You can write MaxCompute SQL scripts in MaxCompute Studio.

1. Open MaxCompute Studio and choose File > New > Project  or File > New > Module….

2. Create a MaxCompute Studio project  or a MaxCompute Studio module.

3. Choose File > New > MaxComput e SQL Script   or right-click the menu and choose New >
MaxComput e SQL Script   to create a MaxCompute SQL script  f ile.

Not e   When you create a MaxCompute SQL script, MaxCompute Studio prompts you to
select  a MaxCompute project  to associate with. You can also use the Project  Select or   on the
right of the toolbar of the SQL Editor to modify the associated project. The SQL Editor checks
the metadata such as table schemas based on the project  that is associated with the SQL
script  and reports errors in the script. When an SQL statement is submitted, the SQL Editor also
sends the SQL statement to the associated project  to execute. For more information, see Write
SQL.

Intelligent error prompts in SQL code
The SQL Editor of MaxCompute Studio intelligently checks the code that you enter. It  can display
prompts for syntax errors, type matching errors, or warnings of SQL statements and mark code errors in
real t ime.

MaxCompute Studio provides the code completion feature. It  can display the project  name, table,
column, function, type, and code keywords based on context, and complement code based on your
select ions.

Compile and submit a job
Compile a job
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Click the

icon on the toolbar of the SQL Editor to locally compile an SQL script. If  a syntax or semantic error
occurs, the SQL Editor reports it .

Submit  a job

Click the

icon on the toolbar of the SQL Editor to submit  a compiled SQL script  to the queue of the project
that is specified by MaxCompute.

View job history
Open Job Explorer to view jobs that have been recently run in a specified project.

Not e   This list  only displays jobs that are submitted by the user ID of the current connection.
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Double-click a job to view the job details.

If  you have the Logview URL of a job, choose MaxComput e  > Open Logview from the menu to go to
the details page of the job.

Develop MapReduce and UDF programs
MaxCompute Studio allows you to develop MapReduce and Java UDF programs. For more information,
see Develop MapReduce and Develop UDFs.

Connect to the MaxCompute client
MaxCompute Studio is integrated with the latest  version of the MaxCompute client. You can also specify
the path of a locally installed MaxCompute client  on the configuration option page of MaxCompute
Studio. For more information, see Configure MaxCompute Studio.

On the Project  Explorer  tool window, right-click a project  and select  Open in Console. The
MaxComput e Console  window appears.

What to do next
After you are familiar with the functional interfaces and common application scenarios of MaxCompute
Studio, you can proceed to learn how to install MaxCompute Studio. For more information, see Tools
Installation and version history.
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This topic describes how to install the basic platform IntelliJ IDEA of MaxCompute Studio. MaxCompute
Studio is a plug-in that runs on IntelliJ IDEA.

Prerequisites
IntelliJ IDEA can be installed on the Windows, MacOS, and Linux operating systems. For more information
about requirements on hardware and operating systems, see Requirements for IntelliJ IDEA.

Procedure
1. Click IntelliJ IDEA to download IntelliJ IDEA based on your operating system, such as Windows,

MacOS, or Linux. The Windows operating system is used in the following example, and supports
IntelliJ IDEA 14.1.4 or later.

Not e   IntelliJ IDEA includes PyCharm Edit ion, Ult imate Edit ion, and free Community Edit ion.

2. After IntelliJ IDEA is downloaded, double-click the installer to start  the setup wizard, and click Next .

3. Specify the dest ination folder and click Next .

3.2. Tools Installation and version history
3.2.1. Install IntelliJ IDEA
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4. Select  your operating system and click Next .

5. Click Inst all .
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6. After IntelliJ IDEA is installed, click Finish.

What's next
Install MaxCompute Studio. For more information, see Install MaxCompute Studio.

This topic describes how to install MaxCompute Studio in IntelliJ IDEA.

Prerequisites
The environment in which you want to install MaxCompute Studio must meet the following
requirements:

The client  runs a Windows, macOS, or Linux operating system.

IntelliJ IDEA 2018.2.4 or later is installed on the client. The Ult imate, PyCharm, and free Community

3.2.2. Install MaxCompute Studio
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edit ions are supported.

Java Runtime Environment (JRE) 1.8 is installed. The latest  version of IntelliJ IDEA is bundled with JRE 1.8.
If  you are using IntelliJ IDEA of the latest  version, you do not need to separately install JRE 1.8

Java Development Kit  (JDK) 1.8 is installed. JDK 1.8 is required only if  you want to develop and debug
user-defined functions (UDFs) in Java.

Not e   MaxCompute Studio version 0.28.0 and later support  JDK 1.9. The earlier versions of
MaxCompute Studio support  only JDK 1.8.

Context
MaxCompute Studio is a plug-in of IntelliJ IDEA. You can use one of the following methods to install
MaxCompute Studio:

Install MaxCompute Studio online by using the plug-in library. We recommend that you use this
method.

Install MaxCompute Studio by using local f iles.

(Recommended) Install MaxCompute Studio online
MaxCompute Studio is available to all Internet users. You can install it  by using the official IntelliJ plug-in
library.

1. In the top navigation bar, choose File > Set t ings  .

2. In the left-side navigation pane of the Set t ings   dialog box, click Plugins.

3. In the Plugins dialog box, search for MaxCompute Studio.

4. Find MaxCompute Studio and click Inst all .
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5. Restart  IntelliJ IDEA to complete the installat ion.

Install MaxCompute Studio by using local files
You can download MaxCompute Studio to your computer and install it .

1. Go to the MaxCompute Studio page to download the plug-in package.

2. In the top navigation bar of IntelliJ IDEA, choose File > Set t ings   > Plugins.

3. In the Plugins dialog box, click Inst all plugin f rom disk  .

Tools and Downloads·MaxComput e 
St udio

MaxComput e

29 > Document  Version: 20210713

https://plugins.jetbrains.com/plugin/9193?spm=5176.doc44555.2.1.4hXBG1


4. In the Choose Plugin File dialog box, select  the downloaded plug-in file and click OK.
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5. Go to the Plugins dialog box and click OK.

6. After the installat ion is complete, click Rest art   in the message that prompts you to restart  IntelliJ
IDEA.
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What's next
After MaxCompute Studio is installed, you must configure connections to MaxCompute projects to use
the data and resources. For more information, see Manage project  connections.

This topic describes how to view and update the version of MaxCompute Studio.

View the version of MaxCompute Studio
1. In the top navigation bar, choose File > Set t ings  .

2. On the Set t ings   page, click MaxComput e St udio   in the left-side navigation pane.

3. On the MaxComput e St udio   page, view the current version and latest  version of MaxCompute
Studio in the Updat es Checking  sect ion.

Update the version of MaxCompute Studio
MaxCompute Studio automatically detects new versions. If  a new version is detected, you are
notified to update the version.

After you receive an update message, you can perform the following operations:

Install: In the update message, click Inst all . The new version is automatically downloaded and
installed. After the installat ion is complete, restart  IntelliJ IDEA.

Sett ings: In the update message, click Set t ings  . You can configure whether to automatically
detect  new versions.

3.2.3. View and update the version of
MaxCompute Studio
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If  the automatic update feature is disabled, you can perform the following steps to check the latest
version of MaxCompute Studio and install it :

i. In the top navigation bar, choose File > Set t ings  .

ii. On the Set t ings   page, click MaxComput e St udio   in the left-side navigation pane.

iii. On the MaxComput e St udio   page, view both the current version and latest  version of
MaxCompute Studio in the Updat es Checking  sect ion.

iv. Click Check new versions to check the latest  available version and install it .

Not e   You can also select  Aut omat ically checks f or new versions    to enable
automatic detect ion of new versions.

This topic describes how to configure MaxCompute Studio.

After MaxCompute Studio is installed, choose File > Set t ings...   in the main menu bar of IntelliJ IDEA to
go to the Set t ings   dialog box to configure MaxCompute Studio.

MaxCompute Studio configuration items
In the Set t ings   dialog box, click MaxComput e St udio   in the left-side navigation pane. The following
configuration items appear on the right side of the dialog box:

General Sett ings

Local met a st ore locat ion   : the storage path of the local metadatabase. This parameter
specifies the local path used to store the metadata of a MaxCompute project. By default ,
MaxCompute Studio stores the metadata in the .odps.studio\meta directory for users.

T able preview rows : the maximum number of rows that can be previewed in a table.

Local direct ory f or jobs  : the local path used to store the data of MaxCompute Studio jobs. By
default , MaxCompute Studio stores the data in the .odps.studio\job directory for users.

Pyt hon pat h t o resolve UDF   : the local installat ion path of Python.

Updates Checking

Aut omat ically checks f or new version   : specifies whether to enable MaxCompute Studio to
automatically check for a new version. By default , this parameter is selected to support  automatic
updates.

Check new versions: You can click this button to manually check for a new version. After you click
this button, the Inst all lat est  version    button appears if  a new version is available. You can click
the Inst all lat est  version    button to install the new version. After the new version is installed, you
must restart  IntelliJ IDEA.

SDK & Console configuration items
In the Set t ings   dialog box, choose MaxComput e St udio   > SDK & Console in the left-side navigation
pane.

The Inst alled Locat ion   parameter appears on the right side of the dialog box. This parameter
specifies the local installat ion path of the MaxCompute client. MaxCompute Studio automatically
detects the version of the MaxCompute client  installed in the path. If  no client  is found, an error
message is returned.

3.3. Configure MaxCompute Studio
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Not e   In MaxCompute Studio versions later than V2.6.1, you do not need to specify the path
because the latest  MaxCompute client  is installed by default . If  you need to use the MaxCompute
client  of a specific version, you can specify the path.

MaxCompute SQL configuration items
In the Set t ings   dialog box, choose MaxComput e St udio   > MaxComput e SQL  in the left-side
navigation pane.

The following configuration items appear on the right side of the dialog box:

Color and Annotator

You can select  Enable synt ax coloring  to enable the syntax highlighting feature.

Code Completion

You can select  Enable code complet ion  to enable the automatic code completion feature.

If  you select  Invoke code complet ion when you ent er a space  , the automatic code
completion feature is disabled when you enter a space.

Code Formatt ing

You can select  Enable code f ormat t ing    to enable the code formatt ing feature.

Script  Submit

If  you select  Show job det ail when script  submit t ed    , job details are displayed when you
submit  a script.

If  you select  Record sql hist ory when script  submit t ed    , the execution history of SQL
statements is recorded when you submit  a script.

If  you select  Show sql cost  conf irm dialog when script  submit t ed     , a message to confirm the
execution cost  of SQL statements appears when you submit  a script.

If  you select  Pin sql execut ion result  t ab by def ault     , the SQL Execution Result  tab is locked by
default .

Job Name:

If you select  use script  f ile name as def ault    , the name of the script  f ile is used as the job
name by default .

If  you select  input  job name when f irst  submit    , you must enter a job name the first  t ime you
submit  a job.

If  you select  input  job name f or every submit   , you must enter a job name each t ime you
submit  a job.

Compile | Submit

This sect ion provides the default  sett ings of global compiler parameters. You can separately
configure the parameters for each file in the toolbar of the SQL compiler:

Compiler mode

St at ement  Mode   : In this mode, the compiler compiles and submits each statement of an SQL
file as a unit .

Script  Mode : In this mode, the compiler compiles and submits an entire SQL file as a unit . This
mode enables the compiler and optimizer to optimize the execution plan and improve the
overall execution efficiency.
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Dat a t ype edit ion  

Legacy T ypeSyst em  : The original data type edit ion of MaxCompute is used.

MaxComput e T ypeSyst em   : The new data type edit ion introduced from MaxCompute V2.0 is
used.

Hive Compat ible T ypeSyst em   : The Hive-compatible data type edit ion introduced from
MaxCompute V2.0 is used.

Compiler

Def ault  : The default  compiler of MaxCompute Studio is used.

UseShort QueryAccelerat ion  : A compiler that can accelerate queries is used.

FallbackWhenFailed: A compiler that can run jobs again if  query acceleration fails is used.

MaxCompute Job configuration items
In the Set t ings   dialog box, choose MaxComput e St udio   > MaxComput e Job  in the left-side
navigation pane.

The following configuration items appear on the right side of the dialog box:

Maximum jobs shown in job explorer table list: the maximum number of jobs that can be displayed on
the Job Explorer page. Default  value: 1000.

Reset filter when switch MaxCompute project: If  you select  this parameter, the job configurations are
reset  when you switch between MaxCompute projects.

Cache history instance in local database: You can select  this parameter to cache historical instance
information in the local data warehouse.

Accounts configuration items
In the Set t ings   dialog box, choose MaxComput e St udio   > Account s  in the left-side navigation
pane.

You can perform the following operations to manage the accounts that are used to access
MaxCompute. For more information about accounts, see User authentication.

Not e   MaxCompute Studio uses the configured accounts to access MaxCompute projects and
run jobs.

Add an account

i. In the right-side navigation pane, choose +  > Aliyun Account  By AccessKey .

ii. In the Add MaxComput e Account   dialog box, configure the following parameters:

Account  Name : the display name of an account on MaxCompute Studio. Both Alibaba Cloud
accounts and RAM users can be added. For example, if  you add the Alibaba Cloud account  us
er_test@test.aliyun.com , set  this parameter to  user_test . If  you add the RAM user  user_ram
@xxxxx.onaliyun.com  that  belongs to the Alibaba Cloud account  user_test@test.aliyun.com ,
set  this parameter to  user_test:user_ram .

Using propert ies f ile  : specifies whether to read an AccessKey ID and an AccessKey secret
from the configuration file. If  you select  this parameter, you must make sure that the conf/od
ps_config.ini f ile is uploaded. For more information, see User authentication.

Tools and Downloads·MaxComput e 
St udio

MaxComput e

35 > Document  Version: 20210713

https://www.alibabacloud.com/help/doc-detail/27930.htm#t12094.html
https://www.alibabacloud.com/help/doc-detail/27930.htm#t12094.html


Using propert ies : specifies whether to manually enter an AccessKey ID and an AccessKey
secret. You must select  this parameter or Using propert ies f ile  .

Access Id: Enter the AccessKey ID of the Alibaba Cloud account or RAM user that you want
to add.

Access Key: Enter the AccessKey secret  of the Alibaba Cloud account or RAM user that you
want to add.

iii. Click OK. The added account is displayed in the account list  in the Set t ings   dialog box.

Remove an account

You can perform the following steps to remove an account from MaxCompute Studio. This operation
does not affect  the real Alibaba Cloud account or RAM user.

i. Select  the account that you want to remove from the account list .

ii. In the right-side navigation pane, click -.

iii. In the message that appears, click OK.

Modify the information of an account

i. Select  the account whose information you want to modify in the account list .

ii. In the right-side navigation pane, click the  icon.

iii. In the Edit  MaxComput e Account    dialog box, edit  the following account information:

Access Id: Enter a new AccessKey ID.

Access Key: Enter a new AccessKey secret.

iv. Click OK.

You can view information about your MaxCompute project  on MaxCompute Studio only after you
connect MaxCompute Studio to your project. The project  information includes tables, views, user-
defined functions (UDFs), and resources. This topic describes how to create and modify MaxCompute
project  connections.

Step 1: Create a MaxCompute Studio project
1. Start  IntelliJ IDEA. In the main menu bar, choose File > New > Project .

2. In the left-side navigation pane of the New Project  dialog box, click MaxComput e St udio  . Then,
click Next .

3.4. Manage project connections
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3. Specify Project  name  and click Finish.
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Not e   If  a project  is open, a dialog box appears and asks whether you want to open the
new project  in a new window or the current window. In this case, click T his Window .

Step 2: Connect to a MaxCompute project
1. In the main menu bar, choose View > T ool Windows  > Project  Explorer .

2. In the upper-left  corner, click the plus sign (+ ) and select  Add project  f rom accessId/Key  .
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3. In the Add MaxComput e project   dialog box, configure the parameters on the Connect ion  tab.

Not e

In the lower-left  corner, click the  icon to view online documentation.

If  a t imeout error occurs, click the Set t ing   tab and modify the following parameters:

sync one t able t imeout (s)   : the t imeout period for table synchronization.
Default  value: 5. Unit: seconds.

sync one f unct ion t imeout (s)    : the t imeout period for function
synchronization. Default  value: 30. Unit: seconds.

Use the configuration file to automatically configure the parameters.

Parameter Description

Propert ies File

The directory where the configuration file odps_config.ini of the
MaxCompute client (odpscmd) is saved. For more information, see
Install and configure the odpscmd client. The configuration file is
used to init ialize the settings of the Access Id  , Access Key,
Project  Name , and End Point  parameters.
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AK Account

The Alibaba Cloud account that is used to connect to the
MaxCompute project. You can click the plus sign (+ ) and select an
existing account on the Account s   page.

Not e   If no accounts exist, you must click the plus sign
(+ ) and select Aliyun Account  By AccessKey  to add an
account on the Account s   page. You can manually add an
account or use the configuration file to automatically add it.
For more information about the Accounts page, see Accounts
configuration items.

Parameter Description

Manually configure the parameters.

Parameter Description

Access Id
The AccessKey ID that is used to connect to the MaxCompute
project.

Access Key
The AccessKey secret that is used to connect to the MaxCompute
project.

Project  Name

The name of the MaxCompute project.

Not e   This parameter specifies the name of your
MaxCompute project rather than that of the DataWorks
workspace to which the project corresponds. Log on to the
MaxCompute console and view the name of your project and
the DataWorks workspace to which the project corresponds
on the Project  management   tab.

End Point The endpoint of the MaxCompute project.

4. Click OK. The Project  Explorer  page shows information about the MaxCompute project, including
the tables, views, UDFs, and resources.

Step 3: Modify the connection to a MaxCompute project
1. On the Project  Explorer  page, right-click the MaxCompute project  whose connection you want to

modify and select  Modif y project  propert ies   .
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2. In the Modif y MaxComput e project    dialog box, modify the configurations of the MaxCompute
project.

What's next
After the MaxCompute project  is connected, you can manage and view the data and resources of the
project. For more information, see Manage data and resources.

This topic describes how to use MaxCompute Studio to view tables, views, functions, and resources in
projects.

Prerequisites
A MaxCompute project  is connected. For more information, see Manage project  connections.

Context
In the Project  Explorer  tool window, you can view tables, views, functions, and resources in
MaxCompute projects that are connected.

Browse and update project data
1. Go to the MaxCompute Studio page. In the left-side navigation pane, click Project  Explorer  to

view your connected MaxCompute project.

3.5. Manage data and resources
3.5.1. Manage project data
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2. Click the drop-down arrow on the left  side of the T ables &  Views  , Funct ions , or Resources
node to view all tables, views, functions, or resources in the project.

Not e   To perform this operation, you must have the  DESC TABLE  permission on the
MaxCompute project.

3. In the toolbar, click the  icon to update the local metadata.

Not e   MaxCompute Studio downloads the metadata of MaxCompute projects to a local
device. When the metadata of a MaxCompute project  is updated, you must trigger a refresh to
reload the changed metadata to the local device.

View details about tables or views
1. In the T ables &  Views   node tree, click a table name to expand the node. You can then view the

columns and column types of the table.
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2. Right-click the table name and select  Show t able det ail   to view the table details. The table
details include the owner, size, column information, and schema of the table.

3. Right-click the table name and select  Find usages to query the scripts in which the table is used.

View function details
1. In the Funct ions  node tree, click the UserDef ined  node to view the functions that you have

created.
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Not e   The Built in  node under the Funct ions  node tree classifies the built-in functions of
the system. You can double-click a function to display the usage notes of the function. For
more information about the built-in functions, see Built in functions.

2. Double-click a function to display the code of the function.

View resource details
Expand the Resources node tree to view the created resources.

MaxCompute Studio allows you to import  local f iles in the CSV or TSV format to MaxCompute tables. It
also allows you to export  data from MaxCompute tables to local f iles. MaxCompute Studio uses
MaxCompute Tunnel to import  and export  data.

Prerequisites
MaxCompute Tunnel is configured for your project  in MaxCompute Studio. For more information, see
Install and configure the MaxCompute client.

The account has the permissions to manage tables in your MaxCompute project.

Import data
1. In the Project  Explorer  tool window, click the drop-down arrow on the left  side of T ables &

Views under your MaxCompute project. In the table list , right-click the table to which you want to
import  data and select  Import  dat a int o t able    .

3.5.2. Import and export table data
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2. In the Import ing dat a t o t able_name     dialog box, configure the parameters.

Input  File : the path of the local f ile to import.

File charset : the encoding format of the input file. Supported encoding formats include UT F-
8, UT F-16 , UT F-16BE , UT F-16LE , ISO-8859-1, US-ASCII, and GBK. The default  encoding
format is UT F-8 .

Column Separat or : the column delimiter. Supported column delimiters include Comma(','),
Space(' '), and T ab('\t ')  . The default  column delimiter is Comma(',').

Record Limit : the maximum number of data rows that can be imported.

Size(MB) Limit : the maximum size of data that can be imported. Unit: MB.

Error Record Limit : the maximum number of data rows that contain errors.

Include Column Header: specifies whether to import  the column header.
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3. Click OK to import  the data.

4. The Success message appears. This indicates that the data is imported. You can then view the
data in the table.

Export data
1. In the Project  Explorer  tool window, click the drop-down arrow on the left  side of T ables &

Views under your MaxCompute project. In the table list , right-click the table from which you want
to export  data and select  Export  dat a f rom t able    .

2. In the Export ing dat a f rom t able_name     dialog box, configure the parameters.

Out put  File  : the path of the local f ile that stores the output data.

File charset : the encoding format of the output file. Supported encoding formats include
UT F-8 , UT F-16 , UT F-16BE , UT F-16LE , ISO-8859-1, US-ASCII, and GBK. The default  encoding
format is UT F-8 .

Column Separat or : the column delimiter. Supported column delimiters include Comma(','),
Space(' '), and T ab('\t ')  . The default  column delimiter is Comma(',').
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Record Limit : the maximum number of data rows that can be exported.

Size(MB) Limit : the maximum size of data that can be exported. Unit: MB.

Error Record Limit : the maximum number of data rows that contain errors.

Include Column Header: specifies whether to export  the column header.

3. The Success message appears. This indicates that the data is exported. You can view the data in
the output file.

Project  Explorer in MaxCompute Studio provides a table schema editor that allows you to manage
tables in a visualized manner. This topic describes how to use Project  Explorer to create, modify, and
delete tables in a visualized manner.

Create a table
1. In the Project  Explorer  tool window, right-click T ables &  Views   under your MaxCompute project,

and select  Creat e new t able  .

2. In the Creat e New T able/View   dialog box, configure the parameters.

For more information about how to configure the parameters, see Table operations.

3.5.3. Manage tables in a visualized manner
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Not e

You cannot set  flags for tables that are created in a visualized manner. The system uses the
following flags by default:

 odps.sql.submit.mode=script 
 odps.sql.type.system.odps2=true 

3. Click Execut e . If  the SUCCESS message appears, the table is created.

Modify a table
1. In the Project  Explorer  tool window, click the drop-down arrow on the left  side of T ables &

Views under your MaxCompute project. In the table list , right-click the table that you want to
modify and select  Open t able edit or  .

2. In the Modif y T able   dialog box, modify the table.

You can add columns to the table and change the table name, table comments, table lifecycle,
column name, and column descript ion. For more information, see Table operations.

3. Click Execut e  to apply the modificat ions.
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Delete a table
1. In the Project  Explorer  tool window, click the drop-down arrow on the left  side of T ables &

Views under your MaxCompute project. In the table list , right-click the table that you want to
delete, and select  Drop t able f rom server  .

2. In the Conf irmat ion Required   message, click OK to delete the table.

Before you use MaxCompute Studio to develop SQL programs, you must create a MaxCompute script
module. This topic describes how to create a MaxCompute script  module.

Context
Create a MaxCompute script  module in one of the following scenarios:

If  no local script  f ile exists, use IntelliJ IDEA to create a module.

If  a local script  f ile exists, you do not need to create a module. Instead, open a module and use
MaxCompute Studio to edit  the script.

Create a module if no local script file exists
1. Start  IntelliJ IDEA. In the top navigation bar, choose File > New > Project .

2. In the left-side navigation pane of the New Project  dialog box, click MaxComput e St udio  . Then,
click Next .

3.6. Develop SQL procedure
3.6.1. Create a MaxCompute script module
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3. Specify the Project  name  parameter and click Finish.
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Not e

If a project  is opened, a dialog box appears and asks whether you want to open the new
project  in a new window or the current window. In this case, click T his Window .

Create a module if a local script file exists
If  a local script  f ile exists, you do not need to create a module. You need only to add a MaxCompute
connection configuration file to the exist ing module directory.

1. In the .\IdeaProjects\MaxCompute_Studio_Project_Name\scripts folder, create a MaxCompute
connection configuration file odps_config.ini and configure the following authentication
information. This authentication information is used to connect to MaxCompute.

# The name of the MaxCompute project.
project_name=xxxxxxxx
# The AccessKey ID of your Alibaba Cloud account.
access_id=xxxxxxxxxx
# The AccessKey secret of your Alibaba Cloud account.
access_key=xxxxxxxxx
# The endpoint of the region where your MaxCompute service is deployed.
end_point=xxxxxxxxx

2. Open IntelliJ IDEA. In the top menu bar, choose File > Open, and select  the .\IdeaProjects\MaxCom
pute_Studio_Project_Name\scripts folder. Then, select  the odps_config.ini f ile.
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Not e   MaxCompute Studio automatically searches for the odps_config.ini f ile in the
folder and captures the metadata on the MaxCompute server based on the configuration
information in the file. MaxCompute Studio then compiles all scripts in the folder.

This topic describes how to develop and submit  an SQL script  in MaxCompute Studio. The SQL script
development includes writ ing and running an SQL script.

Prerequisites
A MaxCompute project  connection is created. For more information, see Manage project  connections.

A MaxCompute Script  module is created. For more information, see Create a MaxCompute script
module.

Write an SQL script
1. In the Project  tool window, click a project  name, right-click script s , and then choose New >

MaxComput e SQL Script  .

3.6.2. Develop and submit an SQL script

MaxComput e Tools and Downloads·MaxComput e 
St udio

> Document  Version: 20210713 52

https://www.alibabacloud.com/help/doc-detail/50855.htm#task-2456405
https://www.alibabacloud.com/help/doc-detail/50898.htm#task-2460342


2. In the New MaxComput e SQL Script   dialog box, specify the required parameters and click OK.

Script  Name : the script  name.

MaxComput e Project  : the MaxCompute project  in which you want to write an SQL script. You
can click the +  button to create a MaxCompute project  connection. For more information, see
Manage project  connections.

3. Write an SQL script  in the compiler. For more information about the SQL syntax, see MaxCompute SQL
overview.
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Not e

You can configure cross-project  resource sharing. For example, you can bind a script  to
Project  A and grant access permissions on table1 in Project  B to the script.

MaxCompute Studio allows you to set  an SQL script  compiler. For more information, see
Overview.

Submit an SQL script
Before you submit  an SQL script, you must configure relevant sett ings as required. MaxCompute Studio
provides mult iple compiler features. You can set  these features in the toolbar at  the top of the
compiler. You can set  the following compilat ion parameters:

Compiler Mode:

St at ement  Mode   : In this mode, the compiler separates the SQL statements in the script  with
semicolons (  ; ), and commits the statements one by one to MaxCompute for execution.

Script  Mode : In this latest  development mode, the compiler submits a whole script  to
MaxCompute at  a t ime. We recommend that you use this mode because this mode improves the
overall execution efficiency.

Type System: You can set  this parameter to avoid compatibility issues related to SQL statements.
Valid values:

Legacy T ypeSyst em  : indicates the legacy type system of MaxCompute.

MaxComput e T ypeSyst em   : indicates the new type system introduced by MaxCompute V2.0.

Hive Compat ible T ypeSyst em   : indicates the type system in the Hive compatibility mode
introduced by MaxCompute V2.0.

Execution Mode:

Def ault  Version  : indicates a stable version.

MaxComput e Query Accelerat ion  : indicates the new MaxCompute query acceleration (MCQA)
feature.

Rerun When Accelerat ion Fails : reruns the task when the query acceleration fails.

1. In the toolbar or side bar, click the  icon to submit  an SQL script  to MaxCompute.
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Not e   If  a variable exists in the SQL script, such as ${bizdate} in the preceding figure, a
dialog box appears, which prompts you to enter the variable value.

2. Before the SQL job runs, IntelliJ IDEA reminds you of the est imated cost  of the SQL job. Confirm the
estimated cost  and click OK in the Conf irmat ion   message.

Not e

In the toolbar, click the  icon to update metadata that is used in the SQL script, such

as tables and user-defined functions (UDFs). This feature applies when MaxCompute
Studio cannot detect  the tables and functions that exist  in MaxCompute.

SQL scripts are compiled based on the metadata that you add in the Project  Explorer
window. If  no errors are detected, the scripts are submitted to MaxCompute for
execution.

Operational logs are generated during the SQL script  execution. If  SQL scripts are
executed in MaxCompute, the job details tab is opened. You can view the basic
information about the execution.

3. On the Result  tab, view the execution results.

If  mult iple statements are executed one by one, the execution result  for each statement is
displayed.

This topic describes how to develop a Java program by using MaxCompute Studio and describes related
directories.

3.7. Developing Java
3.7.1. Overview
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Procedure
Follow these steps to develop a Java program in MaxCompute Studio:

1. Create a MaxCompute Java module.

2. Develop a Java program based on one of the following topics:

Develop a UDF

Develop a MapReduce program

Develop Graph

Query unstructured data

3. Package the Java program, upload the JAR package, and register a function.

Module directory
MaxCompute Studio automatically creates a module after you create a MaxCompute Java module. The
module directory includes the following subdirectories:

examples: stores sample code. You can reference the sample code to develop a script  for unit
test ing.

src/main/java: stores source code for Java program development.

warehouse: stores schemas and data of tables and resources for MaxCompute projects.
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warehouse directory
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The warehouse directory stores the schemas and data of tables and resources for MaxCompute
projects. These tables and resources are used to execute user-defined functions (UDFs) or MapReduce
tasks.

The warehouse directory contains three levels of subdirectories. Level-1 subdirectories are named by
project  name. Level-2 subdirectories include _resources_ and _tables_. Each level-3 subdirectory
under _tables_ is named by a table name and contains the _schema_ and data files.

In a _schema_ file, configure the project  name, table name, and names and data types of columns.
Separate each pair of column name and data type with a colon (:). If  a part it ioned table is used, you
must specify part it ion key columns. In the preceding figure, wc_in1 is a non-part it ioned table, and wc
_in2 is a part it ioned table.

In a data file, table data is stored in the CSV format based on the following rules:

In special characters, only commas (,), double quotation marks ("), and line breaks (  \n  or  \r\n ) are
supported.

A comma (,) is used as a column delimiter.  \n  or  \r\n  is used as a row delimiter.

If  a value in a column contains special characters, enclose the value in a pair of double quotation
marks ("). For example, write  3,No  as  "3,No" .
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If  a value in a column contains double quotation marks ("), use a pair of double quotation marks (")
to escape each double quotation mark ("). For example, write  a"b"c  as  "a""b""c" .

 \N  indicates a NULL value. For a column of the STRING data type, write  \N  as  """\N""" .

Characters in the file are encoded in UTF-8.

MaxCompute Studio allows you to develop Java user-defined functions (UDFs), MapReduce programs,
and Graph programs. Before the development, you must create a MaxCompute Java module. This topic
describes how to create a MaxCompute Java module.

Prerequisites
A MaxCompute project  is connected. For more information, see Manage project  connections.

Procedure
1. Start  IntelliJ IDEA. In the top navigation bar, choose File > New > Module.

2. In the left-side navigation pane of the New Module dialog box, click MaxComput e Java .

3. Configure the directory of the Module SDK file and click Next .

4. Specify Module name and click Finish.

Result
After the preceding steps are complete, MaxCompute Studio automatically creates a Maven module
and completes the following act ions:

Introduces MaxCompute-related dependencies. For more information, see the POM file that contains
the dependencies.

Creates the examples folder to store sample code. For more information, see Module directory.

Creates the warehouse folder to store the data required for local debugging. For more information,
see warehouse directory.

What's next
After you create a MaxCompute Java module, you can develop Java programs. For more information, see
the following topics:

Develop a UDF

Develop a MapReduce program

Query unstructured data

Develop Graph

This topic describes how to develop a user-defined functions (UDF) in MaxCompute Studio. This
includes how to write and debug a UDF.

Prerequisites
Before you begin, make sure that you have completed the following operations:

Manage project  connections

3.7.2. Create a MaxCompute Java module

3.7.3. Develop a UDF
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Create a MaxCompute Java module

Context
You can follow the instruct ions in this topic to develop a UDF, or choose MaxComput e  > Creat e UDF
to directly create a UDF.

Write a UDF
1. In the Project  tool window, expand your MaxCompute Java module and choose src > main > java.

Then, right-click java and choose New > MaxComput e Java .

2. Specify Name, select  the UDF type, and press Enter.

Name: the name of the MaxCompute Java class. If  no package is created, enter
packagename.classname. The system automatically creates a package.

Select  the UDF type.

3. After you create a MaxCompute java class, develop a Java program in the editor.
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Perform a local run to debug the UDF
Perform a local run to test  the UDF and check whether the results meet your expectations.

1. Right-click the compiled Java script  and select  Run.

2. In the Run/Debug Conf igurat ions   dialog box, configure the runtime parameters.

MaxCompute project: the MaxCompute project  in which the UDF runs. To perform a local run,
select  local.

MaxCompute table: the name of the MaxCompute table in which the UDF runs.

Table columns: the columns in the MaxCompute table in which the UDF runs.

3. Click OK to run the UDF.

Not e

The system reads data from the specified table in warehouse as the input during the
local run. You can view the log output in the console.

The system downloads the table data from the specified MaxCompute project  to the w
arehouse directory. If  the data is already downloaded, the system does not perform this
step.

Perform unit testing to debug the UDF
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Refer to the unit  test ing examples in the examples directory and write your test  case.

What's next
After you write and debug a UDF, you must package, upload, and register UDF code. For more
information, see Package, upload, and register a Java program.

This topic describes how to use MaxCompute Studio to develop a MapReduce program. This includes
how to write, debug, package, upload, and run a MapReduce program.

Prerequisites
Before you begin, make sure that you have completed the following operations:

Manage project  connections

Create a MaxCompute Java module

Write a MapReduce program
1. In the Project  tool window, expand your MaxCompute Java module and choose src > main > java.

Then, right-click java and choose New > MaxComput e Java .

3.7.4. Develop a MapReduce program
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2. Specify Name, select  the Driver type, and then press Enter.

Name: the name of the MaxCompute Java class. If  no package is created, enter
packagename.classname. The system automatically creates a package.

Select  the Driver, Mapper, or Reducer type.

3. After you create a MaxCompute java class, develop a Java program in the editor.

The Java template is automatically filled with the framework code. You need only to configure the
input table, output table, and the Mapper and Reducer classes.
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Perform a local run to debug a MapReduce program
Perform a local run to test  your MapReduce program and check whether the results meet your
expectations.

1. Right-click the compiled Java script  and select  Run.

2. In the Run/Debug Conf igurat ions   dialog box, select  the name of the MaxCompute project  where
the MapReduce program runs.
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3. Click OK to run the UDF.

Not e

The system reads data from the specified table in warehouse as the input during the
local run. You can view the log output in the console.

The system downloads the table data from the specified MaxCompute project  to the w
arehouse directory. If  the data is already downloaded, the system does not perform this
step.

Perform unit testing to debug a MapReduce program
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Refer to the WordCount unit  test ing in the examples directory and write your test  case.

Package and upload a MapReduce program
After you debug a MapReduce program, compress the MapReduce program into a JAR package and
upload the package to the MaxCompute server as a resource. For more information, see Package, upload,
and register.

Run a MapReduce program
Use the MaxCompute client  to run a MapReduce program.

1. In the left-side navigation pane, click Project  Explorer .

2. Right-click the name of your project  and select  Open in Console.

3. In the Console tool window, run the following command to start  your MapReduce program.

For more commands, see JAR command.

jar-libjars wordcount.jar -classpath D:\odps\clt\wordcount.jar com.aliyun.odps.examples.mr.WordCou
nt wc_in wc_out;

This topic describes how to use MaxCompute Studio to develop Graph programs. This includes how to
write, debug, package, upload, and run Graph programs.

Prerequisites

3.7.5. Develop Graph
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A MaxCompute project  is connected. For more information, see Manage project  connections.

A MaxCompute Java module is created. For more information, see Create a MaxCompute Java module.

Write a Graph program
1. In the Project  tool window, expand your MaxCompute Java module and choose src > main > java.

Then, right-click java and choose New > MaxComput e Java .

2. Specify Name, select  GraphLoader or Vert ex , and then press Enter.

Name: the name of the MaxCompute Java class that you want to create. If  no package is
created, enter packagename.classname. The system automatically creates a package.

Select  GraphLoader or Vert ex  as the class type.

3. After the class is created, develop a Graph Java program in the editor.

Debug the Graph program
Locally run the Graph program and check whether the results meet your expectation.

1. Right-click the compiled Java script  and select  Run.

2. In the Run/Debug Conf igurat ions   dialog box, configure the runtime parameters.
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MaxComput e project  : the MaxCompute project  in which you want to run the Graph program.

Download Record limit : the maximum number of records that can be downloaded. Default
value: 100.

3. Click OK to run the UDF.

Not e

The system reads data from the specified table in warehouse as the input during the
local run. You can view the log output in the console.

The system downloads the table data from the specified MaxCompute project  to the w
arehouse directory. If  the data is already downloaded, the system does not perform this
step.

Package and upload the Graph program
After you debug the Graph program, compress the Graph program into a JAR package and upload the
package to the MaxCompute server as a resource. For more information, see Package, upload, and
register.

Run the Graph program
Run the Graph program on the MaxCompute client.

1. In the left-side navigation pane, click Project  Explorer .

2. Right-click the name of your project  and select  Open in Console.

3. In the Console tool window, run the following command to start  your Graph program.

For more commands, see JAR command.
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jar -libjars xxx.jar -classpath /Users/home/xxx.jar com.aliyun.odps.graph.examples.PageRank pagerank_
in pagerank_out;

MaxCompute V2.0 allows you to use external tables to access Object  Storage Service (OSS) and
Tablestore. MaxCompute Studio provides code templates to help you query unstructured data. This
topic describes how to use MaxCompute Studio to query unstructured data.

Prerequisites
A MaxCompute project  is connected. For more information, see Manage project  connections.

A MaxCompute Java module is created. For more information, see Create a MaxCompute Java module.

Write a StorageHandler, Extractor, or Outputer program
1. In the Project  tool window, expand your MaxCompute Java module and choose src > main > java.

Then, right-click java and choose New > MaxComput e Java .

2. Specify Name, select  Ext ract or  , St orageHandler , or Out put er  , and then press Enter.

Name: the name of the MaxCompute Java class that you want to create. If  no package is
created, enter packagename.classname. The system automatically creates a package.

Select  Ext ract or  , St orageHandler , or Out put er   as the class type.

3.7.6. Query unstructured data
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3. After the class is created, develop a Java program in the editor. The Java template is automatically
filled with framework code. You need only to compile the logic code based on your requirements.

Debug the Extractor or Outputer program
Write your test  cases to debug your Extractor or Outputer program based on the unit  test  examples in
the examples directory.

Package and upload the program
After you debug the program, compress the program into a JAR package and upload the package to
the MaxCompute server as a resource. For more information, see Package, upload, and register.

Query unstructured data
1. In the Project  tool window, right-click script s  under your MaxCompute project  and choose New >

MaxComput e SQL Script  .

2. Enter the name of an SQL script  in the Script  Name  field, select  a MaxCompute project  from the
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MaxComput e Project   drop-down list , and then click OK.

3. In the editor, enter the SQL statement that is used to create an external table and click the  icon.

4. Create a MaxCompute SQL script, enter the following query statement, and then click the  icon to

query data.

After a Java program is developed, you must package and publish it  to MaxCompute. This topic
describes how to package, upload, and register a Java program.

Context
To publish a Java program such as a UDF, MapReduce program, or Graph program to MaxCompute for
production use, you must package, upload, and register the Java program in sequence. You can use the
one-click publish function to complete these procedures. MaxCompute Studio runs the mvn clean
package command, uploads a JAR package, and registers a UDF in one stop.

Package the code
1. Right-click the compiled Java code and select  Deploy t o server... .

2. In the Package a jar and submit  resource  dialog box, set  the required parameters.

3.7.7. Package, upload, and register a Java
program
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MaxComput e project  : specifies the name of the MaxCompute project.

Resource name: specifies the name of the resource that you want to package.

Funct ion name : specifies the name of the function that you want to package.

Force updat e if  already exist s   : specifies whether to force the update when the resource or
function already exists.

3. Click OK to complete the packaging.

Not e   You can modify relevant sett ings in the pom.xml file based on your packaging
requirements.

Upload the JAR package
After the JAR package is prepared, you must upload it  to MaxCompute.

1. In the top navigation bar, choose MaxComput e  > Add Resource.

2. In the Add Resource dialog box, set  the required parameters and click OK.

MaxComput e project  : specifies the name of the MaxCompute project.

Resource f ile : specifies the path of the JAR package.

Resource name: specifies the name of the resource that you want to upload.

Force updat e if  already exist s   : specifies whether to force the update when the resource or
function already exists.

3. In the left-side navigation pane, click Project  Explorer .
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4. After the Java package is uploaded, you can view the resource under the Resources node of the
Project  Explorer  window.

Register the UDF
You must register the UDF before you can call it .

1. In the top navigation bar, click MaxComput e  and select  Creat e Funct ion  .

2. On the Creat e Funct ion   page, set  the following parameters and click OK.

MaxComput e project  : specifies the name of the project  to which you want to upload the UDF.

Funct ion name : specifies the name of the UDF.

Using resources: specifies the name of the JAR package on which the UDF depends.

Main class: specifies the main class of the JAR package.

Force updat e if  already exist s   : specifies whether to force the update when the resource or
function already exists.

3. In the left-side navigation pane, click Project  Explorer .

4. After the UDF is registered, you can view the UDF under the Funct ions  node of the Project
Explorer window.
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MaxCompute Studio allows you to develop Python programs, such as user defined functions (UDFs) and
MaxCompute SDK for Python (PyODPS) scripts, in IntelliJ IDEA. This topic describes how to configure a
Python development environment.

Install PyODPS
1. Install PyODPS. For more information, see Installation guide and limits.

2. Start  IntelliJ IDEA. In the top navigation bar, choose File > Set t ings  .

3. On the Set t ings   page, click MaxComput e St udio   in the left-side navigation pane.

4. Set  the Pyt hon pat h t o resolve UDF    parameter to the local path of the Python.exe file.

Install the Python plug-in
In the plug-in repository of IntelliJ IDEA, search for Python Community Edit ion and install the Python
plug-in.

1. In the top navigation bar of IntelliJ IDEA, choose File > Set t ings  .

2. On the Set t ings   page, click Plugins in the left-side navigation pane.

3. In the search box, enter Python Community Edit ion to search for the Python plug-in. Then, install
the Python plug-in.

3.8. Develop a Python program
3.8.1. Configure a Python development
environment
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Configure the Python dependency
After you configure the Python dependency for the MaxCompute script  module, you can develop
Python programs by using MaxCompute Studio.

1. In the top navigation bar, choose File > Project  St ruct ure   .

2. Add the Python SDK.

i. In the left-side navigation pane, click SDKs under Platform Sett ings.
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ii. Click the plus sign (+ ) at  the top and add the Python SDK.

iii. Click Apply.

3. Configure the Python dependency for the MaxCompute script  module.

i. In the left-side navigation pane, click Modules under Project  Sett ings.

ii. Click the plus sign (+ ) at  the top and add the dependency on the Python SDK for the
MaxCompute script  module.

iii. Click Apply.

MaxCompute Studio allows you to develop Python user defined functions (UDFs). This topic describes
how to develop, test, and publish a Python UDF.

Prerequisites

3.8.2. Develop a Python UDF
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The following operations are complete:

Manage project  connections

Configure a Python development environment

Develop a Python UDF
1. In the Project  sect ion, right-click script s  under the MaxCompute script  module and choose New >

MaxComput e Pyt hon  .

2. In the Creat e new MaxComput e pyt hon class    dialog box, enter a class name in the Name field,
select  pyt hon UDF  from the Kind drop-down list , and then click OK.

3. Write the UDF code in the code editor.

Test the Python UDF
After the UDF is developed, you must test  whether the UDF code works as expected. MaxCompute
Studio supports local runs for you to locally test  code. You can download some sample data from a
table to your local computer, run the code on the sample data, and debug the code.

1. Right-click the developed Python UDF and select  RUN.

2. In the Edit  conf igurat ion    dialog box, set  the parameters and click OK.
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MaxComput e project  : the MaxCompute project  that is used to run the UDF. For a local run,
select  local.

MaxComput e t able  : the name of the MaxCompute table that is used to run the UDF.

T able columns : the columns in the MaxCompute table that are used to run the UDF.

Download Record limit : the maximum number of records that can be downloaded from the
table. Default  value: 100.
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Not e

If the specified data is already downloaded, MaxCompute Studio does not download
the data again. To download the data again, run the tunnel command on the
MaxCompute client.

By default , 100 records are downloaded. To download more sample data, run the
tunnel command on the MaxCompute client  or use the table download feature of
MaxCompute Studio.

After the sample data is downloaded, you can view the data in the data file of the
table under the warehouse directory.

3. MaxCompute Studio obtains the sample data from the data file based on the columns you
specified and calls the UDF to locally run it  on the sample data.

Not e   Local runs are implemented by using the pyou script  that the MaxCompute SDK for
Python (PyODPS) provides. The command for start ing a local run is  pyou hello.Plus<data . After
you install PyODPS, you can run the corresponding command to check whether the pyou script
exists:

For Windows, run the  ${python}/../Scripts/pyou  command.

For macOS, run the  ${python}/../pyou  command.

4. View the output on the Console tab, check whether the UDF works as expected, and debug the
code if  required.

Publish the Python UDF
After the Python UDF is tested, you can publish it  to the production environment. For more information,
see Package, upload, and register a Java program.

This topic describes how to develop a MaxCompute SDK for Python (PyODPS) script.

Prerequisites

3.8.3. Develop a PyODPS script
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The Python development environment is configured. For more information, see Configure a Python
development environment.

Context
PyODPS supports basic operations on MaxCompute objects and allows you to use DataFrames. You can
use PyODPS to analyze data in MaxCompute.

Procedure
1. In the Project  sect ion, right-click script s  and choose New > MaxComput e Pyt hon  .

2. In the Creat e new MaxComput e pyt hon class    dialog box, enter a class name in the Name field,
select  PyODPS Script  from the Kind drop-down list , and then click OK.

3. Write the script  code in the code editor. When you create a PyODPS script, the  odps  and  o 
objects are automatically init ialized in the PyODPS script  template by using a PyODPS room.

When you develop a PyODPS script  in DataWorks, a room is automatically created. When you
develop a PyODPS script  in IntelliJ IDEA, you must create a room yourself. For more information, see
the PyODPS documentation.

3.9. Manage MaxCompute jobs
3.9.1. View jobs
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This topic describes how to use Job Explorer in MaxCompute Studio to view MaxCompute job instances
that you submitted. You can view the running status, type, and start  and stop t ime of job instances.

Open Job Explorer
To open Job Explorer, choose View > T ool Windows  > Job Explorer in the top navigation bar.

View all job instances in a project
Job Explorer allows you to query the list  of submitted jobs by status, user, date, and duration.
Examples:

If  you want to query the list  of submitted jobs by status, click St at us   and select  Failed to view the
jobs that failed within the last  24 hours.

If  you want to query the list  of submitted jobs by date, adjust  the sliders in the Dat e  drop-down list
to specify the t ime range of the jobs that you want to query.

Not e

By default , only the first  1,000 jobs that meet the condit ions are displayed. If  more than
1,000 jobs meet the condit ions, update the filtering condit ions.

You can click ID and Name and Submit t ed At    to sort  the jobs.

View a job queue
If  a job in the running state is wait ing for scheduling in a queue, click Queue Locat ion  to obtain the
location in the queue, and click Priorit y  to obtain the global priority.
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Not e   The job status and queue location on the Running Inst ances  tab are automatically
updated. After a job finishes, this information is removed from the list .

Save job logs
By default , Logview logs of a job are saved for seven days. If  you want to save some important Logview
logs for a longer period and view them in the future, you can save them locally.

1. Double-click a job in the list  to display the job details on the right.

2. Click Save in the toolbar to save the logs to your local host.

You can set  the path for saving the log file on the Set t ings   page of MaxCompute Studio.

This topic describes how to view job instance details in MaxCompute Studio.

View job instance details
MaxCompute Studio provides the following methods to view the details about a MaxCompute job
instance:

Use a Logview URL or a local offline Logview file to open the details about a job instance in read-only
mode.

Logview is a common method to view details about job instances. It  allows you to view the status of
tasks that are submitted by other users in other projects. You can view details about a job instance
by entering a valid Logview URL in MaxCompute Studio.

In the top menu bar of IntelliJ IDEA, choose MaxComput e  > Open Logview. In the Open job det ail
by logview dialog box, you can copy a valid Logview URL or export  a local offline Logview file.

In Job Explorer, double-click a MaxCompute job instance to view its details.

Job details view
The job details view page consists of a toolbar at  the top, a propert ies bar on the left  pane, and
details views on the right pane. The details view pane contains the following four views:

Execut ion view : displays the overall information for a job in the form of a directed acyclic graph
(DAG). You can view the dependencies and detailed execution plans for each subtask.

Det ails : displays the details about a job as a table. These details include the subtask list , worker list
for each subtask, amount of data that is processed by the workers, execution t ime, and job status.

Script : displays the SQL statement and parameter sett ings that are configured for a job that is
submitted.

Result : displays the execution results of a job.

The job details view page also provides the following information:

T imeline view : displays the execution t imeline of a job. This view provides mult iple filters and allows
you to view the t imeline based on different granularit ies.

Summary (JSON): displays the running details about a job in the JSON format.

Analysis: provides scatter charts, long tail distributions, and skewed data charts to show the
execution results of a job.

3.9.2. Job instance details
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Toolbar

 or : used to expand or collapse views on the left  and right panes. These icons allow you to

focus on a specific view.

: used to stop a job that is running. Only the project  owner or administrator has the permission to

stop running jobs.

: used to refresh details. The basic information such as status and quota of jobs is automatically

refreshed. However, the details views on the right-side pane are not automatically refreshed. If  you
want to view the up-to-date details, you must manually refresh them.

: used to copy Logviews.

: used to open job details in a browser. You can click this icon to generate a Logview URL and open

the URL in a browser.

: used to save job details as a local f ile.

: used to determine whether to enable the auto refresh feature. If  this feature

is enabled, MaxCompute Studio automatically refreshes all details about a running job on a
scheduled basis.

Basic information page
This page displays the basic information about a job, including its ID, owner, status, start  t ime and end
time, computing resource usage, input tables, and output tables. The basic information about a running
job is automatically refreshed on a scheduled basis.

You can double-click a table name to view the basic information about the table.

Execution view
The Execut ion view  is used to display the dependencies in the Job Scheduler Job, Job Scheduler Task,
and Operation layers. It  also provides a series of auxiliary tools such as job playback, progress view, and
heat map view. The Execution view is useful for troubleshooting.

The following items describe the meaning of the marked elements in the Execution view:

1. Click to go to another layer.

2. Zoom in and zoom out.

3. The dependency table.

4. The Job Scheduler task worker.

5. The thumbnail.

6. Click to display the job dependencies.

7. The dependencies in the Job Scheduler Task layer are displayed by default .

The Execution view displays job dependencies in three dimensions: Job Scheduler Job layer, Job
Scheduler Task layer, and Operation layer. Click the up arrow to switch between dimensions. By default ,
dependencies in the Job Scheduler Task layer are displayed.

Job Scheduler Job layer
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Click MaxComput e Job  to open the Job Scheduler Job layer. Workers in the Job Scheduler Job layer
include the name, start  t ime, and end t ime of each Job Scheduler task.

Job Scheduler Task layer

Double-click a Job Scheduler job worker to go to the Job Scheduler Task layer.

If  mult iple Job Scheduler jobs exist , the Job Scheduler Task layer of the last  Job Scheduler job is
opened by default . This layer displays the dependencies, input tables, output tables, and part it ions
of Job Scheduler tasks. When a job is completed, you can click the drop-down box in the toolbar to
switch between Progress Chart , Input  Heat  Chart   , Out put  Heat  Chart    , T askT ime Heat  Chart    ,
and Inst anceT ime Heat  Chart    . The progress chart  displays the task progress for the worker. The
heat chart  uses different colors to dist inguish between the heat sources of different workers.

A Job Scheduler task worker shows the following information:

Instance Count: expressed in the format of  a/b/c . This expression indicates the status of the
subtask instances at  a specific point  in t ime. The value of a represents the number of running
subtask instances, the value of b represents the number of completed subtask instances, and the
value of c represents the total number of subtask instances.

I/O Records: displays the numbers of input and output records at  a specific point  in t ime.

Percentage and orange progress bar: indicates the running status of the task. The percentage is
obtained based on the analysis of running subtask instances.

Line that connects subtasks: shows the number of output records. The arrow indicates the
direct ion of data flow.

Operation layer

Double-click a Job Scheduler task to open the Operation layer.

The Operation layer reveals how Job Scheduler tasks run internally. You can click a worker to view all
Operation layer information.

Not e   For non-SQL jobs, the system displays only jobs in the Job Scheduler Job and Job
Scheduler Task layers. Jobs in the Operation layer cannot be displayed.

Details view
The Details view is used to display details for SQL data manipulation language (DML) jobs. This view
displays the Job Scheduler task lists and compute worker lists of SQL DML jobs on the compute cluster.
Typically, each job is associated with one or more Job Scheduler jobs. Each Job Scheduler job is divided
into mult iple Job Scheduler tasks (stages), and each Job Scheduler task contains mult iple Job Scheduler
instances (workers). You can right-click a Job Scheduler instance to view the standard output, standard
errors, and debugging information.

The following items describe the meaning of the marked elements in the Details view:

1. The Job Scheduler job tab.

2. The Job Scheduler task list .

3. The details and compute worker list  of each Job Scheduler task.

Job playback
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MaxCompute Studio provides the job playback feature. You can view the execution history of a job
within 12 seconds in the same manner as playing a media file. This feature helps you understand the
running status of a MaxCompute job instance at  different t ime points. You can determine the order and
the amount of t ime to run subtasks and obtain the key path to run the job. This allows you to optimize
subtasks that run slowly.

Click the > icon to start  playing and click the icon again to pause. You can also drag the progress bar.

Not e   The playback feature only est imates the amount of I/O data at  a specific point  in t ime
based on the execution t ime to determine the job progress. This does not represent the actual
amount of I/O data at  the point  in t ime. Jobs in the Running state do not support  the playback
feature.

Timeline view
The Timeline view displays the details for the distributed execution of a job in a Gantt  chart. You can
adjust  the display granularity to show all compute workers in a Gantt  chart. Gantt  charts display the
time bott lenecks and long-tail workers of running jobs in a clear manner. You can also use mult iple
filters to select  the key path, the largest  data worker, and the worker that consumes the longest
amount of t ime during the job execution.

Analysis view
The Analysis view displays the long-tail workers and skewed data workers of jobs. It  also displays worker
scatter charts and column charts to help diagnose job execution bott lenecks. Scatter charts and
column charts allow you to click a worker to open the details view page and view the details about Job
Scheduler instances.

Result view
The Result  view displays information based on the job type and the parameters that are set  when you
submit  the job.

For SELECT statements that contain  odps.sql.select.output.format = HumanReadable , this view
displays the result  in the text  format.

For SELECT statements that do not specify the output format parameter, this view displays the result
in the table format.

For scripts that are run to export  data to a table, this view displays the name of the output table
and the link that redirects to the table details.

For abnormal jobs, this view displays the error details.

MaxCompute Studio is integrated with the MaxCompute client  program. You can open the client  on
MaxCompute Studio.

Configure the client installation path

3.10. Tool integration
3.10.1. Integrate with MaxCompute client
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1. MaxCompute Studio contains the MaxCompute client  of the latest  version, which is specified as the
default  client. You can also install the client  of another version by select ing Sett ings >
MaxCompute Studio > SDK & Console on IntelliJ IDEA and adding the client  program and path.
Console download address

2. After sett ing is successful, the MaxCompute client  version is displayed.
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Open the MaxCompute client
After the MaxCompute client  installat ion path is set, you can open the client  program on MaxCompute
Studio.

1. In the project  browsing list , right-click a project  to be opened and select  Open in Console.
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2. You can open mult iple client  programs by following the preceding steps.
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This topic provides the download addresses of the tools and plug-ins that may be required when you
use MaxCompute.

SDK: Maven users can search odps-sdk from the Maven repository to obtain different versions of the
SDK for Java.

MaxCompute client: Download the selected version of the MaxCompute client  from Git .

IntelliJ IDEA: Download IntelliJ IDEA and the MaxCompute Studio plug-in.

Java Database Connectivity (JDBC): MaxCompute provides an open source JDBC driver. You can
download the latest  JDBC driver from GitHub.

SDK for PHP: You can download the SDK for PHP from GitHub.

4.Downloads
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